Subject: [TOOLS-DEVELOPMENT] DOI processing for the RFC Editor

From: Robert Sparks <[email-masked]>
Date: Fri, 30 May 2014 15:28:34 -0500

Here is a first pass at a project SoW for automating working with DOIs 
for the RFC series.
(It is version -02 due to some early iteration with Heather and Alice).
One open question that I'm discussing with them is whether this will 
only update the bibxml files (the unnumbered collection consisting of 
the i-d and rfc references), or if it is also intended to put DOIs for 
other organizations documents when we can find them into bibxml2 through 
bibxml5.
What else does this need to say?

RjS

---

From: "Scott O. Bradner" <[email-masked]>
Date: Fri, 30 May 2014 18:28:29 -0400

this talks about a program to "extract the data from the existing series“

it would not be clear to me what this means - it could mean use the rfc-index,
it could mean processing all of the .txt files or it could mean something else

in the 4th bullet under deliverables it might be good to say in the description that the RFCs 
themselves will not be updated since they are not changed after being published 
(i.e,. be extra clear on this point)

the text mentions “ongoing maintenance” - does this refer to the assignment of DOIs for new
RFCs as they are produced or something else?  “ maintenance” seems a funny term for something
that gets assigned once & never changed

Scott

On May 30, 2014, at 4:28 PM, Robert Sparks <[email-masked]> wrote:

> Here is a first pass at a project SoW for automating working with DOIs for the RFC series.
> One open question that I'm discussing with them is whether this will only update the bibxml files (the unnumbered collection consisting of the i-d and rfc references), or if it is also intended to put DOIs for other organizations documents when we can find them into bibxml2 through bibxml5.
> <DOI_Processing-02.pdf><DOI_Processing-02.docx>_______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development