Subject: [TOOLS-DEVELOPMENT] DRAFT Agenda for Tools Call

From: Russ Housley <[email-masked]>
Date: Fri, 4 Apr 2014 13:20:20 -0400

Please review and comment.

The IESG is planning to make greater use of wikis.  Last Thursday, the IESG decided to encourage each directorate to use a wiki.  Given this greater dependence on wikis, I have moved the transition of wikis from tools.ietf.org to ietf.org out of the parking lot.

Russ

= = = = = = = = = 

Tools Call Agenda -- 15 April 2014 at 13:00 Eastern

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
   - Agenda Scheduling Development -- Robert
   - Agenda Display -- Robert
   - Improved test environment -- Henrik
   - IPR Tool improvements -- Robert
   - Liaison Tool improvements -- Robert
   - Transition to Django authorization model -- Robert
   - Sandbox Datatracker for WG chairs -- Robert

2. Community & Other Projects
   - Pre-MHonArc Messages from mbox files for Mail Search & Archive Tool -- AMS
   - IETF Website Makeover

3. RFC Services Projects
   - xml2rfc bug fixes -- Alice and Henrik
   - RSE Design Team -- Heather

4. Transition of Mission Critical Tools
   - Moving mail aliases to ietf.org and link them to datatracker database
   - Moving issue trackers and wikis for IETF WGs on ietf.org

5. Server Infrastructure
   - Automatic failover from Sunnyvale to Orlando -- AMS
   - Support from a Content Distribution Network -- AMS

6. Parking Lot
   - Currently empty
   
7. AOB

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 04 Apr 2014 20:40:27 +0200

On 2014-04-04 19:20 Russ Housley said the following:
> The IESG is planning to make greater use of wikis. Last Thursday, the
> IESG decided to encourage each directorate to use a wiki. Given this
> greater dependence on wikis, I have moved the transition of wikis
> from tools.ietf.org to ietf.org out of the parking lot.

Makes sense.  And I think we can take a first step for non-wg wikis without
diving into all the scripts that tie into the WG wikis.

No particular comments on the agenda, otherwise.

	Henrik

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development
>

---

From: Russ Housley <[email-masked]>
Date: Thu, 10 Apr 2014 11:34:23 -0400

1. Datatracker Projects

2. Community & Other Projects
   - Pre-MHonArc Messages from mbox files for Mail Search & Archive Tool -- AMS
   - Present a directory view of active, archived, and unknown I-Ds	-- AMS
   - IETF Website Makeover

3. RFC Services Projects

5. Server Infrastructure

6. Parking Lot
   - IMAP access to the email archives
   
7. AOB

---

From: Ray Pelletier <[email-masked]>
Date: Thu, 10 Apr 2014 12:35:21 -0400

Topic: Tools Cmte 
Date: Tuesday, April 15, 2014 
Time: 1:00 pm, Eastern Daylight Time (New York, GMT-04:00) 
Meeting Number: 967 883 620 
Meeting Password: Tools 

------------------------------------------------------- 
To join the online meeting (Now from mobile devices!) 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/j.php?MTID=mad0452eb93ee939c6b5d53fee9364496 
2. If requested, enter your name and email address. 
3. If a password is required, enter the meeting password: Tools 
4. Click "Join". 

To view in other time zones or languages, please click the link: 
https://workgreen.webex.com/workgreen/j.php?MTID=m61d170576856bd429b77f3feed009b29 

------------------------------------------------------- 
To join the audio conference only 
------------------------------------------------------- 
To receive a call back, provide your phone number when you join the meeting, or call the number below and enter the access code. 
Call-in toll-free number (US/Canada): 1-877-668-4490 
Call-in toll number (US/Canada): 1-408-792-6300 
Global call-in numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=272001492&tollFree=1 
Toll-free dialing restrictions: http://www.webex.com/pdf/tollfree_restrictions.pdf 

Access code:967 883 620 

------------------------------------------------------- 
For assistance 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/mc 
2. On the left navigation bar, click "Support". 

You can contact me at: 
[email-masked] 
1-703-652-9534 

To update this meeting to your calendar program (for example Microsoft Outlook), click this link: 
https://workgreen.webex.com/workgreen/j.php?MTID=ma0d901f75ac867163126a2eed38e32f9 

WebEx will automatically setup Meeting Manager for Windows the first time you join a meeting. To save time, you can setup prior to the meeting by clicking this link: 
https://workgreen.webex.com/workgreen/meetingcenter/mcsetup.php 

The playback of UCF (Universal Communications Format) rich media files requires appropriate players. To view this type of rich media files in the meeting, please check whether you have the players installed on your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php. 

Sign up for a free trial of WebEx 
http://www.webex.com/go/mcemfreetrial 

http://www.webex.com 

CCP:+14087926300x967883620# 

IMPORTANT NOTICE: This WebEx service includes a feature that allows audio and any documents and other materials exchanged or viewed during the session to be recorded. By joining this session, you automatically consent to such recordings. If you do not consent to the recording, discuss your concerns with the meeting host prior to the start of the recording or do not join the session. Please note that any such recordings may be subject to discovery in the event of litigation.

---

From: Robert Sparks <[email-masked]>
Date: Mon, 14 Apr 2014 10:42:08 -0500

To try to help keep the call within it's allotted length, here's a 
summary for several items.
Please skim before we get to the meeting.

>     - Expected Datatracker Releases -- Robert and Henrik

The imminent releases in the queue are:

* Agenda fixes
* IRTF RG Functionality
* Schema changes (ScheduledSession rename, expanding slug length limits 
to 16 chars, allowing Consensus DocEvents to return to "Unknown")

The other known upcoming releases are documented at
<http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan>

Recently completed releases can be seen at
<http://datatracker.ietf.org/release/>

>     - Agenda Scheduling Development -- Robert
The primary (and extensive) round of fixes are ready and next in the 
merge queue.
See 
<http://wiki.tools.ietf.org/tools/ietfdb/changeset/7561/personal/rjs/r7559-agenda>

Stephanie and I will go through an end-to-end simulation of setting up 
the schedule for IETF90 tomorrow.
>     - Agenda Display -- Robert
I have been gathering a list of the places that need to be fixed still 
(there aren't many).
Work on fixing them will start after the primary agenda fixes release.
>     - IPR Tool improvements -- Robert
Bids are due today.
>     - Liaison Tool improvements -- Robert
RFB sent - questions due Apr 21.
>     - Transition to Django authorization model -- Robert
Deployed today.
>     - Sandbox Datatracker for WG chairs -- Robert
Nothing done (at least by me). Will work with Alexa before the next 
tools call to build
out a plan for having a sandbox during the Sunday chair training session 
at IETF 90.
>     - Pre-MHonArc Messages from mbox files for Mail Search & Archive Tool -- AMS
The reload is expected to happen over the next weekend.
>     - Present a directory view of active, archived, and unknown I-Ds	-- AMS
The design team is working on incorporating the community comments.
We have a call tomorrow before this team's call. I'll provide a readout 
of that call when we talk.
One thing I expect we will need discuss is this current text:

"Key milestones and deliverables during the redesign process (e.g. site 
architecture, technology, wireframes, page design, content updates) 
should be identified in the proposal. These items will be reviewed and 
approved by a committee identified by the IETF."

What does "identified by the IETF." mean practically?
>     - IMAP access to the email archives
The mentoring program is ready for some lightweight tooling to assist 
with gathering mentor requests and doing matching.