Subject: [TOOLS-DEVELOPMENT] IETF website revamp SOW - 2014-02-05

From: Robert Sparks <[email-masked]>
Date: Tue, 11 Feb 2014 10:00:15 -0600

The web revamp design team has converged on the attached proposed 
statement of work for a redesign of the IETF website.
Please take a look and let us know what else needs to be said.

RjS

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 11 Feb 2014 17:07:16 -0500

a few minor comments & suggestions

one question - will there be access to the raw database?  (I. for one, would find that very helpful
for researching disclosure patterns)

Scott

On Feb 11, 2014, at 11:00 AM, Robert Sparks <[email-masked]> wrote:

> The web revamp design team has converged on the attached proposed statement of work for a redesign of the IETF website.
> <IETF-Website-SOW-20140205.doc>_______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Tue, 11 Feb 2014 16:11:05 -0600

(I think you grabbed a different thread to send the reply on than you 
meant to.)

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 11 Feb 2014 17:17:06 -0500

oops - I trust the intent was clear

Scott

On Feb 11, 2014, at 5:11 PM, Robert Sparks <[email-masked]> wrote:

> (I think you grabbed a different thread to send the reply on than you meant to.)
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 11 Feb 2014 16:30:19 -0600

>> a few minor comments & suggestions
To your comments:

You asked what "remove or better isolate artifacts from earlier 
implementations" means.
It means clean up the code, take fields out of the models, tuck things 
away in the forms,
clean up the data for things that are no longer used, and clean up the data
all as the document later describes. I don't think this will cause 
people bidding any confusion.

You suggested saying "schema" instead of "models". Models is a specific 
technology term in Django.
The schema in the underlying database is defined by the models. Again, 
people bidding will be
familiar with coding in django, and it will confuse them less to say 
models than it would to say schema.

>> for researching disclosure patterns)
Yes - this is all in the datatracker database. You can get a copy of 
that now.

The instructions are at 
<http://trac.tools.ietf.org/tools/ietfdb/wiki/SprintDatabase>
Note in particular how you can download a snapshot and load it into a 
database on your local machine.
If you haven't done so already, I highly encourage picking up enough 
Django knowledge to use Django
queries to poke through the database instead of diving straight into the 
SQL.

> _______________________________________________

---

From: Robert Sparks <[email-masked]>
Date: Tue, 11 Feb 2014 16:31:07 -0600

Yep - I got it - I sent the reply primarily to make it easier to find 
any responses easier with searches later.

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 11 Feb 2014 17:36:24 -0500

On Feb 11, 2014, at 5:30 PM, Robert Sparks <[email-masked]> wrote:

> You asked what "remove or better isolate artifacts from earlier implementations" means.
> It means clean up the code, take fields out of the models, tuck things away in the forms,
> all as the document later describes. I don't think this will cause people bidding any confusion.

the wording is puzzling to me and does not convey a clear message as to what it means
e.g. “isolate artifacts” does not sing to me

> 
> You suggested saying "schema" instead of "models". Models is a specific technology term in Django.
> The schema in the underlying database is defined by the models. Again, people bidding will be
> familiar with coding in django, and it will confuse them less to say models than it would to say schema.

ok - makes sense

> Yes - this is all in the datatracker database. You can get a copy of that now.
> 
> The instructions are at <http://trac.tools.ietf.org/tools/ietfdb/wiki/SprintDatabase>
> Note in particular how you can download a snapshot and load it into a database on your local machine.
> If you haven't done so already, I highly encourage picking up enough Django knowledge to use Django
> queries to poke through the database instead of diving straight into the SQL.

great - thanks

can a pointer to that be put on the new search web page?

https://datatracker.ietf.org/ipr/search/

tnx

Scott

---

From: Robert Sparks <[email-masked]>
Date: Tue, 11 Feb 2014 16:52:31 -0600

> https://datatracker.ietf.org/ipr/search/
I don't think that's the right thing to do.

I suspect, instead, you're really wanting is something that gives you a 
dump of just the ipr disclosure related data, possibly filtered on some 
criteria (you may not want all the attachments all the time for 
example). Creating a page that gives datatracker json dumps, and 
providing a link to _that_ page would be better. We could spend some 
time in London talking about what the criteria you might give such a 
page might look like?

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 11 Feb 2014 17:56:56 -0500

On Feb 11, 2014, at 5:52 PM, Robert Sparks <[email-masked]> wrote:

> I suspect, instead, you're really wanting is something that gives you a dump of just the ipr disclosure related data, possibly filtered on some criteria (you may not want all the attachments all the time for example). Creating a page that gives datatracker json dumps, and providing a link to _that_ page would be better. We could spend some time in London talking about what the criteria you might give such a page might look like?

yes, that would be better - yes, lets talk

Scott

---

From: Russ Housley <[email-masked]>
Date: Wed, 12 Feb 2014 22:16:11 -0500

I have not seen any comments on this SOW yet.  Is it ready for community review?

Russ

---

From: "Scott O. Bradner" <[email-masked]>
Date: Wed, 12 Feb 2014 22:20:47 -0500

it is kinda fuzzy but maybe that is what is needed - I. for one, have no idea what
a new IETF site should look like (other than a LOT less busy  than the current one)
and giving lis level of non guidance lets people think out of the box

i.e., I think it is more of a RFI than a SOW but KN

Scott

---

From: Russ Housley <[email-masked]>
Date: Wed, 12 Feb 2014 22:24:03 -0500

As Robert said on the call, we want a designer to bid.

Russ

---

From: "Scott O. Bradner" <[email-masked]>
Date: Wed, 12 Feb 2014 22:29:13 -0500

yup

Scott

---

From: Bob Hinden <[email-masked]>
Date: Thu, 13 Feb 2014 10:31:53 +0200

I think we are going to need to find some we like, talk to them about what we are thinking about, and then send the RFP.  It may not work to just send folks email and/or putting the RFP on the IETF web site.

Bob

---

From: Ray Pelletier <[email-masked]>
Date: Fri, 28 Feb 2014 06:48:52 -0500

All;

Any further comments?

The next steps are:

1.  TMC Approves an SOW for Community Review
2.  TMC informs the IAOC of same 5 March and Next Steps
3.  SOW goes out for community review 10 Mar - 24 Mar
4.  TMC updates SOW 
5.  RFP goes out with updated SOW 7 Apr
6.  TMC reviews proposals and makes recommendations to IAOC 21 May
7.  IAOC does/does not award contract 29 May

Ray