Subject: [TOOLS-DEVELOPMENT] Tools Call Tuesday 11 Feb: WebEx Details

From: Ray Pelletier <[email-masked]>
Date: Sat, 8 Feb 2014 06:23:45 -0500

All

A reminder of our next call, Tuesday 11 Feb at 1:00 PM EST, GMT -05.  WebEx details below.

Tools Call Agenda -- 11 February 2014 at 13:00 Eastern

1. Datatracker Projects
  - Expected Datatracker Releases -- Robert and Henrik
  - Agenda Scheduling Development -- Robert
  - Agenda Display -- Robert
  - IPR Tool improvements -- Robert
  - Liaison Tool improvements -- Robert

2. Community & Other Projects
  - Mail Search & Archive Tool -- AMS
  - IETF Website Makeover

3. RFC Services Projects
  - xml2rfc bug fixes -- Alice and Henrik
  - RSE Design Team -- Heather

4. Transition of Mission Critical Tools
  - idnits transition is not complete -- AMS
  - Internet-Draft dependencies

5. Parking Lot: These cannot progress until after the London Codesprint
  - Moving mail aliases to ietf.org and link them to datatracker database
  - Moving issue trackers and wikis for IETF WGs on ietf.org
  - Transition to Django authorization model

6. AOB

Ray

Topic: Tools Cmte 
Date: Tuesday, February 11, 2014 
Time: 1:00 pm, Eastern Standard Time (New York, GMT-05:00) 
Meeting Number: 968 910 467 
Meeting Password: Tools 

------------------------------------------------------- 
To join the online meeting (Now from mobile devices!) 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/j.php?MTID=m142414d4d38a39f8382ae3c425c4b206 
2. If requested, enter your name and email address. 
3. If a password is required, enter the meeting password: Tools 
4. Click "Join". 

To view in other time zones or languages, please click the link: 
https://workgreen.webex.com/workgreen/j.php?MTID=mc03a01f87f16b913a382f7dda87a2cce 

------------------------------------------------------- 
To join the audio conference only 
------------------------------------------------------- 
To receive a call back, provide your phone number when you join the meeting, or call the number below and enter the access code. 
Call-in toll-free number (US/Canada): 1-877-668-4490 
Call-in toll number (US/Canada): 1-408-792-6300 
Global call-in numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=268358572&tollFree=1 
Toll-free dialing restrictions: http://www.webex.com/pdf/tollfree_restrictions.pdf 

Access code:968 910 467 

------------------------------------------------------- 
For assistance 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/mc 
2. On the left navigation bar, click "Support". 

You can contact me at: 
[email-masked] 
1-703-652-9534 

To add this meeting to your calendar program (for example Microsoft Outlook), click this link: 
https://workgreen.webex.com/workgreen/j.php?MTID=m518d2313970f9ce4442df23d896b7878 

The playback of UCF (Universal Communications Format) rich media files requires appropriate players. To view this type of rich media files in the meeting, please check whether you have the players installed on your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php. 

Sign up for a free trial of WebEx 
http://www.webex.com/go/mcemfreetrial 

http://www.webex.com 

CCP:+14087926300x968910467# 

IMPORTANT NOTICE: This WebEx service includes a feature that allows audio and any documents and other materials exchanged or viewed during the session to be recorded. By joining this session, you automatically consent to such recordings. If you do not consent to the recording, discuss your concerns with the meeting host prior to the start of the recording or do not join the session. Please note that any such recordings may be subject to discovery in the event of litigation.

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Tue, 11 Feb 2014 10:56:57 -0800

Attendees:
Alexa
Alice
Heather
Henrik
Jari
Matt
Ray
Robert
Russ
Ryan
Scott
Tony

1. Datatracker Projects
  - Expected Datatracker Releases -- Robert and Henrik
5.0.0 released last week; running stable, and successful migration to Jengo.  Will have a 5.0.1 release shortly.
5.0.1 will be mostly a bug fix release; Robert doesn't anticipate another release before the London code sprint, but if Henrik gets more testing tools ready, he may push a second release.

  - Agenda Scheduling Development -- Robert
Robert has a prototype of a port of the remaining fixes to the 5.0.0 branch, that appear to be sane.  Porting the functionality forward took about a day and a half.  Porting tests forward will take much more time, and we don't want to deploy until the tests are in place.  Target to have it integrated and deployed halfway between IETF 89 and 90.  Will work with Stephanie to do a dummy run at that time.

  - Agenda Display -- Robert
There are ongoing problems, related to having fragile code and fixes that are not deployed yet.  There are also some changes in requirements in displaying things like IAB sessions.  There are some fixes fo rthat that will go in with the 5.0.1 release.  Are there any other outstanding issues that we are not tracking?  (Russ) don't know how to request an IAB session.  (RjS) we don't have an easy way to do that, nor to navigate to the place where you would provide the meeting agenda and slides.  The page is there, but you have to manually enter the URL until the Secretariat tool is modified to show you the IAB sessions.  (Russ) when you do the deployment halfway between IETF 89 and 90, providing cheat sheets to the IAB chair would be helpful.  (RjS) do we still have the "yes yes yes yes" problem?  (Henrik) not sure, need to check.  (RjS) This is something we can address during the code sprint. (Tony) there are also some javascript errors on that page, using Safari.  (RjS) *Tony to send Robert a description of those errors.*

  - IPR Tool improvements -- Robert
The SoW is out for community review.  There may be a possible change to one of the things in that SoW.  The community review period ends 17 February.  Alexa will post her input.  The SoW right now adds functionality in keeping a record of the email conversations that the Secretariat has with submitters or if they are going to IPR owners given third party submissions.  The way the SoW is written now, the Secretariat is the only one that can see those email messages, and the change proposed is for everyone to see those.  Is this only for IPR statements already posted?  The most back and forth is in the third party disclosures, and probably don't want the message from the third party disclosure to be public until posted.  All the IPR disclosures come in the same queue.  Alexa follows up on it after it has been posted.  (SOB) This needs to be made clear to those making the disclosure. (RjS) This doesn't match Robert's model or understanding of what happened, and doesn't match what is in the SoW.  (Alexa) we only hold up posting when information is missing.  There are many third party disclosures on the website that are currently unverified.  If someone goes to update an existing disclosure, we do not update that disclosure until we hear back from the person who originally submitted the disclosure.  (RjS) In that case, the email record gathered during that verification phase would not be captured.  (Ray) Is there a change required here?  (RjS) Yes.

  - Liaison Tool improvements -- Robert
SoW has been sent in and is ready to go for community review.  Henrik has not had a chance to look at the model changes.  (Russ) Would like to get this out for community comment by next week.

2. Community & Other Projects
  - Mail Search & Archive Tool -- AMS
We are deployed.  There are a few conversation we need to have about this.  We have been running stable, we have the archive header about to go in production, we have had a non-trivial number of WG chairs point out that the mail archive tool does not go as far back as we have inbox records.  This was a consequence of the decision to use monarc's filters on the inbox.  RjS proposed we start taking these as tickets and over time, go list by list and re-import the older messages and find a way to run spam assassin on them or something.  (SOB) this includes a lot out of ietf discuss and more.  (Russ) is there a date where we know monarc was kicked in?  (RjS) Per list, yes, but not across lists.  (SOB) the missing mail is not consistent - some is missing from before monarc was used, some is not.  (RjS) This is a messy problem.  The mess will likely be different from list to list. (SOB) the inbox files are still being maintained.  (Russ) Who is going to do this?  (RjS) been thinking to ask AMS to help with this, with Ryan taking the load per list.  (Ryan) Agree that taking it one list at a time is the right move, and will need to do that in order to estimate level of effort and whether this can be automated.  *Ryan will get one list done before London so we can talk about it further there.*

  - IETF Website Makeover
We have an SoW to review, sent to the Tools Team earlier today.  (Russ) Please review this in the next week or so.  Would like to get an RFP out fairly soon.  (RjS) It is an SoW written to attract a designer, contains constraints on what the design proposed would meet, but is not attempting to do that design.

3. RFC Services Projects
  - xml2rfc bug fixes -- Alice and Henrik
(Alice) We are using 2.4.5 for every doc that coems in, and right now we do not have any bugs blocking.  We were using the web for a while when the CLI wasn't working and encountered some bugs.  Will try to recreate those.  (Henrik) the blank screen problem does occur if you get exception when you have asked for file output.  If you ask for on-screen output, you don't get the blank screen.  It is a web interface issue.  It does show that there are still input that will give exceptions, so there is still work to do, but much less than before.  (Russ) When exceptions are thrown, is that logged?  (Henrik) hasn't checked that, but he is receiving reports from individuals that he can reproduce.  

  - RSE Design Team -- Heather
HF is concerned about the requirements draft for HTML - Joe Hildebrand has been busy; HF is taking over the editorial pen.  It does look like we will have SVG, PDF->HTML, v2 vocabulary and v3 vocabulary in a good state for community education.  The last thing that will be needed is the SoW that pulls all this together to say "we are looking for tool(s) that create these things (final XML file, HTML, PDF, TXT output), using this vocabulary (v3), checks for these profiles (SVG).  HF will create that SoW and have the Design Team review it before taking it to the Tools team.  Also have a -00 draft being circulated among the RSOC and i18n program prior to posting by Friday, 14 February.

4. Transition of Mission Critical Tools
  - idnits transition is not complete -- AMS
With the deployment of 5.0.1 we will have a transition of idnits.  (Russ) this means we should not talk about this next call.  Robert will bring this back up if something goes sideways.

  - Internet-Draft dependencies
We have the "what this doc depends on and what it references and what references this doc" deployed.  Has been deployed since shortly after Vancouver.  During code sprint in London, Robert will take away the link to the old pages.  That leaves us with the ned to replace the "per working group drafts" dependencies.  Robert has a prototype of that working, using old generation tools and feeding it from the datatracker.  So, proof of concept that we can get there.  Between now and London will try to turn that prototype into code.  Right now, we only like from www.ietf.org.  It might be interesting to get Henrik to look at the logs to see if anyone is following them.  Is anyone using this in recent history?  *Henrik and Robert to talk about this offline.*  Expect to have something to deploy after London.

A lot of the blocking is not blocking on code sprint, but blocking on conversations between Henrik and Glen.  Glen will not be in London.  Glen would like the Tools Team to be aware that Matt will be taking over a number of the duties that Glen was doing for the IETF.  Matt will be directing this project from the AMS side going forward, and progress is expected after London.  Encouraging a short conversation before London to get this kicked off.  (Henrik) would be useful to browse through all the glue code with Glen.  It will be much easier to do in person; need another approach if they cannot sit down together.  Would like to get the new data tracker test features in place before he spends more effort on this.  If that priority is incorrect, let him know.  (Glen)  We can do some kind of screen share after London, and will be at Toronto and Honolulu.  *Matt and Glen has the action to ping Henrik about this after London.* 

6. AOB
(Henrik) Understand that the cutoff day for the BoF has shifted?  (Alexa) They were changed before the last meeting.  There were a few more dates that shifted as well to try and make more deadlines finish on Fridays.  (Henrik) No one told the data tracker about this, so the actual submission dates have _not_ changed.  It is a configuration option, and *Ryan must change it in the local config file*.  We need to change the current value for first and second cut-off days from 12 to 15 (to be verified offline).  (Robert) For the secretariat to easily make this change, we need to add an interface to the database.  Direct access to the config file is not recommended.  While we are doing that, we might make it a property of "meeting".  *Robert to enter a ticket to track this feature request*.

---

From: Robert Sparks <[email-masked]>
Date: Tue, 11 Feb 2014 13:43:40 -0600

>
> (Tony) there are also some javascript errors on that page, using Safari.
> (RjS) *Tony to sen d Robert a description of those errors.* 
Was this Tony or Scott? (I thought it was Scott - my apologies if I was 
hearing the wrong voice).

RjS

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Tue, 11 Feb 2014 11:48:36 -0800

On 2/11/14 11:43 AM, Robert Sparks wrote:
> Was this Tony or Scott? (I thought it was Scott - my apologies if I
> was hearing the wrong voice).

At least according to WebEx, Tony's name was listed as the one making
the sounds.

-Heather

---

From: Tony Hansen <[email-masked]>
Date: Tue, 11 Feb 2014 15:17:15 -0500

> At least according to WebEx, Tony's name was listed as the one making 

'twas me and it's been done