Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 14 Jan 2014

From: Russ Housley <[email-masked]>
Date: Fri, 10 Jan 2014 15:23:10 -0500

Tools Call Agenda -- 14 January 2014 at 13:00 Eastern

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
   - Shim Layer Removal Work Orders (being developed by IOLA)
   - Agenda Scheduling Development (being developed by Sandalman)
   - IPR Tool improvements -- Robert
   - Liaison Tool improvements -- Robert
   - Transition from Django 1.2 -- Robert and Henrik
   - Transition to Django authorization model -- Robert and Henrik

2. Community & Other Projects
   - Mail Search & Archive Tool -- AMS
   - Making IETF Website more friendly to mobile devices

3. RFC Services Projects
   - xml2rfc bug fixes -- Alice and Henrik
   - RSE Design Team

4. Transition of Mission Critical Tools
   - Moving mail aliases to ietf.org and link them to datatracker database
   - Moving issue trackers and wikis for IETF WGs on ietf.org
   - Internet-Draft dependencies

5. AOB

---

From: Robert Sparks <[email-masked]>
Date: Fri, 10 Jan 2014 16:01:23 -0600

Inline

> 4. Transition of Mission Critical Tools
We should spend a few moments on idnits here
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Jari Arkko <[email-masked]>
Date: Mon, 13 Jan 2014 08:33:23 +0100

This is once again difficult time for me. Some comments inline though:

>   - Agenda Scheduling Development (being developed by Sandalman)

From my perspective the tool has been a significant improvement. I'd like to understand what the ongoing/remaining work is, is it the more automatic schedule-generation?

>   - Making IETF Website more friendly to mobile devices

So we have an overall web redesign project that should tackle this as well. Is the above that project or something different?
>   - Moving mail aliases to ietf.org and link them to data tracker database

This is important.

>   - Moving issue trackers and wikis for IETF WGs on ietf.org

This too.

>   - Internet-Draft dependencies

Jari

---

From: Russ Housley <[email-masked]>
Date: Mon, 13 Jan 2014 09:15:43 -0500

> From my perspective the tool has been a significant improvement. I'd like to understand what the ongoing/remaining work is, is it the more automatic schedule-generation?

I hope those will be covered tomorrow.

> So we have an overall web redesign project that should tackle this as well. Is the above that project or something different?

They are the same.  The mobile device was the first thing identified, and it has grown.  I'll update my agenda item wording.

>>  - Internet-Draft dependencies

Robert tells me that we need to talk about idnits too.

Russ

---

From: Robert Sparks <[email-masked]>
Date: Mon, 13 Jan 2014 10:43:47 -0600

On 1/13/14, 8:15 AM, Russ Housley wrote:
> Jari:
>
>> This is once again difficult time for me.
Do we need to try a different baseline time?
>> Some comments inline though:
>>
Yes.
Here's a summary now so we can focus on questions tomorrow.

As we discussed in Vancouver, we have accepted the automatic schedule 
generating code, but are not going to deploy it in its current form. We 
will use it as a base for research into ways to make it more useful.

We have accepted a set of tests that automate exercising the javascript 
parts of this code (using the Selenium framework under Django 1.2). 
Creating these automated tests has already had high payback in the form 
of correcting bugs discovered in the javascript code as the tests were 
being developed. Trunk is in the process of moving to Django 1.6, which 
has a _much_ richer integration with Selenium. I am planning for the 
tools team to port these tests into the updated framework rather than 
merging them directly.

Michael is currently addressing a set of bugs and feature requests 
identified while scheduling the Vancouver meeting. These include
* Improving how conflicts both to and from a group are displayed
* Improving navigation between multiple sessions for a given group
* Explicitly tracking the resources (projectors, meetecho, etc.) needed 
for a session
* Including the need for specific people (such as ADs) to be present in 
conflict resolution
* Addressing minor UI issues
This work should be checked in this week. We will need to work out 
timing on deploying these. We will bring them in as quickly as we can, 
but we are going to avoid the kind of disruption we had in the 
meeting/agenda apps that we experienced before Vancouver.

---

From: Jari Arkko <[email-masked]>
Date: Mon, 13 Jan 2014 18:36:09 +0100

> I hope those will be covered tomorrow.

Yes. So my question was whether there is some point where additional work on automation will come at a higher cost than the benefit that Stephanie gets from automation. I'm sure we need to do some more work, but there will be a point where we're done.

> They are the same.  The mobile device was the first thing identified, and it has grown.  

Ok, good.

Jari