Subject: Re: [TOOLS-DEVELOPMENT] suggestion for dependencies page

From: Robert Sparks <[email-masked]>
Date: Tue, 14 Jan 2014 13:15:01 -0600

On 1/14/14, 12:45 PM, Alice Russo wrote:
> Hi Robert,
>
> Suggest defining the "(???)".
> Seems to be for Status under Referred-To Document.
> Not sure what it is for Type.
<snip/>
>
> example:
> http://www.fenron.net/~fenner/ietf/deps/index.cgi?dep=draft-ietf-json-rfc4627bis 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?dep=draft-ietf-json-rfc4627bis>
Ah - that's Bill's old tool. These new views we were talking about are 
at the next two links to the right of where you found that one.
(look for References and Referred By). The newer implementation doesn't 
use the question marks - ??? won't appear on the new pages
  - what they were trying to convey got encoded into the reference type.

You'll see some difference between documents Bill's old tool identifies 
and what the new tool identifies - there are heuristics involved.
The new tool uses a stronger set of heuristics refined by Bill and 
Henrik and should have fewer false positives.

RjS

>
> ------------------------------------------------------------------------
>
> Documents that depend on: draft-ietf-json-rfc4627bis
>
>
> Referring Document 	Referred-To Document 	Type
> draft-lhotka-netmod-yang-json-02 (active) 	draft-ietf-json-rfc4627bis 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=draft-ietf-json-rfc4627bis> 
> (???) 	normative (???)
> draft-vanderstok-core-comi-02 (active) 	draft-ietf-json-rfc4627bis 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=draft-ietf-json-rfc4627bis> 
> (???) 	normative (???)
> draft-bierman-netconf-restconf-03 (active) 	draft-ietf-json-rfc4627bis 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=draft-ietf-json-rfc4627bis> 
> (???) 	normative (???)
> draft-bierman-netconf-efficiency-extensions-00 (active) 
> draft-ietf-json-rfc4627bis 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=draft-ietf-json-rfc4627bis> 
> (???) 	normative (???)
> draft-ietf-jose-json-web-signature-19 (active) 
> draft-ietf-json-rfc4627bis 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=draft-ietf-json-rfc4627bis> 
> (???) 	normative (???)
> draft-bierman-netconf-yang-patch-00 (active) 
> draft-ietf-json-rfc4627bis 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=draft-ietf-json-rfc4627bis> 
> (???) 	normative (???)
>
>
>
> Documents that are depended on by: draft-ietf-json-rfc4627bis
>
> Referring Document 	Referred-To Document 	Type
> draft-ietf-json-rfc4627bis-10 (???) 	bcp14 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=bcp14> 
> normative
> draft-ietf-json-rfc4627bis-10 (???) 	rfc0020 (ASCII format for network 
> interchange) 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=rfc0020> 
> (Unknown) 	normative (???)
> draft-ietf-json-rfc4627bis-10 (???) 	rfc20 (ASCII format for network 
> interchange) 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=rfc20> 
> (Unknown) 	normative (???)
> draft-ietf-json-rfc4627bis-10 (???) 	rfc2119 (Key words for use in 
> RFCs to Indicate Requirement Levels) 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=rfc2119> 
> (Best Current Practice) 	normative
> draft-ietf-json-rfc4627bis-10 (???) 	rfc5234 (Augmented BNF for Syntax 
> Specifications: ABNF) 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=rfc5234> 
> (Internet Standard) 	normative (???)
> draft-ietf-json-rfc4627bis-10 (???) 	std68 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=std68> 
> normative
> draft-ietf-json-rfc4627bis-10 (???) 	rfc4627 (The application/json 
> Media Type for JavaScript Object Notation (JSON)) 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=rfc4627> 
> (Informational) 	informative
> draft-ietf-json-rfc4627bis-10 (???) 	bcp78 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=bcp78> 	unknown
> draft-ietf-json-rfc4627bis-10 (???) 	bcp79 
> <http://www.fenron.net/%7Efenner/ietf/deps/index.cgi?doc=bcp79> 	unknown
>
>
>

---

From: Alice Russo <[email-masked]>
Date: Wed, 15 Jan 2014 11:56:18 -0800

Robert,
OK; thanks for the pointer.

Suggestion for the table on http://datatracker.ietf.org/doc/help/relationships/reference/
-- update the descriptions to quote or paraphrase the IESG statement (http://www.ietf.org/iesg/statement/normative-informative.html). For example:

"Normative references specify documents that must be read to understand or implement the technology in the new RFC, or whose technology must be present for the technology in the new RFC to work."

"An informative reference [...] provides additional information. For example, [it] might provide background or historical information. Informative references are not required to implement the technology in the RFC." 

Thanks,
Alice

On Jan 14, 2014, at 11:15 AM, Robert Sparks wrote:

> Ah - that's Bill's old tool. These new views we were talking about are at the next two links to the right of where you found that one.
> (look for References and Referred By). The newer implementation doesn't use the question marks - ??? won't appear on the new pages
> You'll see some difference between documents Bill's old tool identifies and what the new tool identifies - there are heuristics involved.
> The new tool uses a stronger set of heuristics refined by Bill and Henrik and should have fewer false positives.
> 
> RjS
>