Subject: [TOOLS-DEVELOPMENT] Tools Agenda & WebEx Details

From: Ray Pelletier <[email-masked]>
Date: Mon, 9 Dec 2013 15:14:59 -0500

All

We will have the monthly Tools Call at 11:00 AM EST, GMT -05 Tuesday 10 December, followed by the TMC call.

Draft Agenda:

1. Datatracker Projects
  - Expected Datatracker Releases -- Robert and Henrik
  - Agenda Scheduling Development (being developed by Sandalman)
  - Shim Layer Removal Work Orders (being developed by IOLA)
  - Liaison Tool improvements -- Robert
  - IPR Tool improvements -- Robert
  - Transition to Django authorization model -- Robert and Henrik
  - Transition from Django 1.2 -- Robert and Henrik

2. Community & Other Projects
  - Mail Search & Archive Tool -- AMS
  - IAOC & Trust Website Makeover -- AMS
  - Making IETF Website more friendly to mobile devices

3. RFC Services Projects
  - xml2rfc bug fixes -- Alice and Henrik
  - RSE Design Team
  - Requirements for stats & graphs tools

4. Transition of Mission Critical Tools
  - Moving mail aliases to ietf.org and link them to datatracker database
  - Moving issue trackers and wikis for IETF WGs on ietf.org
  - Internet-Draft dependencies

5. AOB

Ray

Topic: Tools Cmte 
Date: Tuesday, December 10, 2013 
Time: 1:00 pm, Eastern Standard Time (New York, GMT-05:00) 
Meeting Number: 963 376 474 
Meeting Password: Tools 

------------------------------------------------------- 
To join the online meeting (Now from mobile devices!) 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/j.php?ED=265355597&UID=0&PW=NNmVjZmIxMzA4&RT=MiMxMQ%3D%3D 
2. If requested, enter your name and email address. 
3. If a password is required, enter the meeting password: Tools 
4. Click "Join". 

To view in other time zones or languages, please click the link: 
https://workgreen.webex.com/workgreen/j.php?ED=265355597&UID=0&PW=NNmVjZmIxMzA4&ORT=MiMxMQ%3D%3D 

------------------------------------------------------- 
To join the audio conference only 
------------------------------------------------------- 
To receive a call back, provide your phone number when you join the meeting, or call the number below and enter the access code. 
Call-in toll-free number (US/Canada): 1-877-668-4490 
Call-in toll number (US/Canada): 1-408-792-6300 
Global call-in numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=265355597&tollFree=1 
Toll-free dialing restrictions: http://www.webex.com/pdf/tollfree_restrictions.pdf 

Access code:963 376 474 

------------------------------------------------------- 
For assistance 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/mc 
2. On the left navigation bar, click "Support". 

You can contact me at: 
[email-masked] 
1-703-652-9534 

To add this meeting to your calendar program (for example Microsoft Outlook), click this link: 
https://workgreen.webex.com/workgreen/j.php?ED=265355597&UID=0&ICS=MI&LD=1&RD=2&ST=1&SHA2=gwfUuDyPCQHQT7z/M7ZW3RFbfNPJGamvRSqjmu2UD1E=&RT=MiMxMQ%3D%3D 

The playback of UCF (Universal Communications Format) rich media files requires appropriate players. To view this type of rich media files in the meeting, please check whether you have the players installed on your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php. 

Sign up for a free trial of WebEx 
http://www.webex.com/go/mcemfreetrial 

http://www.webex.com 

CCP:+14087926300x963376474# 

IMPORTANT NOTICE: This WebEx service includes a feature that allows audio and any documents and other materials exchanged or viewed during the session to be recorded. By joining this session, you automatically consent to such recordings. If you do not consent to the recording, discuss your concerns with the meeting host prior to the start of the recording or do not join the session. Please note that any such recordings may be subject to discovery in the event of litigation.

---

From: Ray Pelletier <[email-masked]>
Date: Mon, 9 Dec 2013 15:41:13 -0500

CORRECTION

Call is at 1:00 PM EST, GMT -05 -not- 11:00 AM EST

Ray

On Dec 9, 2013, at 3:14 PM, Ray Pelletier <[email-masked]> wrote:

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Jari Arkko <[email-masked]>
Date: Tue, 10 Dec 2013 13:25:30 +0200

Unfortunately, it is yet another the day where I can not make the call. I know there has been many on this call series. I am meeting with people who are only available tonight at the same time as our call is.

You may have noticed that I'm far less involved on the tools side than Russ has been. I'm doing that in part knowingly, because I know you all know exactly what to do and the firefighting that I need to do is elsewhere; the tools efforts are in good hands. Please tell me if I'm ignoring tools too much and need to be more involved. And thank you all for working so hard on tools!

Jari

---

From: Ray Pelletier <[email-masked]>
Date: Tue, 10 Dec 2013 07:07:31 -0500

Jari
What we miss and need are your interest in and skills capturing data to analyze how the processes are working, especially as we now have a Datatracker capturing the life cycle of the IETF's technical work. We may need additional tools, perhaps additional data elements to provide meaning. I know there is increasing demand for the Chair to be engaged in the important efforts in Internet governance on top of the full time job overseeing and managing the technical work of the IETF.  Perhaps you can find a way to bring others together to look into this area and provide the TMC with meaningful direction and SOWs. 

Ray

> On Dec 10, 2013, at 6:25 AM, Jari Arkko <[email-masked]> wrote:
>

---

From: Ray Pelletier <[email-masked]>
Date: Tue, 10 Dec 2013 14:49:27 -0500

Tools Call Agenda -- 10 December 2013 at 13:00 Eastern

Attendees

Alice
Alexa
Bob
Glen
Heather
Henrik
Karen
Robert 
Russ
Ray
Scott

1. Datatracker Projects

	Henrik - will try to merge latest shim later in the next 5 days; will then do some minor bug releases; then Django one time merge at latest 22 Dec; following that a merger release of the Agenda code, no date yet

	Robert - Henrik doing a release in next 5 days, then 2 days later bug fixes; then Django upgrade; Ryan needs to track, esp the Django release

	Robert - going to finish handoff of some code this year; adding tests over the jabber scripts; fixing bugs we’ve identified; expect have majority of that in place this year; bug fix scale in next year; merging in when they’re ready, rather than rush schedule; scheduling work for London can go forward although there may be some bug fixes; meeting slot requests are stable; automatic part will not be used for London, will be taken in but not used.

	Henrik - expect merge and release will be more than a couple of hours; will need some adjustments 

	Henrik - pretty much done; 
	Robert - left is polish not substantial

  - Liaison Tool improvements -- Robert
	Robert - not made progress on SOW yet, except research; by mid-January

  - IPR Tool improvements -- Robert
	Robert - SOW is ready to go
	Ray - ready for Request for Bid to IOLA, Yaco, and AMS
	Go to community for feedback?
	Robert - massive improvement to maintenance and Secretariat; remainder to community are tickets requested by the community

  - Transition to Django authorization model -- Robert and Henrik
	Robert - on hold till Django transition; 
	Henrik - need assurance from Secretariat re: impacts; probably February; Henrik and Ryan

  - Transition from Django 1.2 -- Robert and Henrik
	Targeting 22 Dec; probably ver 1.6

2. Community & Other Projects
  - Mail Search & Archive Tool -- AMS
	Ryan - picked a URL; setting site up and taking final index build; ready on Monday
	Russ - when announce
	Robert - parallel with Mhonarc; deploy slowly?; recommend Jari send mail to Chairs; then after that surge; send to rest of community later

  - IAOC & Trust Website Makeover -- AMS
	Alexa - finished, live; taking comments for minor improvements

  - Making IETF Website more friendly to mobile devices
	Alexa - website design team call next week

3. RFC Services Projects
  - xml2rfc bug fixes -- Alice and Henrik
	Henrik - new release prepared, being held; would prefer to release
	Alice - Jim wants hold for page breaking
	Henrik - will release today
	Heather - might be able to start the 6 month timer to cutover on 1 Jan
	Russ - joint message from RSE and IETF Chair recommended

  - RSE Design Team
	Heather - working on vocabulary for DTD; need to lock it down; HTML requirements are fairly solid; still reviewing PDF requirements; accessibility requirements impact on what we are requiring; Do all have to be accessible, or one?; Govt, picking one may be fine for the moment;
W3C Guidelines - plain text is missing tags; useful seminars on scientific publications; support there for XML as a canonical format

	Russ - Design Team completion?
	Heather - XML DTD, vocabulary this year; Hoffman to finish in January
					Requirements for document formats; Hildebrand draft - more the end of January
	Robert - V2, not input to SOW
				V3, Paul working on Definition, would be input into an SOW

	Henrik - not obvious changes for Authors are going to be major or not?  

	Heather - some significant changes for Authors;

	Robert - no concrete examples; some significant changes in the structure as to the input format; but may not survive design team

	Henrik - will need a tool to convert in both directions; whichever tool is built to handle XML to Target Formats is not a design team issue.

	Robert - V3 doc is defining the XML output; Hildebrand version to get to output formats

	Ray - one or more SOWs in Q1 2014; Heather agrees

  - Requirements for stats & graphs tools
	Heather - expecting part time programmer to work on	

4. Transition of Mission Critical Tools
  - Moving mail aliases to ietf.org and link them to datatracker database
	Henrik - ready to generate one of 2 files that are needed; a little more coding to do; a little deal, first part done at Code Sprint; need one more day.

  - Moving issue trackers and wikis for IETF WGs on ietf.org
	Henrik - haven’t talked to Glen about it yet.; After Mail Alias; will require a bit more coordination with this than Mail Search.

  - Internet-Draft dependencies
	Robert - At last Sprint code done for most; will working on bug fixes; Henrik working on one bit; mid to late January to finish normative and informative references; 
	Alice - able to track clusters; but why useful for authors?

5. AOB

	CoLo 
		Alexa - ticket because someone dropped from mail list; reverse DNS some folks unsubscribed from lists; people not notified they were dropped; Will send out a note to the community
		Glen - Mailman not able to send mail to notify people they were dropped