Subject: [TOOLS-DEVELOPMENT] Tools Call 10 Sept AGENDA & WebEx

From: Ray Pelletier <[email-masked]>
Date: Wed, 4 Sep 2013 20:20:44 -0400

All;

Tools Call Tuesday 10 September at 1:00 EDT, GMT -04

Agenda:

ools Call Agenda -- 10 September 2013 at 13:00 Eastern

1. Datatracker Projects
  - Expected Datatracker Releases -- Robert and Henrik
  - Agenda Scheduling Development -- Sandalman
  - Shim Layer Removal Work Order -- IOLA

2. Community & Other Projects
  - NomCom Tool Deployment Status -- Yaco
  - Mail Search & Archive Tool -- AMS
  - IAOC & Trust Website Makeover -- AMS

3. RFC Services Projects
  - xml2rfc bug fixes -- Alice and Henrik
  - RSE Design Team
  - Improve rfc-editor.org website
  - Stats & graphs tools

4. Transition of Mission Critical Tools
  - Moving mail aliases to ietf.org and link them to datatracker database
  - Issue trackers and wikis for IETF WGs on ietf.org
  - Internet-Draft dependencies

5. AOB

Ray
Begin forwarded message:

> From: Ray Pelletier <[email-masked]>
> Date: September 4, 2013 8:14:45 PM EDT
> To: [email-masked]
> Subject: (Forward to attendees) Meeting invitation: Tools Cmte
> Reply-To: [email-masked]
> 
> 
> **** You can forward this email invitation to attendees **** 
> 
> Hello , 
> 
> Ray Pelletier invites you to attend this online meeting. 
> 
> Topic: Tools Cmte 
> Date: Tuesday, September 10, 2013 
> Time: 1:00 pm, Eastern Daylight Time (New York, GMT-04:00) 
> Meeting Number: 966 519 527 
> Meeting Password: Tools 
> 
> 
> ------------------------------------------------------- 
> To join the online meeting (Now from mobile devices!) 
> ------------------------------------------------------- 
> 1. Go to https://workgreen.webex.com/workgreen/j.php?ED=210802817&UID=0&PW=NNTVlOGFlMjE2&RT=MiMxMQ%3D%3D 
> 2. If requested, enter your name and email address. 
> 3. If a password is required, enter the meeting password: Tools 
> 4. Click "Join". 
> 
> To view in other time zones or languages, please click the link: 
> https://workgreen.webex.com/workgreen/j.php?ED=210802817&UID=0&PW=NNTVlOGFlMjE2&ORT=MiMxMQ%3D%3D 
> 
> ------------------------------------------------------- 
> To join the audio conference only 
> ------------------------------------------------------- 
> To receive a call back, provide your phone number when you join the meeting, or call the number below and enter the access code. 
> Call-in toll-free number (US/Canada): 1-877-668-4490 
> Call-in toll number (US/Canada): 1-408-792-6300 
> Global call-in numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=210802817&tollFree=1 
> Toll-free dialing restrictions: http://www.webex.com/pdf/tollfree_restrictions.pdf 
> 
> Access code:966 519 527 
> 
> ------------------------------------------------------- 
> For assistance 
> ------------------------------------------------------- 
> 1. Go to https://workgreen.webex.com/workgreen/mc 
> 2. On the left navigation bar, click "Support". 
> 
> You can contact me at: 
> [email-masked] 
> 1-703-652-9534 
> 
> To add this meeting to your calendar program (for example Microsoft Outlook), click this link: 
> https://workgreen.webex.com/workgreen/j.php?ED=210802817&UID=0&ICS=MI&LD=1&RD=2&ST=1&SHA2=uhytybo4Zz/ibjzTQK4n9PgRqe/EKVSI7pc8pzBP4Yo=&RT=MiMxMQ%3D%3D 
> 
> The playback of UCF (Universal Communications Format) rich media files requires appropriate players. To view this type of rich media files in the meeting, please check whether you have the players installed on your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php. 
> 
> Sign up for a free trial of WebEx 
> http://www.webex.com/go/mcemfreetrial 
> 
> http://www.webex.com 
> 
> CCP:+14087926300x966519527# 
> 
> IMPORTANT NOTICE: This WebEx service includes a feature that allows audio and any documents and other materials exchanged or viewed during the session to be recorded. By joining this session, you automatically consent to such recordings. If you do not consent to the recording, discuss your concerns with the meeting host prior to the start of the recording or do not join the session. Please note that any such recordings may be subject to discovery in the event of litigation.

---

From: Jari Arkko <[email-masked]>
Date: Mon, 9 Sep 2013 22:27:45 +0800

Folks,

Unfortunately, I need to skip this call, as I'm touring China this week, and while I plan to attend some IETF calls this week, I cannot stay up every night. This call would be my time 1-2AM. Please send materials & do take notes. If there's anything where you need my input, jabber/e-mail me beforehand!

Jari

On Sep 5, 2013, at 8:20 AM, Ray Pelletier <[email-masked]> wrote:

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Ray Pelletier <[email-masked]>
Date: Tue, 10 Sep 2013 14:14:37 -0400

Tools Call 10 Sep 13

Attendees
Russ
Ray
Alexa
Scott
Robert
Alice
Ryan
Tony
Henrik
Karen
Glen

1. Datatracker Projects
  - Expected Datatracker releases - Robert & Henrik
	Just released 4.71
	Henrik - minor fixes, then Agenda tools merge end of month

	Robert - do we need advance warnings before the release
				Secretariat tools stopped working; Do we prioritize Secretariat tool fix over Mail tool?

	Ryan - prioritize secretariat tools transition, left is to modify apache authentication, and change links and breadcrumbs. Probably done in a couple days

	Robert - libraries got moved around as part of cleanup.  Broken for a small period of time after release

  - Agenda Scheduling Development -- Sandalman
	Robert - thorough review of version 3 of tool; consistency issues to be fixed; different versions of libraries; Michael building out a new branch for a merge about 18 September.  Michael expects to have auto-schedule part done for Vancouver meeting.

  - Shim Layer Removal WO 1 -- IOLA
	Some code released yesterday
	Robert - still have several parts to go; ietf work flows tree to go; iesg tree and liaison tree as well; still work to go
	Henrik - IOLA still had a few hours left; might not cover the work; and will need a second WO; Unknown whether to complete all by year's end.

2. Community & Other Projects
  - NomCom Tool Development -- Yaco
	Henrik - released and Allison working with it; Henrik awaiting any possible requests for help.  In production for some time.

  - Mail Search & Archive Tool -- AMS
	Robert - Ryan been focusing on finishing the import; last round being done; and will reach a "good enough" point and declare victory.  5 Bugs that need to be taken care of before testers; likely in October for testers.  Do have the ability to move aside and not display.
	Ryan - there's an Admin interface where you can see things not otherwise available

  - IAOC & Trust Website Makeover -- AMS
	Alexa - IAOC is essentially complete; trust almost done and needs some input from Ray, then can be wrapped up pretty quickly.  Done before end of September.
Needs additional content, explanatory material, minor fixes.

 - IETF Website
	Alexa - discussions between Jari and Greg Wood to upgrade substantially with site development in 2014.  A project plan and timeline developed but no budget associate with it.

3. RFC Services Projects
  - XML2RFC Bug Fixes
	V2 - RFC Production center usage. 
	Henrik is fixing bugs, figuring one week or so.
	Alice - yes all the bugs on the list for Henrik; still using V1 when needed

  - RSE Design Team
	When will there be a recommendation from Team?
	Robert - something ready to discuss in Vancouver; a BOF Slot request by Heather?

	[Stepped out]

  - Stats & graphs tools
	Alice - condensing and automating some of the reporting being done

4. Transition of Mission Critical Tools
  - Moving mail aliases to ietf.org and link them to datatracker database
	Russ - server move first.
	Glen - Colo facility doing last part of install Friday; new IETF server early next week; will be discussing cutover plans with I* in the next couple weeks

  - Issue trackers and wikis for IETF WGs on ietf.org
	Henrik - needs a bit more work; there are scripts that need to be re-written and put on the ietf server; will sort over with Glen in Vancouver

  - Internet-Draft dependencies
	Henrik - sounds like Bill is unavailable; will check and if so, will find someone else.

5.  AOB

	Robert - Secretariat Issue re: IPR declaration updating; Used django admin.
	I'm concerned with the state of this branch, need to move re-write up the priority list.
	Robert and Alexa to draft SOW for IDIQ bid.

	Robert - move authorization level to use django authorization as opposed to using Apache authorization.  On Henrik's list behind several others.  Need sooner rather than later.  

	Henrik - Coding is limited to a few lines, so not outside contractor work.

	Robert - need time to move off of django version to higher release.  
	Henrik - 10 - 20 hours
	SOW by Robert for IDIQ contractor