Subject: [TOOLS-DEVELOPMENT] Tools Call Tuesday 16 July

From: Ray Pelletier <[email-masked]>
Date: Mon, 15 Jul 2013 09:11:37 -0400

All

A reminder of the Tools Call Tuesday at 1:00 PM EDT, GMT -04.  WebEx details below.  There will be a TMC call immediately following.

Tools Call Agenda 

1. Datatracker Projects
  - Back End Development -- IOLA
  - Agenda Scheduling Development -- Sandalman
  - Shim Layer Removal WO 1 -- IOLA
  - Merges -- Henrik

2. Community & Other Projects
  - NomCom Tool Development -- Yaco
  - Mail Search & Archive Tool -- AMS
  - IAOC & Trust Website Makeover -- AMS

3. RFC Services Projects
  - xml2rfc Specification for RPC Format Requirements
  - xml2rfc Specification for Enhancements
  - Improve rfc-editor.org website
  - Stats & graphs tools

4. Transition of Mission Critical Tools
  - Process Document -- Russ and Alexa
  - Moving mail aliases to ietf.org and link them to datatracker database
  - Issue trackers and wikis for IETF WGs on ietf.org
  - Internet-Draft dependencies

5. AOB

Ray

Topic: Tools Cmte 
Date: Tuesday, July 16, 2013 
Time: 1:00 pm, Eastern Daylight Time (New York, GMT-04:00) 
Meeting Number: 962 104 625 
Meeting Password: Tools 

------------------------------------------------------- 
To join the online meeting (Now from mobile devices!) 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/j.php?ED=208944827&UID=0&PW=NNzliMjI4ZjI2&RT=MiMxMQ%3D%3D 
2. If requested, enter your name and email address. 
3. If a password is required, enter the meeting password: Tools 
4. Click "Join". 

To view in other time zones or languages, please click the link: 
https://workgreen.webex.com/workgreen/j.php?ED=208944827&UID=0&PW=NNzliMjI4ZjI2&ORT=MiMxMQ%3D%3D 

------------------------------------------------------- 
To join the audio conference only 
------------------------------------------------------- 
To receive a call back, provide your phone number when you join the meeting, or call the number below and enter the access code. 
Call-in toll-free number (US/Canada): 1-877-668-4490 
Call-in toll number (US/Canada): 1-408-792-6300 
Global call-in numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=208944827&tollFree=1 
Toll-free dialing restrictions: http://www.webex.com/pdf/tollfree_restrictions.pdf 

Access code:962 104 625 

------------------------------------------------------- 
For assistance 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/mc 
2. On the left navigation bar, click "Support". 

You can contact me at: 
[email-masked] 
1-703-652-9534 

To add this meeting to your calendar program (for example Microsoft Outlook), click this link: 
https://workgreen.webex.com/workgreen/j.php?ED=208944827&UID=0&ICS=MI&LD=1&RD=2&ST=1&SHA2=jsmHwrBGeam5TaHk-81h2pAMuflEWx7XuzQcVIwMyuo=&RT=MiMxMQ%3D%3D 

The playback of UCF (Universal Communications Format) rich media files requires appropriate players. To view this type of rich media files in the meeting, please check whether you have the players installed on your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php. 

Sign up for a free trial of WebEx 
http://www.webex.com/go/mcemfreetrial 

http://www.webex.com 

CCP:+14087926300x962104625# 

IMPORTANT NOTICE: This WebEx service includes a feature that allows audio and any documents and other materials exchanged or viewed during the session to be recorded. By joining this session, you automatically consent to such recordings. If you do not consent to the recording, discuss your concerns with the meeting host prior to the start of the recording or do not join the session. Please note that any such recordings may be subject to discovery in the event of litigation.

---

From: Jari Arkko <[email-masked]>
Date: Tue, 16 Jul 2013 16:24:02 +0200

I am here in Durban, at the ICANN meeting and due to the local program and meetings I'm not sure I will be able to join you. I will try to call, but I fail to find a suitable spot or signal, please take notes.

Jari

---

From: Ray Pelletier <[email-masked]>
Date: Tue, 16 Jul 2013 13:59:38 -0400

Tools Call 16 Jul 13

Attendees

Russ
Bob
Scott
Henrik
Robert
Tony
Alice
Alexa
Glen
Karen
Steve
Ryan

Tools Call Agenda 

1. Datatracker Projects

	Alice - we're up and running; receiving notifications, two directions now, to and from datatracker
			Still working on some aspects of IANA, don't believe completed
	Henrik - latest with IANA, they were expecting datatracker to change the states; there are fixes for IANA issues to set the states; hopefully deployed very soon; shim layer changes not released
	Steve - will be done today
	Henrik - IANA wants to add more information to the datatracker; maybe Robert and I meet with IANA in Berlin to get update
	Alice to meet with IANA in Berlin

  - Agenda Scheduling Development -- Sandalman
	Robert - did successfully use conflict resolution tool with IESG; AMS had to back out, wasn't too egregious; Michael wrapping up a few (12) UI changes, some will goo into Phase 3; will be working on re-basing to Henrik's state; only focused on a subset of the tests; did fix the speed problem; once done, then move into Phase 3; basically the rest of the UI when you have the schedule in place; Phase 4 for Vancouver to have the tool generate an initial schedule, end of September.
	Ray - no demo scheduled

  - Shim Layer Removal WO 1 -- IOLA
	Henrik - no IOLA work since last time, vacation

  - Merges -- Henrik
	Henrik - all merges done; need more tests; some fixes were done; a couple waiting resolution
	New release tomorrow.
	Expect to merge NomCom in a few days, when satisfied with Shim Layer merges.  Expect to be done before Berlin

2. Community & Other Projects
  - NomCom Tool Development -- Yaco
	Robert - Allison is exploring doing review of responses blinded
	Henrik concerned about this; only place that mail to NomCom is captured is NomCom tool

  - Mail Search & Archive Tool -- AMS
	Ryan - implemented admin interface for Secretariat to remove spam; implemented export feature; last of main feature to be implemented.  Robert did a round of testing; Ryan working on the issues; recently external server re-built so re-deploying the systems; resuming test imports for timing and errors identification; 2.2 million messages
	Robert - interface very impressive
	Russ - deployment?
	Ryan - another test round, expand users; build confidence, then deploy; August is doable
	Robert - uncertainties as to how to get access to private lists; another round of testing and assumptions we need to verify; August - September timeframe is right.

  - IAOC & Trust Website Makeover -- AMS
	Alexa - IAOC is up and live; still taking feedback, finishing things next week; Privacy Policy sent out last week, will send to Scott.  Need DMCA info out.

3. RFC Services Projects
  - xml2rfc Specification for RPC Format Requirements
  - xml2rfc Specification for Enhancements
	Alice - would be good to talk to Heather in Berlin; she is pulling together a design team
  - Improve rfc-editor.org website
  - Stats & graphs tools

4. Transition of Mission Critical Tools
  - Process Document -- Russ and Alexa
	Russ - we need to finish; no comments on the Last Call

  - Moving mail aliases to ietf.org and link them to datatracker database
	Henrik - expect to complete code in Berlin at the Code Sprint

  - Issue trackers and wikis for IETF WGs on ietf.org
	Henrik - first is to set up a test deployment of Trak; next, move over, or partially re-write code that generate a new instance a new WG is chartered, could be moved easily; migration and setting up re-directs; timeline for testing Trak, same or different server; Glen and Steve - can you take that on, we will follow up with Henrik.   
	Henrik - after Berlin, attention on mergers and xml2rfc work; on vacation after Berlin and doing some travel; probably after next call	

  - Internet-Draft dependencies
	Henrik - will Bill be in Berlin; if so, then he will complete, else, no.

5. AOB

	Alice - xml2rfc v2 - we have not notified users and started 6 month period; not stable enough; still reverting to v1 occasionally; 

On Jul 15, 2013, at 9:11 AM, Ray Pelletier wrote:

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development