Subject: [TOOLS-DEVELOPMENT] Tools Call 18 June; Webex Details

From: Ray Pelletier <[email-masked]>
Date: Thu, 13 Jun 2013 12:07:44 -0400

All;

A reminder of the call on Tuesday 18 June at 1:00 PM EDT, GMT -04.  WebEx details below.

Ray

Topic: Tools Cmte 
Date: Tuesday, June 18, 2013 
Time: 1:00 pm, Eastern Daylight Time (New York, GMT-04:00) 
Meeting Number: 963 989 080 
Meeting Password: Tools 

------------------------------------------------------- 
To join the online meeting (Now from mobile devices!) 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/j.php?ED=207691727&UID=0&PW=NMzZkZmRlMDAw&RT=MiMxMQ%3D%3D 
2. If requested, enter your name and email address. 
3. If a password is required, enter the meeting password: Tools 
4. Click "Join". 

To view in other time zones or languages, please click the link: 
https://workgreen.webex.com/workgreen/j.php?ED=207691727&UID=0&PW=NMzZkZmRlMDAw&ORT=MiMxMQ%3D%3D 

------------------------------------------------------- 
To join the audio conference only 
------------------------------------------------------- 
To receive a call back, provide your phone number when you join the meeting, or call the number below and enter the access code. 
Call-in toll-free number (US/Canada): 1-877-668-4490 
Call-in toll number (US/Canada): 1-408-792-6300 
Global call-in numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=207691727&tollFree=1 
Toll-free dialing restrictions: http://www.webex.com/pdf/tollfree_restrictions.pdf 

Access code:963 989 080 

------------------------------------------------------- 
For assistance 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/mc 
2. On the left navigation bar, click "Support". 

You can contact me at: 
[email-masked] 
1-703-652-9534 

To add this meeting to your calendar program (for example Microsoft Outlook), click this link: 
https://workgreen.webex.com/workgreen/j.php?ED=207691727&UID=0&ICS=MI&LD=1&RD=2&ST=1&SHA2=r9-KbTOUYpg64Ma-icOnuuYDrEifsIfy2dnQ5Fxt1BY=&RT=MiMxMQ%3D%3D 

The playback of UCF (Universal Communications Format) rich media files requires appropriate players. To view this type of rich media files in the meeting, please check whether you have the players installed on your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php. 

Sign up for a free trial of WebEx 
http://www.webex.com/go/mcemfreetrial 

http://www.webex.com 

CCP:+14087926300x963989080# 

IMPORTANT NOTICE: This WebEx service includes a feature that allows audio and any documents and other materials exchanged or viewed during the session to be recorded. By joining this session, you automatically consent to such recordings. If you do not consent to the recording, discuss your concerns with the meeting host prior to the start of the recording or do not join the session. Please note that any such recordings may be subject to discovery in the event of litigation.

---

From: Ray Pelletier <[email-masked]>
Date: Tue, 18 Jun 2013 12:42:53 -0400

1. Datatracker Projects
    - Back End Development -- IOLA
    - Agenda Scheduling Development -- Sandalman
    - Shim Layer Removal WO 1 -- IOLA
    - Merges -- Henrik

2. Community & Other Projects
    - NomCom Tool Development -- Yaco
    - Mail Search & Archive Tool -- AMS
    - IAOC & Trust Website Makeover -- AMS

3. RFC Services Projects
    - xml2rfc RPC Tool
    - xml2rfc Community Tool
    - diff tool
    - website
    - Stats & graphs tools

4. Transition of Mission Critical Tools

5. AOB

On Jun 13, 2013, at 12:07 PM, Ray Pelletier wrote:

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Ray Pelletier <[email-masked]>
Date: Tue, 18 Jun 2013 15:56:58 -0400

Tools Call 18 Jun 13

Russ
Bob
Jari
Robert
Henrik
Scott
Tony
Glen
Steve
Ray

1. Datatracker Projects

	Robert - quiet at the moment; 
	Henrik - close to done, one issue regarding notifications going to RFC Editor; Phases 1 & 2 for RFC Editor done; but IANA wants to add attributes; no coding going on; just my debugging; Berlin? - not sure about IANA being done by then

	Russ - attributes?

	Henrik - additional entries in a table or two

	Robert - lots of activities knocking out issues; hoping to use as a parallel tool with current tools; on track to use visual manipulation next week; high level plan sent to TMC; summary is work on auto scheduling has been pushed out to make tools usable in Berlin; anticipate completion well before Vancouver.

	Robert - has two change sets for Henrik ; proceeding; not huge strides because of other dependencies; 

	Henrik - ideally two drops in; NomCom, Agenda tool in for IOLA to have something stable to work on

	Robert - there's other work I want to do which is being held up by this

    - Merges -- Henrik

	Henrik - been working for over 10 day period on Agenda tool merge; with a situation - test suite working too slowly, 50 minutes to complete; straight forward way to fix is to pare down large tables he's using; he chose another path which we'll adopt, changed to using DB back ends, instead of another; which permits journaling to undo what you've just run;  makes the test run 5 minutes instead of 30 - 40 minutes;  some things don't work with this approach.  So there are errors being committed that Michael hasn't seen; trying to fix is a bit of a bother, time consuming; we need to have something that will let tests run reasonably fast; I feel I'll be able to sort out, but not thrilled about it; will continue a bit longer, then put aside then go back and do IOLAs and possibly NomCom ahead of Michael's.  

	Robert - yes to doing NomCom's ahead of Michael's

	Henrik - summing - change merge order; forward on path to sort out using Journaling; then have Michael merge up to a later release.  

	Robert - merge plan - parts 1 and 2 by end of June?  Will give Michael a target to work on.
	Henrik - want to do much faster than that.

	Russ - lots going on; Thanks Henrik, sorry it's so painful

	Robert - we've accepted.  In the Queue to merge, will be doing later cleanups, customary cleanup; good testing from Joel, good comments from Allison.  I expect Allison to use it beginning Berlin.

	Henrik - there's been a feature request from Allison so that Nominees material is anonymous. (Questionnaire responses to be blinded)  We may want to add that as a project.

	Russ - fall within 10% additional cost?
	Henrik - I expect so.

	Robert - may be a difficult task to Anonymize.

	Robert - Ryan made great progress; still working through import of existing archives and mechanics.  Difficult, coding in progress.  Ryan still indicates it to come together in July timeframe.

	Robert - discussed policies with removing message from archives with IESG.  Sufficient set of statements re: making into the archives in the first place and IESG helping to locate missing archives.

	Ray - progress with IAOC site; look and feel similar to ietf site; soon to be in review again by IAOC before going live.  Trust site has begun. 

 Jorge is developing privacy statement draft to be added to website.  ISOC has been cited as an example for statement.  Glen to ask Alexa and Karen to review ISOC statement.  

3. RFC Services Projects
    - xml2rfc RPC Tool
    - xml2rfc Community Tool

	One tool?  One SOW?

	Henrik - 
			Text in
			HTML and PDF formats out

	Ray - Process will clarify the boundaries for the SOW.  RSOC will send its input to the TMC which will review and flesh out.  After RSOC buys off there will be one SOW for the development of specifications for the tool.

	- Beta Test of xml2rfc status

	Henrik - we could have been in production for some time; Community using ver 2; RPC uses till it breaks, then reverts to v 1.  During July should be able to cleanup.

    - diff tool

	Russ - cleanup to make older I-D available for doing diffs on AMS side
	Henrik - 3 directories; a 4th has links to one of 3 others; there is a tool that knows what's happening from the 3 to the 4th; in production for 6 - 9 months;  I've considered it done for some time.

	Russ - exactly what I was looking for.

    - website
	Ray - needs a SOW

    - Stats & graphs tools
	Ray - need SOW for RPC
	Jari - need for RFC Editor and IETF as well
	Bob - I hope we're not just automating what's being done now; lots of data but confusing as to what it means

4. Transition of Mission Critical Tools
	Russ - been developing a process to once tool Identified, what are steps to move from X to ietf.org and Secretariat administration.  I believe Alexa has pen for last updates, then run by this group in the next few days.

	Henrik suggested a couple possibilities, the issues tracker and version controls (?)
	Robert - includes wiki; Henrik, yes.

	Russ - age of WG; newer are using and older are not; 

	Henrik - tools server auto constructs tracker, wiki, mail list, sends email to chairs with instructions

	Jari - support taking these two things forward; move something when it's ready to move;

	Henrik - started to recode address lists
	Robert - different repository tool perhaps decouple

	Robert - 3rd thing - link to dependencies for each I-D; Bill Fenner's code; 

	Russ - transition, not here; but this is a potential capability

	Henrik - not going to move old stuff; not necessarily good; Bill - rather start from scratch and code in Datatracker

5. AOB

	New servers
	Glen - migrating IETF to new servers; new challenge, new server with new OS running slower than old server with old OS; looking to adjust, or reload.  Unknown yet to resolution time.

	Glen - got green light to move to CoLo in Sunnyvale; future looks good

	Bob - what do we need to do to take advantage of the servers in the Colo is something we need to talk about.

	Robert - still fallout from having 2 acting NomComs; data missing from datatracker; found it and can fix.

---

From: Russ Housley <[email-masked]>
Date: Tue, 18 Jun 2013 16:06:20 -0400

I have an all day meeting on 9 July 2013.  After going through all of that doodle-madness, I hate to do this, but I'd like to hold the next call on the 3rd Tuesday instead of the 2nd Tuesday in July.  Will holding the call at 1:00pm Eastern (the usual time) on Tuesday, 16 July 2013 work for everyone?

Russ

---

From: Scott O Bradner <[email-masked]>
Date: Tue, 18 Jun 2013 16:09:02 -0400

wfm (as long as it is set soon)

Scott

---

From: Bob Hinden <[email-masked]>
Date: Tue, 18 Jun 2013 13:43:27 -0700

16 July is fine for me.

Bob

---

From: Robert Sparks <[email-masked]>
Date: Tue, 18 Jun 2013 15:50:35 -0500

Should work for me

---

From: Alexa Morris <[email-masked]>
Date: Tue, 18 Jun 2013 14:08:48 -0700

wfm 

alexa

>>> I have an all day meeting on 9 July 2013.  After going through all of that doodle-madness, I hate to do this, but I'd like to hold the next call on the 3rd Tuesday instead of the 2nd Tuesday in J…

----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: Alice Russo <[email-masked]>
Date: Tue, 18 Jun 2013 14:32:02 -0700

wfm.

Thanks,
Alice

---

From: Tony Hansen <[email-masked]>
Date: Tue, 18 Jun 2013 19:19:17 -0400

wfm

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 19 Jun 2013 03:07:03 +0200

On 2013-06-18 22:06 Russ Housley said the following:
> Will holding the call at 1:00pm Eastern (the usual time) on Tuesday,
> 16 July 2013 work for everyone?

WFM, as far as I can tell.

	Henrik