Subject: [TOOLS-DEVELOPMENT] Tools Call Wednesday 15 May

From: Ray Pelletier <[email-masked]>
Date: Tue, 7 May 2013 09:12:54 -0400

All;

A reminder of the 15 May call at 11:00 AM EDT, GMT -05.  Webex details below.

Agenda to be sent separately.  Do you have an agenda item to suggest?

Ray

Topic: Tools Cmte 
Date: Wednesday, May 15, 2013 
Time: 11:00 am, Eastern Daylight Time (New York, GMT-04:00) 
Meeting Number: 964 861 102 
Meeting Password: Tools 

------------------------------------------------------- 
To join the online meeting (Now from mobile devices!) 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/j.php?ED=206007042&UID=0&PW=NZmQyZTNhMjNi&RT=MiMxMQ%3D%3D 
2. If requested, enter your name and email address. 
3. If a password is required, enter the meeting password: Tools 
4. Click "Join". 

To view in other time zones or languages, please click the link: 
https://workgreen.webex.com/workgreen/j.php?ED=206007042&UID=0&PW=NZmQyZTNhMjNi&ORT=MiMxMQ%3D%3D 

------------------------------------------------------- 
To join the audio conference only 
------------------------------------------------------- 
To receive a call back, provide your phone number when you join the meeting, or call the number below and enter the access code. 
Call-in toll-free number (US/Canada): 1-877-668-4490 
Call-in toll number (US/Canada): 1-408-792-6300 
Global call-in numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=206007042&tollFree=1 
Toll-free dialing restrictions: http://www.webex.com/pdf/tollfree_restrictions.pdf 

Access code:964 861 102 

------------------------------------------------------- 
For assistance 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/mc 
2. On the left navigation bar, click "Support". 

You can contact me at: 
[email-masked] 
1-703-652-9534 

To update this meeting to your calendar program (for example Microsoft Outlook), click this link: 
https://workgreen.webex.com/workgreen/j.php?ED=206007042&UID=0&ICS=MRS2&LD=1&RD=2&ST=1&SHA2=tnzcpMw7mSQcAycXorh/MrsazApFPm1be1inox94o0o=&RT=MiMxMQ%3D%3D 

WebEx will automatically setup Meeting Manager for Windows the first time you join a meeting. To save time, you can setup prior to the meeting by clicking this link: 
https://workgreen.webex.com/workgreen/meetingcenter/mcsetup.php 

The playback of UCF (Universal Communications Format) rich media files requires appropriate players. To view this type of rich media files in the meeting, please check whether you have the players installed on your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php. 

Sign up for a free trial of WebEx 
http://www.webex.com/go/mcemfreetrial 

http://www.webex.com 

CCP:+14087926300x964861102# 

IMPORTANT NOTICE: This WebEx service includes a feature that allows audio and any documents and other materials exchanged or viewed during the session to be recorded. By joining this session, you automatically consent to such recordings. If you do not consent to the recording, discuss your concerns with the meeting host prior to the start of the recording or do not join the session. Please note that any such recordings may be subject to discovery in the event of litigation.

---

From: Robert Sparks <[email-masked]>
Date: Wed, 08 May 2013 10:36:00 -0500

Please leave some time to discuss the mail archive import progress (it's 
ok to do this as part of the update on the projects).

Scott - will you be on this call?

RjS

On 5/7/13 8:12 AM, Ray Pelletier wrote:
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Scott O Bradner <[email-masked]>
Date: Wed, 8 May 2013 11:37:29 -0400

On May 8, 2013, at 11:36 AM, Robert Sparks <[email-masked]> wrote:

> Please leave some time to discuss the mail archive import progress (it's ok to do this as part of the update on the projects).
> 

yes

Scott

---

From: Sean Turner <[email-masked]>
Date: Wed, 08 May 2013 16:50:26 +0100

Unfortunately, I won't be able to make this call.  Note that at the IESG 
retreat we discussed a number of possible tool tickets.  I hope o have 
them to you relatively soon, but I need to firm them up and I want to 
run them by Robert first to make sure I don't duplicate existing tickets.

spt

On 5/8/13 4:36 PM, Robert Sparks wrote:
>> 1. Go to
>> https://workgreen.webex.com/workgreen/j.php?ED=206007042&UID=0&PW=NZmQyZTNhMjNi&RT=MiMxMQ%3D%3D
>>
>> To receive a call back, provide your phone number when you join the
>> meeting, or call the number below and enter the access code.
>> Global call-in numbers:
>> https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=206007042&tollFree=1
>>
>> Toll-free dialing restrictions:
>> http://www.webex.com/pdf/tollfree_restrictions.pdf
>>
>> Access code:964 861 102
>>
>> WebEx will automatically setup Meeting Manager for Windows the first
>> time you join a meeting. To save time, you can setup prior to the
>> meeting by clicking this link:
>> The playback of UCF (Universal Communications Format) rich media files
>> requires appropriate players. To view this type of rich media files in
>> the meeting, please check whether you have the players installed on
>> your computer by going to
>> https://workgreen.webex.com/workgreen/systemdiagnosis.php.
>>
>> IMPORTANT NOTICE: This WebEx service includes a feature that allows
>> audio and any documents and other materials exchanged or viewed during
>> the session to be recorded. By joining this session, you automatically
>> consent to such recordings. If you do not consent to the recording,
>> discuss your concerns with the meeting host prior to the start of the
>> recording or do not join the session. Please note that any such
>> recordings may be subject to discovery in the event of litigation.

---

From: Ray Pelletier <[email-masked]>
Date: Wed, 15 May 2013 09:08:13 -0400

All

Draft Agenda.

Ray

Agenda

1.  Projects in Work
  a.  Datatracker Projects	
	1  Back End Development				IOLA
	2  Agenda Scheduling Development	Sandalman
	3  Shim Layer Removal WO 1			IOLA
	4.  Merges							Henrik

  b.  Community & Other Projects		
	1  NomCom Tool Development		Yaco
	2  Mail Search & Archive Tool			AMS
	3  IAOC & Trust Website Makeover		AMS

  c.  RFC Services Projects

2.  Transition of Mission Critical Tools

3.  AOB

---

From: Ray Pelletier <[email-masked]>
Date: Wed, 15 May 2013 15:31:13 -0400

All

I took rough notes of the call.
Ray

Tools Call 15 May 13

Agenda

1.  Projects in Work
  a.  Datatracker Projects	

  c.  RFC Services Projects
		1.  xml2rfc	RPC Tool
		2.  xml2rfc	Community Tool
		3.  diff tool
		4.  website
		5.  Stats & graphs tools

3.  AOB

1.  Projects in Work
  a.  Datatracker Projects	
	1  Back End Development					IOLA
		Alice - RPC testing phase 2, where we pull data from datatracker, pretty far along on testing side
					Add draft step pulled in.  

	2  Agenda Scheduling Development		Sandalman
		Robert - good meeting with developer and AMS; second round of testing in next few days
						AMS will determine whether used for Berlin; may be good for conflict resolution call
		Alexa - impossible to know just now; useful in some ways; may need to use manual; very responsive to requests
		Robert - should be on well before Vancouver	

	3  Shim Layer Removal WO 1				IOLA
		Henrik - Ole working on it; a few hours left on WO 1 in two weeks time; tweak schedule? to try and get some support for Research Groups before Berlin?  Will try to be ready by mid-June, but wouldn't promise; vacation time during July, so no promise for Research Group for Berlin.	Group Functionality.

	4.  Merges											Henrik
		Henrik - done merges yesterday, done IOLA milestones work; a release today; plan is to merge in Agenda code next, a piece of it, setting up the next code merge;  Quite a bit of work to set this up, Michael does his work differently, so selection to be made; next are two shim layer drops from IOLA

  b.  Community & Other Projects		
	1  NomCom Tool Development				Yaco
		Robert - validation phase started, Joel and Robert testing, found some things; Yaco making changes; second round of testing end of week, beginning of next; Suresh and Allison teed up for testing; Allison may use current or new one, she will decide.  Timeline is pretty far out.  Henrik - timeline new use is typically the week before the July IETF.  Henrik - new instance of current tools wouldn't take much time to set up.

	2  Mail Search & Archive Tool				AMS
		Ryan - working on import engine, testing; 2.2 million messages; working on issue of spam; a lot of work done to remove from MONARCH; techniques - using MONARCH archive to identify spam; leave 800,000 SPAM and not imported messages; second pass, maybe Spam Assassin to eliminate more Spam.

		Scott - spoken with IESG about Spam and integrity of mail archive?

		Robert - ramifications - messages that do not appear in MONARCH Archive; a target to mimic MONARCH is inappropriate; therefore likely to bring in a bunch of SPAM; err on side of inclusion than exclusion; MONARCH itself has done incorrect things; wants feedback, when done we can keep the old files around; keep a copy of what's not imported

		Scott - Jari should discuss with IESG; Bob concurs; Jari will do

		Scott - maintain box format mail desired
		Robert - yes, will do

		Henrik - one approach at making spam removal more flexible long term, include them, but mark as spam, but won't search on them

		Robert - make it easier to maintain later as well; moderated by an automated maintainer
		Ryan - using Spam Assassin; pretty clean now 
		Henrik - found that old lists had a relevant messages when closed; afterwards went to an old list directly in archive; trailing spam messages

		Robert - Archiving - 90 WGs, mostly closed, points to an archive not our archive, eg, HTTP Bis points to W3 archive
					about a dozen groups, mostly closed, where can't find archive, eg, SIDRD
					Try to get IESG to help to get a local copy; many are barely BoFed; 

		Jari - adding a Management item and Roberts invited to provide details

	3  IAOC & Trust Website Makeover	AMS
		Alexa - Couple weeks ago presented to IAOC Retreat got feedback; done a lot of the work, asking for info

  c.  RFC Services Projects
		1.  xml2rfc	RPC Tool
		2.  xml2rfc	Community Tool
		3.  diff tool
		4.  website
		5.  Stats & graphs tools

3.  AOB

Ryan - Agenda scheduling - please keep me involved.  Robert - yes

Alice - xml2rfc release?

Henrik - has reserved time during next week to do so.