Subject: [TOOLS-DEVELOPMENT] Tools Call 6 March

From: Ray Pelletier <[email-masked]>
Date: Tue, 5 Mar 2013 16:03:25 -0500

All;

There will be a tools call Wednesday 6 March at 11:00 AM EST, GMT -05.  Webex details below.

1. Secretariat tools branch merge status
2.  xml2rfc status
3.  Orlando Tools Schedule
4.  Outstanding Projects
5.  AOB

Ray  

Begin forwarded message:

> From: Ray Pelletier <[email-masked]>
> Date: March 5, 2013 4:00:37 PM EST
> To: [email-masked]
> Subject: (Forward to attendees) Meeting invitation: Tools Cmte
> Reply-To: [email-masked]
> 
> 
> **** You can forward this email invitation to attendees **** 
> 
> Hello , 
> 
> Ray Pelletier invites you to attend this online meeting. 
> 
> Topic: Tools Cmte 
> Date: Wednesday, March 6, 2013 
> Time: 11:00 am, Eastern Standard Time (New York, GMT-05:00) 
> Meeting Number: 968 655 875 
> Meeting Password: Tools 
> 
> 
> ------------------------------------------------------- 
> To join the online meeting (Now from mobile devices!) 
> ------------------------------------------------------- 
> 1. Go to https://workgreen.webex.com/workgreen/j.php?ED=203484087&UID=0&PW=NNWJiZWRjNDBj&RT=MiMxMQ%3D%3D 
> 2. If requested, enter your name and email address. 
> 3. If a password is required, enter the meeting password: Tools 
> 4. Click "Join". 
> 
> To view in other time zones or languages, please click the link: 
> https://workgreen.webex.com/workgreen/j.php?ED=203484087&UID=0&PW=NNWJiZWRjNDBj&ORT=MiMxMQ%3D%3D 
> 
> ------------------------------------------------------- 
> To join the audio conference only 
> ------------------------------------------------------- 
> To receive a call back, provide your phone number when you join the meeting, or call the number below and enter the access code. 
> Call-in toll-free number (US/Canada): 1-877-668-4490 
> Call-in toll number (US/Canada): 1-408-792-6300 
> Global call-in numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=203484087&tollFree=1 
> Toll-free dialing restrictions: http://www.webex.com/pdf/tollfree_restrictions.pdf 
> 
> Access code:968 655 875 
> 
> ------------------------------------------------------- 
> For assistance 
> ------------------------------------------------------- 
> 1. Go to https://workgreen.webex.com/workgreen/mc 
> 2. On the left navigation bar, click "Support". 
> 
> You can contact me at: 
> [email-masked] 
> 1-703-652-9534 
> 
> To add this meeting to your calendar program (for example Microsoft Outlook), click this link: 
> https://workgreen.webex.com/workgreen/j.php?ED=203484087&UID=0&ICS=MI&LD=1&RD=2&ST=1&SHA2=ZWMW9UCVoocXJoUAZXp9MDwu8J0Lywi-3ub5X2e6F2s=&RT=MiMxMQ%3D%3D 
> 
> The playback of UCF (Universal Communications Format) rich media files requires appropriate players. To view this type of rich media files in the meeting, please check whether you have the players installed on your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php. 
> 
> Sign up for a free trial of WebEx 
> http://www.webex.com/go/mcemfreetrial 
> 
> http://www.webex.com 
> 
> CCP:+14087926300x968655875# 
> 
> IMPORTANT NOTICE: This WebEx service includes a feature that allows audio and any documents and other materials exchanged or viewed during the session to be recorded. By joining this session, you automatically consent to such recordings. If you do not consent to the recording, discuss your concerns with the meeting host prior to the start of the recording or do not join the session. Please note that any such recordings may be subject to discovery in the event of litigation.

---

From: Ray Pelletier <[email-masked]>
Date: Wed, 6 Mar 2013 11:49:24 -0500

Tools Call 6 Mar 13

1. Secretariat tools branch merge status
	Henrik - did merge, some tests failed; all running smoothly last night
					release sometime later today; will send to Steve
	Steve - will do today
					will do Sprint branches based on that

2.  xml2rfc status
	Henrik - not had any more notices of trouble after 2.4.1 release; feels pretty stable now
					waiting for usage feedback
	Glen - will check status of Windows GUI

	Alice - will add ticket to tracker; Unexpected result; some small defects related to nroff output
				having small quirks in v2

	Russ - down to minor things it seems

	Bob - still looking for Mac GUI version; Henrik will look into

	Russ - ietf.org/tools points to v1.  Time to change to v2?  Henrik - I think so
				web version - upload and get output back

	Bob - first time used and had to debug by running one fix at a time; not useable; installation basically broken

	Henrik - an exception in the code; believed fixed; should be resolved now.  Try again	

	Jari - can compile now; supportive of moving to v2

	Russ - asks Alexa to have point to v2; but also leave v1 available
	Alexa - can do

	Alice - quality of error messages; some v1 messages more useful than v2; will put in issue tracker
	Henrik - fixing as found in Issue Tracker

3.  Orlando Tools Schedule
	Sat 		0930	Code Sprint									Grand Sierra A
	Sun		1100	IETF Servers								Regents Boardroom
	Mon	1300	Agenda Scheduling Demo			Regents Boardroom
	Tue		1700	Mail Archive								Regents Boardroom
	Wed	0900	IAOC-Trust Web Makeover	Regents Boardroom

4.  Outstanding Projects
	a.  Agenda Scheduling Tool - Richardson
		Henrik - has been progress, not at speed planned
		Alexa - have not seen any newer version, but confident they're working on it

	b.  Back End - IOLA
		Alice - switched to production; notifications are going when done
		Henrik - IANA sending info - Phase I done, but need to add attributes to send
					Phase II is Berlin

		Russ - as servers move, will firewall rules by IANA break because connected to IP addresses and not domain names
		Henrik - yes will need to address this
		Steve - will discuss with IANA

	c.  NomCom Tools - Yaco
		Henrik - they are now back with both prior programmers, progress being made
		Goal is completion by Berlin	
		Henrik - would like in April so we can test

	d.  Shim Layer Removal - IOLA
		Henrik - Reasonable progress; programmer was ill; needs to work on latest merge

	e.  xml2rfc beta testing
	f.  xml2rfc installer for windows
		Glen - don't have full Visual Studio installed; will do after meeting
		
	g.  Merge of AMS-developed tools into same source code repository

	h.  IAOC & Trust Website Makeover
	
	i.  Mail Archive Tool - AMS
		Russ - When might the community see a Beta
		Henrik - End April, but Ryan should say

	j.  Henrik's Merges	

5.  AOB
	Video Service - how scale in long run to likely include each WG
	Whats the Architecture?

	IAOC - Put together a subgroup to review and make a recommendation

On Mar 5, 2013, at 4:03 PM, Ray Pelletier wrote:

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Bob Hinden <[email-masked]>
Date: Wed, 6 Mar 2013 09:17:43 -0800

One nit below.

Bob

> 	Bob - still looking for Mac GUI version; Henrik will look into

I have the Mac GUI version (not looking for it).  The problem is that it broke when I tried installing a new version of xml2rfc.  

BTW, I think the simplest solution is that the GUI installers/images should always include the latest version of xml2rfc.  The installer should simply replace everything.  However, this is Henrik's call.