Subject: [TOOLS-DEVELOPMENT] Fwd: Change in I-D announcement format

From: Russ Housley <[email-masked]>
Date: Wed, 24 Oct 2012 10:03:35 -0400

What change was deployed?  Was this intentional?

Russ

Begin forwarded message:

> From: t.p. <[email-masked]>
> Date: October 24, 2012 9:28:16 AM EDT
> To: Russ Housley <[email-masked]>
> Cc: IETF discussion list <[email-masked]>
> Subject: Re: Change in I-D announcement format
> 
> And now there seems to be another unannounced change, in that in
> addition to the usual announcement format e-mails, there may also be, or
> may not be, the appearance seems random, of
> 
> Subject: New Version Notification -
> 
> e-mails.  This may or may not be an improvement, depending on how long
> it takes me to work out what is happening and whether or not I then like
> my conclusion.  And whether or not what I rely on is still available.
> 
> Tom Petch
> 
> ----- Original Message -----
> From: "Russ Housley" <[email-masked]>
> To: "Brian E Carpenter" <[email-masked]>
> Cc: "IETF discussion list" <[email-masked]>
> Sent: Wednesday, June 13, 2012 2:06 PM
> Subject: Re: Change in I-D announcement format
> 
> 
> Brian:
> 
> There was no announcement that this change was about to be deployed;
> however, there was a long discussion of the change.  It started with a
> request for the HTML version of the I-D instead of the plain text
> version.  At the end of the discussion the decision was to use the
> Datatracker URL as it allows anyone to get the plaintext or a diff with
> just one more click.
> 
> Russ
> 
> 
> On Jun 13, 2012, at 3:47 AM, Brian E Carpenter wrote:
> 
>> Did I miss an announcement of the change in format of
>> I-D announcement messages?
>> 
>> There's no longer a URL for the standard .txt format. That's
>> mildly annoying for me (extra time and extra mouse clicks)
>> and must be a nuisance for anyone who processes these messages
>> automatically.
>> 
>> At least, I would have expected a warning message about the change.
>> 
>> --
>> Regards
>>  Brian Carpenter
>> 
>> 
> 
> 
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 24 Oct 2012 20:34:26 +0200

Hi Russ,

> What change was deployed?  Was this intentional?

I'm not aware of having deployed any change related to these 'new' notification
emails for a long time.  The 'New Version Notification' emails came in when we
fixed some missing features in the submission tool.  The relevant release was
v3.53, released 4 May 2011 (18 months ago).

I'm also not aware of having removed any notification emails that Tom is used
to seeing, but it would be easier to check that given information of which
emails he considers to be the usual announcements.

Maybe I should add [email-masked] to the recipients of the standard
release emails for the datatracker?

Best regards,

	Henrik

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development
>

---

From: Russ Housley <[email-masked]>
Date: Thu, 25 Oct 2012 11:22:19 -0400

I do not think the standard datatracker release messages are formatted as announcements.  But, I think you are on to something.  Let's brainstorm the right way to handle this without creating any additional work for ourselves.

Russ

---

From: Russ Housley <[email-masked]>
Date: Thu, 25 Oct 2012 14:54:05 -0400

Tom:

We do not see any changes that were made to the datatracker in over a year that would cause different formatting.  Please provide more details so that we can figure out what might be going on.

Russ

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 26 Oct 2012 00:14:25 +0200

> I do not think the standard datatracker release messages are formatted as announcements.  But, I think you are on to something.  Let's brainstorm the right way to handle this without creating any a…

Ack.  I have a suggestion in the works.

	Henrik

---

From: Russ Housley <[email-masked]>
Date: Fri, 26 Oct 2012 09:29:55 -0400

Tom:

These appear (and have for many years) when there is an IESG member holding a DISCUSS position on a document and a new version is posted.  The notice goes to the IESG member and the authors and the WG chairs.

Russ

On Oct 26, 2012, at 7:08 AM, t.p. wrote:

> Sorry, I am being sloppy in my wording.
> 
> I was referring to a separate e-mail, with a subject line of
> Subject: New Version Notification - ........
> which is appearing in parallel to the usual announcement of a new I-D
> with a subject of
> Subject: I-D Action
> and more or less duplicates it.
> 
> One of the posts on the main list suggested that it came to ADs, authors
> and WG chairs and the like but in the case of eg
> http://www.ietf.org/internet-drafts/draft-ietf-6man-udpzero-07.txt
> I am a nobody so I am unclear why it should have been sent to me.
> 
> I append the e-mail header
> ==========================================
> Received: from DBXPRD0710HT005.eurprd07.prod.outlook.com (10.255.79.168)
> by
> DBXPRD0710HT004.eurprd07.prod.outlook.com (10.255.79.167) with
> Microsoft SMTP
> Server (TLS) id 14.16.224.5; Mon, 22 Oct 2012 09:00:08 +0000
> Received: from mail119-ch1-R.bigfish.com (216.32.181.175) by
> DBXPRD0710HT005.eurprd07.prod.outlook.com (10.255.79.168) with
> Microsoft SMTP
> Server (TLS) id 14.16.224.5; Mon, 22 Oct 2012 09:00:07 +0000
> Received: from mail119-ch1 (localhost [127.0.0.1]) by
> mail119-ch1-R.bigfish.com (Postfix) with ESMTP id CB08FA01B6 for
> <[email-masked]>; Mon, 22 Oct 2012 09:00:06 +0000 (UTC)
> X-Forefront-Antispam-Report:
> CIP:64.170.98.30;KIP:(null);UIP:(null);IPV:NLI;H:mail.ietf.org;RD:mail.i
> etf.org;EFVD:NLI
> X-SpamScore: -22
> X-BigFish:
> ps-22(zzzz1202h1d1ah1d2ahzz1033IL17326ah8275dhz2fhfI11Ieh5fh668h839h944h
> d24h107ah1220h1288h12a5h12a9h137ah13b6h13eah1441h14ddh1504h1155h)
> Received-SPF: pass (mail119-ch1: domain of ietf.org designates
> 64.170.98.30 as permitted sender) client-ip=64.170.98.30;
> envelope-from=[email-masked]; helo=mail.ietf.org ;ail.ietf.org ;
> Received: from mail119-ch1 (localhost.localdomain [127.0.0.1]) by
> mail119-ch1
> (MessageSwitch) id 1350896405126256_8943; Mon, 22 Oct 2012 09:00:05
> +0000
> (UTC)
> Received: from CH1EHSMHS043.bigfish.com
> (snatpool1.int.messaging.microsoft.com
> [10.43.68.241]) by mail119-ch1.bigfish.com (Postfix) with ESMTP id
> 1308F34005B for <[email-masked]>; Mon, 22 Oct 2012 09:00:05 +0000
> (UTC)
> Received: from mail.ietf.org (64.170.98.30) by CH1EHSMHS043.bigfish.com
> (10.43.69.252) with Microsoft SMTP Server id 14.1.225.23; Mon, 22 Oct
> 2012
> 09:00:04 +0000
> Received: from ietfa.amsl.com (localhost [127.0.0.1]) by ietfa.amsl.com
> (Postfix) with ESMTP id EEF9221F88AF; Mon, 22 Oct 2012 01:58:52 -0700
> (PDT)
> DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org;
> s=ietf1;
> t=1350896333; bh=iOBc7kxvfTyQxl6Jy57tu9E6L5EYOZQwECLc2p462eo=;
> h=MIME-Version:From:To:Subject:Message-ID:Date:List-Id:
>  List-Unsubscribe:List-Archive:List-Post:List-Help:List-Subscribe:
>  Content-Type:Content-Transfer-Encoding:Sender;
> b=C9ZaBpqLHLyosiZrGye9K92fRS/+/pv6aaA1EqH3Nt3hWm42arKOCKCQt8bsOWaeb
>  jCs+AOyLqSscQvu1db0D8Uv9jWqw9c7NbpSYNWKpvwRtQ5RSB5/T5IEk47rXuoY1UW
>  4KZUy5W2JG+7CKcrbmq69ezT0GL0N28kREpoyAzY=
> X-Original-To: [email-masked]
> Delivered-To: [email-masked]
> Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com
> (Postfix)
> with ESMTP id C094121F86EB for <[email-masked]>; Mon, 22 Oct 2012
> 01:58:44 -0700 (PDT)
> X-Virus-Scanned: amavisd-new at amsl.com
> X-Spam-Flag: NO
> X-Spam-Score: -102.401
> X-Spam-Level:
> X-Spam-Status: No, score=-102.401 tagged_above=-999 required=5
> tests=[AWL=-0.061, BAYES_00=-2.599, SARE_SUB_OBFU_Z=0.259,
> USER_IN_WHITELIST=-100]
> Received: from mail.ietf.org ([64.170.98.30]) by localhost
> (ietfa.amsl.com
> [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id XVpsDZZccbRh; Mon,
> 22
> Oct 2012 01:58:44 -0700 (PDT)
> Received: from ietfa.amsl.com (localhost [127.0.0.1]) by ietfa.amsl.com
> (Postfix) with ESMTP id B60D221F8623; Mon, 22 Oct 2012 01:58:43 -0700
> (PDT)
> From: <[email-masked]>
> To: <[email-masked]>,
> <[email-masked]>,
> <[email-masked]>, <[email-masked]>, <[email-masked]>,
> <[email-masked]>
> Subject: New Version Notification - draft-ietf-6man-udpzero-07.txt
> X-Test-IDTracker: no
> X-IETF-IDTracker: 4.34
> Message-ID: <[email-masked]>
> Date: Mon, 22 Oct 2012 01:58:43 -0700
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.1.12
> Precedence: list
> List-Id: "IPv6 Maintenance Working Group \(6man\)" <ipv6.ietf.org>
> List-Unsubscribe: <https://www.ietf.org/mailman/options/ipv6>,
> <mailto:[email-masked]?subject=unsubscribe>
> List-Archive: <http://www.ietf.org/mail-archive/web/ipv6>
> List-Post: <mailto:[email-masked]>
> List-Help: <mailto:[email-masked]?subject=help>
> List-Subscribe: <https://www.ietf.org/mailman/listinfo/ipv6>,
> <mailto:[email-masked]?subject=subscribe>
> Content-Type: text/plain; charset="us-ascii"
> Content-Transfer-Encoding: 7bit
> Sender: <[email-masked]>
> Errors-To: [email-masked]
> Return-Path: [email-masked]
> X-MS-Exchange-Organization-SCL: 1
> X-MS-Exchange-Organization-AVStamp-Mailbox: MSFTFF;1;0;0 0 0
> X-MS-Exchange-Organization-AuthSource:
> DBXPRD0710HT005.eurprd07.prod.outlook.com
> X-MS-Exchange-Organization-AuthAs: Anonymous
> MIME-Version: 1.0
> 
> ==============================================
> 
> Tom Petch
> 
> 
> To: "t.p." <[email-masked]>
> Cc: "IETF Tools Development" <[email-masked]>
> Sent: Thursday, October 25, 2012 7:54 PM
> We do not see any changes that were made to the datatracker in over a
> year that would cause different formatting.  Please provide more details
> so that we can figure out what might be going on.
> 
> Russ
> 
> 
> Begin forwarded message:
>

---

From: Robert Sparks <[email-masked]>
Date: Fri, 26 Oct 2012 09:12:16 -0500

Tom:

The tracker allows additional addresses to added to the list Russ describes.
Those addresses show on the datatracker's view of the document.
In this particular document's case:
<https://datatracker.ietf.org/doc/draft-ietf-6man-udpzero/>
the "Send Notices to" field contains
[email-masked], [email-masked], 
[email-masked]

You received it via the [email-masked] list (see the List-* headers in 
the header you copied below).

The history tab captured who put it there:
2012-10-04 	06 	Brian Haberman 	Notification list changed to : 
[email-masked] <mailto:[email-masked]>, 
[email-masked] 
<mailto:[email-masked]>, [email-masked] 
<mailto:[email-masked]>

Hope that helps,

RjS

---

From: Russ Housley <[email-masked]>
Date: Fri, 26 Oct 2012 15:23:03 -0400

I'd be glad to hear your suggestion.  Send it if you like, or we can talk at the codesprint.

Russ