Subject: [TOOLS-DEVELOPMENT] Filename Checks in I-D Submission Tool

From: Russ Housley <[email-masked]>
Date: Thu, 19 Apr 2012 13:49:31 -0400

This draft submission does not follow traditional convention: draft-iiban-01.txt

The IESG discussed this situation today, and we do not want to get overly prescriptive, but we think that submission of this form should require an additional acknowledgment step. That is, if the filename is of this form draft-<something>-<version>.<extension>, then a screen should be displayed with the filename conventions and a choice to proceed / cancel.

The tools team is not being asked to make up the text.  That is already available in http://www.ietf.org/ietf-ftp/1id-guidelines.html.

Does anyone have suggestions for the easiest way to implement this additional check?

Russ

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 23 Apr 2012 13:53:32 +0200

Hi Russ,

On 2012-04-19 19:49 Russ Housley said:
> The IESG discussed this situation today, and we do not want to get
> overly prescriptive, but we think that submission of this form should
> require an additional acknowledgment step. That is, if the filename
> is of this form draft-<something>-<version>.<extension>, then a
> screen should be displayed with the filename conventions and a choice
> to proceed / cancel.
> 
> The tools team is not being asked to make up the text.  That is
> already available in
> http://www.ietf.org/ietf-ftp/1id-guidelines.html.
> 

When the naming of this draft was first mentioned, on the wgchairs list
if I recall correctly, I started a new revision of idnits which would give
an error for such a filename (based on the existing 1id-guidelines text).

What you're indicating above is that this is too strong (as it would
give an idnits error on submission, only permitting manual submission)?

Or would the manual submission route be an acceptable implementation
of what the IESG prefers?

I can easily make this an idnits warning instead, but that would not
give the additional acknowledgement step you request.

Moving this out of idnits entirely would give a mismatch between what
the submission tool requires and what idnits says based on 1id-guidelines,
which is probably sub-optimal.

Best regards,

	Henrik

---

From: Russ Housley <[email-masked]>
Date: Mon, 23 Apr 2012 10:12:11 -0400

> which is probably sub-optimal.

The IESG does not want to spend a huge amount of time fine tuning a policy.  The return on that investment will be small.  That is the reason for the suggestion that the poster can proceed after a click.

Russ

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 23 Apr 2012 17:26:06 +0200

Hi Russ,

On 2012-04-23 16:12 Russ Housley said:
> The IESG does not want to spend a huge amount of time fine tuning a
> policy.  The return on that investment will be small.  That is the
> reason for the suggestion that the poster can proceed after a click.

Understood.  I guess my point is that we currently have 3 possible
outcomes of policy checks in the submission tool; this will add a 4th
one.  We currently have:

	* no warnings or errors -- autoposting is possible
	* warnings -- warnings are shown, but require no ack;
			     autoposting is possible
	* errors -- manual posting is possible, but not autoposting

We will now add a 4th outcome, with one policy check assigned to this
category:

	* 'questionables' -- autoposting is possible only after
	  reading and acknowledging an additional warning screen.

So I was wondering if this case was special enough to warrant this
additional outcome, or if we could handle it through one of the
existing 3.

Anyway; I'll start working on implementing 'questionables', even if I
have some reservations about the proliferation of ways to handle and
present policy checks.

Best regards,

	Henrik