Subject: [TOOLS-DEVELOPMENT] Fwd: IPR Disclosure: Avaya Inc.'s Statement of IPR Related to draft-mostafa-mmusic-sip-cp-00

From: Russ Housley <[email-masked]>
Date: Mon, 9 Jan 2012 11:19:25 -0500

This situation does not seem useful to me.  The things that is posted does not indicate the commitment to provide something in the future nor does it indicate the commitment to c).  Maybe something like:

" Commitment to reasonable and non-discriminatory licenses. More information will be provided in the future regarding licenses."

Russ

Begin forwarded message:

> From: "Romascanu, Dan (Dan)" <[email-masked]>
> Date: January 9, 2012 10:24:41 AM EST
> To: "Russ Housley" <[email-masked]>
> Cc: "Robert Sparks" <[email-masked]>, "Gonzalo Camarillo" <[email-masked]>
> Subject: RE: IPR Disclosure: Avaya Inc.'s Statement of IPR Related to draft-mostafa-mmusic-sip-cp-00
> 
> Hi Russ,
> 
> It looks like you are not reading this correctly. This is what results
> when filling in answer (d) in the submission form. 
> 
> Here is what was on the form:
> 
> VI. Licensing Declaration 
> The Patent Holder states that its position with respect to licensing any
> patent claims contained in the patent(s) or patent application(s)
> disclosed above that would necessarily be infringed by implementation of
> the technology required by the relevant IETF specification ("Necessary
> Patent Claims"), for the purpose of implementing such specification, is
> as follows (select one licensing declaration option only): 
> *	 a) No License Required for Implementers.
> *	 b) Royalty-Free, Reasonable and Non-Discriminatory License to
> All Implementers.
> *	 c) Reasonable and Non-Discriminatory License to All
> Implementers with Possible Royalty/Fee.
> *	 d) Licensing Declaration to be Provided Later (implies a
> willingness to commit to the provisions of a), b), or c) above to all
> implementers; otherwise, the next option "Unwilling to Commit to the
> Provisions of a), b), or c) Above". - must be selected). 
> 
> On the form AVAYA selected choice (d) which clearly commits to no worse
> licensing terms than selection (c).  Note that while not excerpted above
> that there are choices E (Unwilling to commit to a, b or c above) and F
> (where licensing policy is spelled out in prose).
> 
> I hope this clarifies. Of course, IANAL and if a more official response
> is needed our legal contacts need to be approached. 
> 
> Regards,
> 
> Dan
> 
> 
>> -----Original Message-----
>> From: Russ Housley [mailto:[email-masked]]
>> Sent: Sunday, January 08, 2012 4:02 PM
>> To: Romascanu, Dan (Dan)
>> Cc: Robert Sparks; Gonzalo Camarillo
>> Subject: Re: IPR Disclosure: Avaya Inc.'s Statement of IPR Related to
>> draft-mostafa-mmusic-sip-cp-00
>> 
>> Dan:
>> 
>> Am I reading this correctly?  There is not even a promise for fair,
>> reasonable, and non-discriminatory licenses.
>> 
>> Russ
>> 
>> 
>> On Jan 6, 2012, at 6:17 PM, IETF Secretariat wrote:
>> 
>>> 
>>> Dear Adel Mostafa:
>>> 
>>> An IPR disclosure that pertains to your Internet-Draft entitled "A
>> Mechanism
>>> for Negotiating Multi-Stream Continuous Presence Video in SIP"
>> (draft-mostafa-
>>> mmusic-sip-cp) was submitted to the IETF Secretariat on 2011-12-23
>> and has been
>>> posted on the "IETF Page of Intellectual Property Rights
> Disclosures"
>>> (https://datatracker.ietf.org/ipr/1661/). The title of the IPR
>> disclosure is
>>> "Avaya Inc.'s Statement of IPR Related to draft-mostafa-mmusic-sip-
>> cp-00."");
>>> 
>>> The IETF Secretariat
>>> 
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 10 Jan 2012 17:08:37 +0100

Hi Russ,

> " Commitment to reasonable and non-discriminatory licenses. More information will be provided in the future regarding licenses."

I take it this should replace the current text under 'd'?  This should be
easy enough to change -- should I do it for the next release?

Best regards,

	Henrik

> Russ
>
>
>
> Begin forwarded message:
>
>> From: "Romascanu, Dan (Dan)"<[email-masked]>
>> To: "Russ Housley"<[email-masked]>
>> Cc: "Robert Sparks"<[email-masked]>, "Gonzalo Camarillo"<[email-masked]>

---

From: Russ Housley <[email-masked]>
Date: Tue, 10 Jan 2012 11:47:18 -0500

I just want to make sure I am clear.  When the user chooses (d), the liaison statement does not tell the reader that this is the case.  To the reader, (e) and (d) are not distinguishable.

Russ

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 10 Jan 2012 19:25:42 +0100

Hi Russ,

On 2012-01-10 17:47 Russ Housley said the following:
> I just want to make sure I am clear. When the user chooses (d), the
> liaison statement does not tell the reader that this is the case. To
> the reader, (e) and (d) are not distinguishable.

Aha.  Ok, so no changes in the choices that can be made when submitting
a disclosure, but a clearer indication of when (d) has been chosen when
presenting the disclosure?

Best regards,

	Henrik

---

From: Russ Housley <[email-masked]>
Date: Tue, 10 Jan 2012 13:33:10 -0500

> presenting the disclosure?

That is correct.

Thank you.

Russ

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 12 Jan 2012 17:06:40 +0100

Hi Russ,

> " Commitment to reasonable and non-discriminatory licenses. More information will be provided in the future regarding licenses."

but this doesn't catch option 'a) No Licence Required for Implementers'.  Maybe
modify this to:

  "Commitment to Reasonable and Non-Discriminatory Licenses or No Licence
  Required for Implementers. More information will be provided in the future
  regarding licenses."

?

Best regards,

	Henrik

---

From: Russ Housley <[email-masked]>
Date: Thu, 12 Jan 2012 12:51:05 -0500

That is fine.  Thanks.