Subject: [TOOLS-DEVELOPMENT] PPTX Support

From: Russ Housley <[email-masked]>
Date: Fri, 6 Jan 2012 08:48:03 -0500

Currently, participants can upload slides in .ppt and .pdf files.  The new PowerPoint has become fairly well deployed.  What will it take to allow .pptx before the Paris meeting?

Russ

---

From: Bob Hinden <[email-masked]>
Date: Fri, 6 Jan 2012 07:13:26 -0800

Russ,

> Currently, participants can upload slides in .ppt and .pdf files.  The new PowerPoint has become fairly well deployed.  What will it take to allow .pptx before the Paris meeting?

What you say is true (I upgraded to Office 2011 for Mac yesterday), but the ability to also create pdf has also become very widespread.  Why not just support pdf and no longer accept ppt (in it's various forms)?

Thanks,
Bob

---

From: Russ Housley <[email-masked]>
Date: Fri, 6 Jan 2012 10:36:43 -0500

> What you say is true (I upgraded to Office 2011 for Mac yesterday), but the ability to also create pdf has also become very widespread.  Why not just support pdf and no longer accept ppt (in it's v…

I find the presentations end up being just a little bit different.  The way that some things "build" is not the same when saved as PDF.  And, tables somehow get messed up too, even between versions of PowerPoint.  For this reason, it is helpful to be able to provide the same version of PowerPoint to the remote participant.  They way, they have a better chance of seeing the same thing that is shown on the screen in the room.

Russ

---

From: Dave Crocker <[email-masked]>
Date: Fri, 06 Jan 2012 07:57:41 -0800

> I find the presentations end up being just a little bit different.  The way that some things "build" is not the same when saved as PDF.  And, tables somehow get messed up too, even between versions…

Perhaps the core requirement is for a stable, universal baseline format that 
MUST be included for all presentations, and then one or more optional formats 
that MAY be included.[1]

Given that model, supporting any and all popular additional formats is merely a 
matter of interest and work rather than policy.

Presumably, pdf would be the stable, universal, required form.

d/

[1] Folks might note some similarity between this meta-model and the way we do 
protocols. It also would match the current RFC and I-D model of requiring txt 
but allowing some other formats.

---

From: Russ Housley <[email-masked]>
Date: Fri, 6 Jan 2012 11:14:26 -0500

Dave:

> Perhaps the core requirement is for a stable, universal baseline format that MUST be included for all presentations, and then one or more optional formats that MAY be included.[1]
> 
> Given that model, supporting any and all popular additional formats is merely a matter of interest and work rather than policy.
> 
> [1] Folks might note some similarity between this meta-model and the way we do protocols. It also would match the current RFC and I-D model of requiring txt but allowing some other formats.

Yes, but...

The proceedings only include the PDF.  As Bob points out, this is getting better and better across all platforms.

I think the needs for following along in real-time are similar, but slightly different.  In this situation, we want to allow the remote participant to have the greatest possible opportunity to see the same think on his screen as is being seen in the room.

Russ

---

From: Dave Crocker <[email-masked]>
Date: Fri, 06 Jan 2012 08:22:29 -0800

On 1/6/2012 8:14 AM, Russ Housley wrote:
> I think the needs for following along in real-time are similar, but slightly
> different.  In this situation, we want to allow the remote participant to
> have the greatest possible opportunity to see the same think on his screen as
> is being seen in the room.

We used to support only txt.  We could upgrade the proceedings to include /all/
the versions a presenter includes, but /require/ that there at least be the PDF.

If the argument is that the quality of the experience can be better when using 
an alternative format, then I don't think it matters whether it is in real-time 
or later.  (I also don't see anything that makes it onerous to upgrade the 
proceedings, if we decide to upgrade the real-time.)

One version of "later" is simultaneously watching a video of the presenter 
speaking and then tracking with the slides.  I'll claim that this creates a 
viewing requirement that is identical to real-time.

d/

---

From: Bob Hinden <[email-masked]>
Date: Fri, 6 Jan 2012 10:11:22 -0800

Russ,

> I find the presentations end up being just a little bit different.  The way that some things "build" is not the same when saved as PDF.  And, tables somehow get messed up too, even between versions…

I agree that "builds" and animation" are lost, but I don't see that as a big loss for the proceedings.   My experience (or should I say our experience) regarding problems with tables and and other formatting, is more between different versions of powerpoint (e.g., Mac powerpoint and Windows powerpoint), than a pdf version.  I think this is one of the weakness of using powerpoint for the proceedings, the display may depend on the version of powerpoint and platform the user is running powerpoint on.  It's hard to tell from the file what platform/version the powerpoint file was created on.

For these reasons, I think pdf is a better format for the proceedings.

Thanks,
Bob

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 11 Jan 2012 19:00:08 +0100

Hi Russ,

On 2012-01-06 14:48 Russ Housley said:
> Currently, participants can upload slides in .ppt and .pdf files.
> The new PowerPoint has become fairly well deployed.  What will it
> take to allow .pptx before the Paris meeting?

I'm not sure whether you're asking about a technical change or a
policy change?

People have been uploading .pptx for some time now; the counts 
I have for recent meetings are:

	ietf  ppt pptx

	65    388   0
	66    314   0
	67    366   0
	68    364   0
	69    356   0
	70    401   0
	71    392   0
	72    357   0
	73    351   0
	74    337   0
	75    348   0
	76    314   0
	77    316  40
	78    317  49
	79    307 128
	80    275 152
	81    232 177
	82    192 214

The on-the-fly conversion to PDF which I do on the tools servers handle
most files in both .ppt and .pptx formats.

FWIW, I'm in favour of requesting chairs to always upload .pdf, with
the option of uploading other formats in addition.  Compared with the
on-the-fly conversion on tools, this has the benefit of making chairs
(and hopefully presenters) pay some attention to checking that the
.pdf versions actually look right, and making .pdf available from the
master repository already at meeting time.

Best regards,

	Henrik

---

From: Russ Housley <[email-masked]>
Date: Thu, 12 Jan 2012 11:46:50 -0500

Henrik:

The last time that I tried to upload a .pptx, it was rejected.  I was unaware that any change had been made.  Obviously that was a while ago.

Sorry for the noise,
  Russ