Subject: [TOOLS-DEVELOPMENT] Tools Call - 14 Dec 2011

From: Steve Conte <[email-masked]>
Date: Wed, 14 Dec 2011 08:56:53 -0800

Tools Call - 14 Dec 2011

Attendees:
Russ Housley
Robert Sparks
Steve Conte
Bob Hinden
Alice Hagens
Peter Saint Andre
Glen Barney
Alexa Morris
Tony Hansen
Karen Moreland
Ryan Cross
Ray Pelletier

1.  Projects In Work Update - Henrik

		a.  Back End Development - IOLA

		b.  Draft Tracking Tool - Yaco

2.  AMS Projects in Work Update - AMS

RC: in Denmark, looked at 8 top tools to see what it would take to convert it and started working
on each of the tools.  Have a good idea of what it'll take (no suprises).

Telechat tool to be finished before holiday break, then move to testing
sessions tool is complete
RH: When would testing be completed for all 8 of them?
RC: broke up those tools that HAVE to be ready at conversion.  10 days to complete very minimum
set of tools.
RH: End of January?
RC: it should be

		a.  Secretariat Tools Conversion - Way Forward

KM: plan was rolled out by HL about how conversion process would take place.  KM suggest that this
be flushed out a bit more for better understanding.
RH: Pls set up call to discuss this.  Right after the holidays

		b.  Agenda Scheduling Tool SOW

AM: still working on incorporating the comments.  Can have it finished by end of week/beginning of
next week if needed.
RH: Next step would be to bundle into RFP and discuss w/ community before release of RFP
RP: SoW going to IAOC on Jan 9.  No RFP to be put out before Jan 

3.  Taipei Code Sprint

RP: HL had passport issue and was delayed in arrival.. missed part of the sprint.
How can we structure things to be more robust and alleviate single point of failure
RjS: Will require additional pre-work with HL to ensure that we have redunancy (for set up) or 
enough setup done and tested prior.
Sprints put stress on infrastructure that at other times wouldn't receive that stress
RjS to discuss with HL about how to diminish the risk of single point of dependancies
Thing that slowed it down the most was database replication issues that were deep inside areas that
HL is maintaining
GB: had success with Antony (working with HL) and may be a good person to be the redundant point 
RH: Antony should have the proper access.. RjS to determine if he has enough knowledge of the 
infrastructure
RjS: Regardless, much was accomplished.  Just different than intended 

RjS: Sprint related, but not necessarily Taipei.  Would like to explore ways to encourage people
who have been productive at past sprints to make it to future sprints.  Brainstorming.  Some ideas
are to give financial support (plane ride).
PSA: Always prizes or other incentives.  May be a way to get new people involved.

4.  Mission Critical Tools

rfcdiff
RH: Issue is rfcdiff isn't very useful unless you have old ver of IDs onhand.
GB: Will provide single directory on ietf servers which will contain symlinks to all IDs that 
are available.  2 primary sources for drafts (FTP and Draft Archive).  Decicion to make Draft Archive
public has been made.  Some drafts from past are missing.  HL had a copy of those and efforts to 
recover missing drafts is under way.  
archive at ~/archive/id/
not sure of current status but HL has said that script is finished and will be implmenting
once done, tweak rfcdiff tool to point to new site and done
RH: please send a note to HL to find out status of implementation 

5.  NomCom Tools

TH: HL was last to touch them for NomCom11. Has proposals that are still in work.  
RH: tools are fairly fragile?
TH: there are a certain number of things that are not designed well to transport from one year
to another.  They don't separate the data repository from the tools themselves and any given years
data needs to be cleaned out prior to setting up tool for next year's NomCom.
TH: I'm probably the last person to make functional changes to the tool
RH: looking for somehting more stable and something that secretariat can do?  Spend money to make 
it happen?
TH: during changes last year, had to make changes directly in the structure.  no place to make 
changes that can be built and distributed where it's being actively used.  Confidentially is well
protected (use PKI) and all data is encrypted.  
RH: What's best way forward?
TH: separate code from data.  Could be done by either volunteer or by contractor.  
RH: Is there a specification on how tool should work?  This could make it easier to be less dependant
on those who have gone through the NomCom process to understand the code/flow
TH: all specs to date have all dealt with new features
RjS: Suggestion: if we have the time to do it, can we schedule the call in Jan with TH and HL and other
volunteers to try to get some knowledge transfer.  Can get someone to come in and capture conversation
to find out what really does need to happen.  Maybe have an empty instance during the call so it 
can be reviewed.
TH: clone in non-production place would have to be done first to respect confidentiality.
RH: Who is able to clone?
TH: Henrik
GB: Believes that some of the tools are on the secretariat server, but not fully sure.  HL indicated 
that the process of cloning was difficult but maybe it can be cloned (with assist from HL) to clone
on secretariat servers.
RH: Would like this done before the NomCom after next.
RH: TH, can you write a short SoW to work out how to get from current to proposed?
TH: Yes

6.  Tracker Project Issues
		http://wiki.tools.ietf.org/tools/ietfdb/wiki/ProjectList 

RH: (looking at Tracker Ext Project List)
Status shows items that have been completed.  

xml2rfc
AH: main surprise was 5741 boiler plate wasn't working correctly, ticket has been assigned

RFC/IANA: backend issues.  IANA response delayed as they respond to IANA contract with DoC

7.  AOB	

RjS: Mail archive tool document has received the comments that will get.  Inside comments is 
suggestion to change discussion about internationalized email.
Person was asserting that EAI was done
RjS: WG status is in the document.  Suggest we take it out
RH: Next step is to send out an RFC 

-----
Steve Conte
Internet Leadership Programmes
The Internet Society
[email-masked]

---

From: Tony Hansen <[email-masked]>
Date: Wed, 14 Dec 2011 22:41:01 -0500

On 12/14/2011 11:56 AM, Steve Conte wrote:
> ...

So, I had a quick exchange of email with Henrik about the nomcom tools. 
What follows is mostly my recollections with a few things thrown in by 
Henrik.

Here is a quick overview of the nomcom tools. This should be a good 
starting point for generating a SOW.

The nomcom tools can be split into two areas: the public view and the 
private view. Both the public and private view requires the user to log 
in to the tools.ietf.org domain. A private key is needed for access to 
individual comments.

The public area is split into these sections:
     Home | Nominate | Requirements | Questionnaires | Provide Comments 
| Logout Info

The private area has these additional sections:
     Help | Charter | Nominees | Enter Nomination | Feedback: Interview 
/ 3rd-party | Templates | Send Email | CryptoKey | Wiki

Where there are "duplicates" between the public and private areas, for 
example the public Nominate and the private Enter Nomination pages, the 
private versions typically do the same thing but allow you to enter 
additional information, such as entering a nomination on behalf of 
someone else. This allows for "anonymous" entries.

The CryptoKey page is used to enter an individual's private key. It gets 
stored into a session cookie and is used to access individual comments. 
Without the private key, individual comments don't appear. (The 2010 
CryptoKey page is broken now, so I can no longer enter my private key to 
look at pages needing it.)

Some of information needs to be configured at the beginning of the year, 
such as the list of nomcom members, who the liaisons are, which 
positions are open, etc.

The public home pages is filled in with similar information, but right 
now they're just written out and formatted however the (presumably) 
chair feels. A lot of those pages *could* be filled in automatically 
from the configuration files.

Other information gets filled in as people are nominated and other 
people make comments.

I did some poking around and found it interesting how much of the 
previous nomcom private sites are visible without being a member of 
those nomcoms. While I can't see what the individual comments are, I 
*can* tell who all was nominated for which positions, how many people 
made comments on each individual, who it was who made those comments, 
and when they made those comments. I tend to think that this is bad, and 
it appears to have been fixed for the 2011 pages.

I can't log in to the server where the previous-years' tools are on at 
the moment (no response from the ssh server), so can't verify some 
things. So the following is from memory:

The biggest thing I remember from the tools is that there is no 
separation whatsoever between the files that make up the web site, the 
files that are configuration (e.g., lists of members, positions, etc) or 
that get filled in once each year (e.g., the public intro page), and the 
data files that get created during the course of the nomcom season.

Henrik has a script which will create an cleaned empty site for a new 
year's nomcom from the site of previous year's nomcom. In this way, you 
can't lose any of the changes/updates done during the previous year.

I'm sure that the task could be simplified considerably by just 
introducing a couple subdirectories under the "private" root or in 
parallel trees -- one each for configurable files and the dynamic data 
files, and then moving the appropriate files into place. Such a 
separation shouldn't be too hard to do. The next step is to create a 
template for the configuration directory that contains unfilled-in 
versions of each of those files. The resulting code and configuration 
template could then be put into source control.

At this point, deploying updates to an existing nomcom's site would be 
done from the source tree, instead of making changes directly to the 
live tree. Deploying an update would only change the web pages and not 
the configuration files or the associated data files.

Similarly, creating a new version (say, for another year's nomcom) no 
longer requires copying a previous version and "cleaning it up" -- 
instead, you just deploy the new version into the new web area and 
configure it, just like all of our other tools.

This also allows us to easily create a test version that can be used to 
work on a rewrite.

The immediate enhancements to the nomcom site that I was envisioning 
were all oriented towards supporting the various votes that the nomcom 
takes while it does its work. Some of these are similar in many ways to 
the many survey sites that are out there, however would be managed 
specifically under our environment for privacy. But there are also some 
specific types of votes that it would be useful to support, such as 
supporting condorcet and weighted voting in addition to simpler votes 
like yes/no. The chair and co-chair will need to be able to look at the 
raw data, while individual voters should be able to look only at the 
results from the voting plus their own vote. The biggest code change 
needed to support this is that an additional private key will be needed 
for the chair and co-chair.

Henrik does not think we should continue to carry the current code 
forward -- the site is ripe for a rewrite, and preferably a rewrite 
using Django. The old code was OK as an initial hack; it's now 
appropriate to do a new take on this.

     Tony