Subject: [TOOLS-DEVELOPMENT] MPLS WG Secretary with real problems

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 26 Aug 2011 17:38:17 +0100

HI,

We are in a bit of a mess.

The MPLS WG secretary is blessed with a long email address
([email-masked]). Apparently this causes tools login a big
problem with truncation at 30 characters. 

The result seems to be a variety of messy symptoms not limited to:

- duplicate login credentials created
- tools crashes on login
- able to log in but not to do anything
- duplicate entry appearing on MPLS charter page

This is stopping Martin from doing work and pushing the work back on chairs, AD,
and secretariat.

My ideal fix would be that we support >30 characters. I going to guess this is a
DB problem not just a compile-time limit.

Failing that, and assuming that martin does not want to change job to work for a
company with a shorter name (or change his own name to something more compact)
we will find a suitable short email address for him, and ask you to flush his
record and start again.

Please advise.

Thanks,
Adrian

> -----Original Message-----
> From: Martin Vigoureux [mailto:[email-masked]]
> Sent: 26 August 2011 17:11
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: Tidying links on the MPLS charter page
> 
> Adrian,
> 
> I had some fears about this and it might be that I had good reason
> to have some:
> I can log on the Meeting Material Manager but do not have any right
> any more to do anything ... (can't upload the minutes for example)
> I do not know if it is a bug of the MMM or that removing an instance
> of my address from the charter page had this impact.
> A similar thing happened in the past when I was removed from the
> list [email-masked]. I lost all my rights.
> 
> I'll send the minutes to Wanda but we'll need to have this fixed.
> 
> Thanks for your help.
> -m
> 
> Le 14/08/2011 16:49, Adrian Farrel a écrit :
> > Hi,
> >
> > Two things that I don't believe need IESG approval.
> >
> > http://datatracker.ietf.org/wg/mpls/charter/ shows...
> >
> >     Secretaries:
> >         Martin Vigoureux<[email-masked]>
> >         Martin Vigoureux<[email-masked]>
> >
> > Although Martin is remarkably present, I think there is only one of him. Can
you
> > sort this out?
> >
> >
> > http://datatracker.ietf.org/wg/mpls/charter/ also shows...
> >
> >       The Working Group chairs tracking of the working group documents can
be
> >        viewed at http://www.tla-group.com/~mpls/mpls-wg-docs.htm
> >
> > The content at this is URL is very out of date and is not maintained. Could
you
> > please remove this paragraph?
> >
> > Thanks,
> > Adrian.
> >
> >

---

From: Glen <[email-masked]>
Date: Fri, 26 Aug 2011 09:44:32 -0700

Adrian -

Yes, this is a database problem, and is being handled in the redesign.  But
there is no solution for it at this time.  The short email address is the
correct solution.  Something from gmail would be fine.

Then have him contact the IETF secretariat, and they will make the change.

Glen
Glen Barney
IT Director
AMS (IETF Secretariat)

On Fri, Aug 26, 2011 at 05:38:17PM +0100, Adrian Farrel wrote:
> > Le 14/08/2011 16:49, Adrian Farrel a ?crit :
> > > Hi,
> > >
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 29 Aug 2011 15:08:52 +0200

Hi,

I've now changed the 30-character limit on usernames in the IETF database
and in Django's User model (the new limit is 64 characters).  Unless there
are limitations elsewhere in the system, it should now be possible for people
with long email addresses to log as WG chairs and do their stuff.  

Best regards,

	Henrik

On 2011-08-26 18:44 Glen said:
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Glen <[email-masked]>
Date: Mon, 29 Aug 2011 09:54:27 -0700

Martin -

The IETF Secretariat (AMS) is the "to whom" in this case.  :-) I've forwarded
this on to the secretariat team, and one of them will look into this, fix
it, and recontact you directly when its done.

Thanks,
Glen
Glen Barney
IT Director
AMS (IETF Secretariat)

On Mon, Aug 29, 2011 at 04:29:59PM +0200, Martin Vigoureux wrote:
> Henrik, all
>
> thanks! Adrian had in the meantime kindly provided me with an alias, just 
> in case.
> So I can now log in the datatracker, but that does not solve all my
> issues, sadly.
> The issue is that when I log in the Meeting Material Manager (and
> after having selected either 81st or 82nd meeting), I end up on a
> page with two bullets:
>  * Upload Agenda/Minutes/Presentations
>  * View Meeting Materials Page
> and there is no link associated to the first bullet text (while there
> is for the second).
> This might be explained by the fact that I might not be Secretary of the 
> MPLS WG any more (in the databases I mean)
> Indeed, when I log in the IETF Meeting Session Request Tool  I get:
> The list below includes those working groups for which you or your co-chair 
> has requested sessions at the upcoming IETF meeting. You can click on an 
> acronym to initiate changes to a session, or cancel a session:
>
>     NONE
>
> Normally it is written MPLS instead of NONE.
> This is most surely related to the request from Adrian to remove one
> instance of my e-mail address that was appearing twice on the charter page 
> of MPLS WG (see bottom of thread). I however fail to understand how the 
> request to remove a duplicate e-mail address can lead to removing me my 
> Secretary rights and role. This is the second time this happens ...
>
>
> Therefore, to whom is responsible for these:
>
> would it be possible that I:
> * be able to log and operate as per my rights in the various tools 
> pertaining to the Secretary role (Meeting Session Request Tool, Meeting 
> Materials Manager, datatracker, ...)
> * be subscribed (in case I was automatically un-subscribed) to 
> [email-masked]
> * but not subscribed to [email-masked]
> * and that my e-mail address only appears once on the MPLS WG Charter page
> my e-mail address is: [email-masked]
>
> maybe removing all references to me and my address and restarting from 
> scratch might be a good idea.
>
> thank you.
>
> regards,
> martin
>
> Le 29/08/2011 15:08, Henrik Levkowetz a ?crit :
>> Hi,
>>
>>>> My ideal fix would be that we support>30 characters. I going to guess this is a