Subject: Re: [TOOLS-DEVELOPMENT] Tools-Related Notes from IESG Retreat

From: Robert Sparks <[email-masked]>
Date: Wed, 6 Jul 2011 13:58:31 -0500

A brief checkpoint/followup :

On May 3, 2011, at 6:43 AM, Peter Saint-Andre wrote:

> Here are some rough notes from IESG discussions yesterday.
> 
> ###
> 
> Tools-Related Notes from IESG Retreat
> May 2011
> 
> Legend:
>  AI = action item
>  FR = feature request for the wish list
>  FYI = merely an informational note
> 
> AI: add a cookie to choose format below document "header" on
> datatracker.ietf.org (e.g., plain text vs. HTML)

Not yet done, being tracked as bug 682 (see <http://trac.tools.ietf.org/tools/ietfdb/wiki/EnhancementIdeas>)

> 
> AI: re-add ability to Last Call on RFC to go from Proposed to Draft

Coding done - should be in release soon (if not already in current release)

> 
> FYI: moving to one button (no longer "Edit" vs. "Change state")

Being tracked as bug 683
> 
> AI: allow "AD is watching" as initial state

Bug 684

> 
> FYI: add sub-State for "Waiting on WG"? use "External Party" instead
I don't know if we're doing anything with this.
> 
> AI: don't show DISCUSS box unless click "discuss" radio button
Fixed in a previous release
> 
> FR: at https://datatracker.ietf.org/iesg/agenda/documents/ allow
> "Download PDFs" (or other formats)
Bug 685
> 
> FYI: move historical discusses to History tab? No strong desire for this...
Nothing done for this
> 
> FYI: might need template for media type registrations (these are IETF
> contributions because asking for IETF consensus) -- no need for
> "registration-*" yet, Pete and Peter to follow up after IANA-related
> discussions happening now
Nothing done for this
> 
> FYI: possible need for "liaison-*" in the future, as well
Nothing done for this
> 
> AI: want to see IPR disclosures in auto-generated Last Call text
Done in a previous release
> 
> FR: pull downrefs into idnits
Peter - can you expand on what we were asking for here?
> 
> AI: auto-include abstract in write-up
Done in a previous release
> 
> FR: wrap the preview for "save and send email"
Done in a previous release
> 
> ###
> 
> 
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 06 Jul 2011 13:08:59 -0600

> Peter - can you expand on what we were asking for here?

As I recall, some IESG members thought it would be a nice feature for
the idnits tool to warn you about downrefs but also incorporate
information from the downrefs registry:

http://trac.tools.ietf.org/group/iesg/trac/wiki/DownrefRegistry

Peter

-- 
Peter Saint-Andre
https://stpeter.im/