Subject: [TOOLS-DEVELOPMENT] Tools Call: 13 July 2011

From: Steve Conte <[email-masked]>
Date: Wed, 13 Jul 2011 08:43:07 -0700

Standard disclaimer applies in relation to mistakes and typos.

Steve

-----

IETF Tools Call - 13 July 2011

Attendees:
Ray Pelletier
Robert Sparks
Steve Conte
Alice Hagens
Alexa Morris
Bob Hinden
Russ Housley
Julian Reschke
Karen Moreland
Henrik Levkowetz
Glen Barney

Agenda:

1.  DB Conversion Update (IOLA)

HL: WO#5.  They are starting to see the end of the work but suspect that one more WO will
be needed.  Holiday season currently in europe, so will impact the work during.  Sept
is approx time for completion.

Enough pieces are in place that it can be used with other work.

Yaco started coding against new schema.  no feedback yet.

AM: asking if AMSL can also get the new schema so that their programmers can also start
coding against new schema

2.  xml2rfc Update (Concentric Sky)

HL: have completed the online tool.  HL to do some testing against it.
RP: Proposal was that command line tool testing done by June 13.  Was it complete then
or is it newly finished
HL: started looking at it about 3 weeks ago.  Would be helpful if Alice or Sandy to do
testing as well.  HL to send information to RFC Editor
JR: in old tool, there is a set of test cases that should be tested against new tool 
AH: Willing to test, please send along the information 
RP: any idea when GUI will be available?
HL: not yet.  based on hours they've reported, HL is estimating 2-3 weeks

3.  WG Charter Tool Update (IOLA)

HL: IOLA has started on this.  Nothing except a few starter commits 

4.  ID Tracking Tool Update (Yaco)

HL: Yaco has started and HL has set up a branch for them utilizing the new schema.  Only
a few commits as well.  Developer says he's very overloaded.  No real progress at the 
moment.
RP: Should we speak with Angel regarding this?

5.  Quebec Code Sprint Update
		Signed Up
		Enhancement Ideas

RP: Showed current signups and scheduled work.  
RJS: There may be some additional people, will reach out to them
Scheduled work is OK
#683 to be moved up in the list
#609 (survey tool) - A wiki was put up to handle pieces of this (interop part).  Question
on viability is how often does IETF do surveys.  Currently using Survey Monkey for surveys.

RJS: is part of the sprint to be used to train people on the new DB schema?
HL: should be able to have people coding against the new schema
RJS: Not really any detailed description on how the models are supposed to work.  Is this
captured elsewhere?
HL: they're in spots in more detail but not complete either.  How much documentation is
needed vs. looking at the code?
RJS: they need an introduction
Will IOLA be at sprint?
HL: No
Skype or Jabber?
HL: Having them avail via jabber may be very useful.  Will reach out to IOLA
RJS: will it make sense to spend 30mins to reintroduce the larger pieces 
HL: Yes

To be done towards the start of sprint.

6.  Projects Update

RP: 
11 projects compeleted (listed on posted document)
7 works in progress 

IOLA to perform actual DB conversion (as opposed to Yaco)

Bids: back end development due by 20 july, questions due today

13 awaiting work.  tools mgmt committee to discuss this after this call. 

HL: WO#5 estimating to be completed in Aug, WO#6 in Sept.

Forecasts published

RH: Agenda Scheduling Tool?
RP: Specs are on the update
AM: first specs by Quebec - end of august.  RFP by mid-september.  Completion until 
probably after Taipei.

AM: question about liasion tool.  fwd'd mail from elliot lear regarding some requests
that the users had for changes.  Can we do this?
HL: yes

RP: is there a process to capture change requests (for any tool)
HL: not really.. would be good to put it in trac
RP: can that be put into priority tickets
HL: not really priority, is an enhancement ticket and only priority depending on the related
tool.
RP: is there an online form?
HL: yes.  email is not set up to create tickets
RH: should occasionally go through these change requests and then determine if it should 
be converted into an RFP
HL: an idea would be to put a link that would pre-populate some data as opposed to going
through the standard ticket submission channel
RH: can we put that into the sprint priority?
HL: yes

7.  AOB

RJS: sent requirements to email archive and searching system.  Please take a look and 
respond as appropriate.
RH: supports this.  need to make some progress on this.

-----
Steve Conte
[email-masked]

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 13 Jul 2011 09:47:09 -0600

My apologies, I neglected to add this call to my calendar. :(