Subject: Re: [TOOLS-DEVELOPMENT] Errata tool feature requests

From: Alice Hagens <[email-masked]>
Date: Wed, 25 May 2011 19:03:35 -0400

Pete,

Thank you for sending along these requests.

On May 16, 2011, at 4:57 PM, Pete Resnick wrote:

> (I understand the tools team doesn't work on the RFC Editor pages. Thought I would Cc in case this is of interest to them.)
> 
> Two change requests for the errata tool:
> 

To be clear, this is regarding the RFC errata verification system (which is used by "stream managers" to change the content and/or status of errata reports), not the public errata system.

> 1. Instead of an "Edit or Verify", please make it an "Edit" button and let me change to whatever state (including "Reject" and "Hold for Document Update") in there. I've screwed up twice, forgetting to save an edit and then clicking "Hold for Document Update". It would be nice if I could set the correct status inside of the Edit screen.
> 

It seems the one-click action of the "Hold for Document Update" button (as described on http://www.rfc-editor.org/how_to_verify.html) is causing this issue. The "Hold for Document Update" path is the only status change that works in this manner; the others have "Preview" and "Edit Again" options.

In general, errata are edited before their status is changed.  Often the submitted report has a typo or has the incorrect type (Editorial/Technical), or the verifier wants to add a note, so 'Edit or Verify' is a typical first step for errata processing. 

> 2. Please allow me to go back and change errata that I have edited, at least for some short period of time. As I said above, I've screwed up a few already and it would be nice to fix them without having to bug the RFC Editor staff.
> 

What period of time would you recommend?  The concept was that errata (especially once their status is changed) would be fairly static over time in order to be useful.

Thank you.

Alice
for the RFC Production Center

> Thanks,
> 
> pr
> 
> -- 
> Pete Resnick<http://www.qualcomm.com/~presnick/>
> Qualcomm Incorporated - Direct phone: (858)651-4478, Fax: (858)651-1102
>

---

From: Robert Sparks <[email-masked]>
Date: Fri, 27 May 2011 12:29:40 -0500

Hi Alice -

A couple of followup comments inline:

> In general, errata are edited before their status is changed.  Often the submitted report has a typo or has the incorrect type (Editorial/Technical), or the verifier wants to add a note, so 'Edit o…

Actually, that's far from clear from the interface. Any new verifier is going to be extremely reticent to hit the edit or verify button if the goal is to reject or hold for document update.
(It was a long time before I figured out by myself I could make that edit step and then not choose verify).

We can leave notes for future IESG members on the IESG wiki, but it would make it far more likely that the right thing "just happened" if you either separated edit out as a standalone interface, or
integrated hold and reject onto the same form with verify.

> What period of time would you recommend?  The concept was that errata (especially once their status is changed) would be fairly static over time in order to be useful.

Brainstorming:

One approach you might consider is adding a "Please revert this to reported" button. You could then code (and change at your discretion) logic that either automatically approved and executed the request, or sent email to a human to determine if it's the right thing to do. One initial policy might be to automatically approve those requests if the most recent change was within the last 24 (or perhaps fewer hours).

That said, while I agree with Pete that it would be nicer if we didn't have to interrupt someone else's day because we bumped a button wrong, I don't think we're at the point where just handling it with email between people as we do now is over-burdensome. 

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development