Subject: [TOOLS-DEVELOPMENT] The cookie option for selecting datatracker behavior is still not working well - what can we do differently?

From: Robert Sparks <[email-masked]>
Date: Mon, 16 May 2011 10:15:32 -0500

Hi -

The cookie(s) editable by <http://datatracker.ietf.org/cookies/> are not being persisted sufficiently by some folks browsers.
It may be that the choice of leaving such cookies around is beyond their control.

David, for instance, is still having to repeatedly re-opt to get the full draft on the tracker's main document page.
This is quite frustrating (I had a similar experience before the lifetime of the cookies were changed around Prague),
and it's likely to become more of a problem as we allow greater customization of what the tracker displays.

Are cookies really the best tool for this? Should we consider moving this state into the database associated with a login instead?

RjS

p.s. For this particular bit of configuration, I'm frequently asked why the default is to show a truncated version of the draft instead
of the full version, making truncation an option. My understanding is that this makes it far less likely that a mobile user would 
download a large document (a very large mib for example) that they didn't intend to read right now anyhow. Was there any other 
motivation for the sense of the choice as it is currently implemented?

---

From: Glen <[email-masked]>
Date: Mon, 16 May 2011 08:37:42 -0700

On Mon, May 16, 2011 at 10:15:32AM -0500, Robert Sparks wrote:
> Hi -
> The cookie(s) editable by <http://datatracker.ietf.org/cookies/>
> are not being persisted sufficiently by some folks browsers.

Robert -

We use cookies on the mail IETF website for style sheet selection persistence,
and are not aware of anyone having problems (which may mean that there are
problems and nobody has complained yet).  But perhaps looking at what we did
might be helpful?
 
> p.s. For this particular bit of configuration, I'm frequently
> asked why the default is to show a truncated version of the draft instead
> of the full version, making truncation an option. My understanding
> is that this makes it far less likely that a mobile user would 

Perhaps making the datatracker client-aware or mobile-aware might be a useful
alternative?

Glen

---

From: Glen <[email-masked]>
Date: Mon, 16 May 2011 08:39:44 -0700

> We use cookies on the mail IETF website for style sheet selection persistence,

s/mail/main/

Sorry.

Glen