Subject: [TOOLS-DEVELOPMENT] Tools Call: 20 Apr 2011

From: Steve Conte <[email-masked]>
Date: Wed, 20 Apr 2011 08:28:35 -0700

Greetings, 

Below is the notes from the tools call.  If you could look closely at item 5 to make sure I captured correctly the discussion of the WG Charter Tool v. the Milestone Management, I would appreciate it.  

Thanks,

Steve

-----

IETF Tools Call - 20 April 2011

Attendees:

Ray Pelletier
Steve Conte
Alexa Morris
Julian Reschke
Glen Barney
Ryan Cross
Robert Sparks
Karen Moreland
Peter Saint-Andre
Russ Housley
Alice Hagens
Bob Hinden
Tony Hansen

Agenda:

0.  Code Sprint Results

RjS: No list prepared, can send a list of items achieved if needed
significant amount of new functionality
lots of work post-code sprint 
10-12 participants
JR: Tony and JR worked on xml2rfc and made changes on that day 
RH: Tony worked a long time after to get xml2rfc out 
RP: would like to see a public update.. email or website for tools to get more
visibility
RH: Yes..  SC to get data from HL and RjS and build mockup

1.  DB Conversion Update

RH: IOLA is doing update.. broken the the work into several task orders.  All in so far
have been on schedule and under dollar
should be done (tooling) prior to Quebec City.  As it gets closer, decision on 
conversion timeline will be decided
RP: Just began work order #4 

2.  XML2RFC RFP

RP: RFP has been awarded and expecting work to begin in next week or so
HL to meet with team and set up time line for work 

3.  Agenda Scheduling Tool

GB: working on specs for this
AM: specs are in progress, shouldn't be much longer. Spec draft should be ready 
next week 
defining boundries on what sched tool is supposed to do 
RjS: Adam has a PoC built to show moving items within a schedule and reflecting
conflicts

4.  Tool Cmte Tool WishList

Current wishlist is maintained at AMS and some of it in the code sprint pages

5.  IT Projects Update

RP: completed: 4, In work: 10
In work: Front end is under contract, waiting for acceptance from WG chairs
RH: will deploy real soon.
RP: WG Charter Tool specs: milestones management.. 
RH: during development of iesg charter tool, it became clear that there were different
models on how a charter works.  Composed of 2 parts; 1) description of work (prose), and
2) milestones.. managed by AD.  the database behind is that for each milestone there is a 
db record and a db record for prose.  chartering is all about prose.  AD can manage 
milestones without other AD approval. to develop separate spec for milestone management 
as second step to allow milestone management to be done by WG chairs.
RP: initial scope of work will go to development, will not be waiting for charter milestone
management work to delay tool development 
Back End Spec Req: in last call 

6.  Other

-----
Steve Conte
[email-masked]

---

From: Russ Housley <[email-masked]>
Date: Wed, 20 Apr 2011 12:00:15 -0400

Steve:

I guess my main point did not come through.  Current specification will manage the prose part of the charter -- and its approval process.  Another spec will be developed for the management of milestones, which will probably include more delegation to WG chairs

Russ

On Apr 20, 2011, at 11:28 AM, Steve Conte wrote:

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development