Subject: [TOOLS-DEVELOPMENT] Request for feature: use of "current" in a draft filename

From: Paul Hoffman <[email-masked]>
Date: Fri, 11 Feb 2011 18:36:16 -0800

Greetings. If I want to give out a URL that points to the latest diff on 
a draft, I need to know the version number. That is, my URL needs to 
look like:

http://tools.ietf.org/rfcdiff?url2=draft-ietf-somewg-someprot-10.txt

and I need to know that "10" is the latest version. What I would like is 
to have the URL always be:

http://tools.ietf.org/rfcdiff?url2=draft-ietf-somewg-someprot-current.txt

Thanks for considering this!

--Paul Hoffman

---

From: Robert Sparks <[email-masked]>
Date: Fri, 11 Feb 2011 20:58:15 -0600

Paul -

You can get the latest version of a draft without knowing its version number using a URL like:
<https://datatracker.ietf.org/doc/draft-ietf-payload-rfc4695-bis/>

For rfcdiff, what are you wanting to do the diff against? Current and Current - 1?

RjS

On Feb 11, 2011, at 8:36 PM, Paul Hoffman wrote:

> Greetings. If I want to give out a URL that points to the latest diff on a draft, I need to know the version number. That is, my URL needs to look like:
> 
> and I need to know that "10" is the latest version. What I would like is to have the URL always be:
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 11 Feb 2011 19:48:55 -0800

> For rfcdiff, what are you wanting to do the diff against? Current and Current - 1?

Exactly.