Subject: [TOOLS-DEVELOPMENT] Internet Draft Signatures

From: Lars Eggert <[email-masked]>
Date: Wed, 8 Dec 2010 16:42:57 +0200

Hi,

http://www.ietf.org/id-info/idsignatures.html

has these instructions to verify the p7s signatures:

openssl cms -verify -CAfile comodo.pem -content <id-file-name> -inform DER \
     -in <sig-file-name> -out /dev/null

However, openssl does not have a "cms" command on either Mac, FreeBSD or Ubuntu Linux?

Lars

---

From: Russ Housley <[email-masked]>
Date: Wed, 08 Dec 2010 10:00:11 -0500

Lars:

In April 2008, it was in OpenSSL 0.9.9.  I used it to test the syntax in
the Internet-Draft.  What version are you running?

OpenSSL 1.0.0 supports it too.

Russ

On 12/8/2010 9:42 AM, Lars Eggert wrote:
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development