Subject: [TOOLS-DEVELOPMENT] Author recognition in I-D submissions

From: Joerg Ott <[email-masked]>
Date: Fri, 12 Nov 2010 15:34:37 +0200

Hi,

I am having trouble with the automated author detection in
the I-D submission system.  Quite often, only two names get
recognized (out of three, in this case).

I am attaching one Internet Draft that had this problem
two days ago.  Varun Singh and myself were recognized as
authors, Igor Curcio was not.

Thanks,
Joerg

---

From: Julian Reschke <[email-masked]>
Date: Sat, 13 Nov 2010 10:24:35 +0100

On 12.11.2010 14:34, Joerg Ott wrote:
> ...

To those you'll be working on revising this code...

Please seriously consider to use the XML source when present (just run 
it through xml2rfc to see whether it matches the TXT submission), it'y 
way more reliable than parsing the plain text.

Best regards, Julian

---

From: Robert Sparks <[email-masked]>
Date: Sat, 13 Nov 2010 22:49:58 +0800

Hi Julian -

Do you have the time/interest to scan the contents of the repository now to see if there are any
instances of xml not rendering txt (or at least not matching authors)?
If there aren't any...

RjS
On Nov 13, 2010, at 5:24 PM, Julian Reschke wrote:

> Please seriously consider to use the XML source when present (just run it through xml2rfc to see whether it matches the TXT submission), it'y way more reliable than parsing the plain text.
> 
> Best regards, Julian
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Julian Reschke <[email-masked]>
Date: Sat, 13 Nov 2010 16:31:45 +0100

> instances of xml not rendering txt (or at least not matching authors)?

I could write a quick script that extract author information from the 
XML versions.

Do we have something we could diff the output against?

Best regards, Julian