Subject: Re: [TOOLS-DEVELOPMENT] [codesprints] Setting codesprint goals for IETF79

From: Peter Musgrave <[email-masked]>
Date: Fri, 1 Oct 2010 08:39:44 -0400

Hi Robert,

w.r.t.: "* Add a new tab for IPR disclosures (probably showing how
many there are in
   the tab title: e.g. "IPR disclosures (2)").

Are you asking for an IPR column in the WG page display of WG docs,
individual drafts and RFCs? If so - I can take a swing at that in
Beijing - since I was messing around there last time.

Peter Musgrave

On Fri, Sep 24, 2010 at 5:01 PM, Robert Sparks <[email-masked]> wrote:
> We have several things to accomplish during the upcoming codesprint.
>
> There are two new tools that should be ready for additional testing
> and polish - the liaison management tool and the ID submissions tool.
>
> We have a growing list of small things to work on that would have
> high impact for the people that have requested them. The full list is
> at <http://trac.tools.ietf.org/tools/ietfdb/wiki/EnhancementIdeas>.
> Here are a few examples that look addressable at the codesprint. (This
> is not at all comprehensive:)
>
>  * Periodically email the list of addresses on any given tools alias (like
>    rai-ads@ or draft-foo-bar@) to that alias to improve the chances that lists
>    that are wrong get corrected.
>
>  * Add a new tab for IPR disclosures (probably showing how many there are in
>    the tab title: e.g. "IPR disclosures (2)").
>
>  * Make it possible for an IESG member to add a comment (for the document
>    history) in the "change document state" dialog.
>
>  * Show the date of last change to the various writeups on the page displayed
>    on the IESG writeups tab.
>
>  * The Atom feed should include everything in the history tab, not just the
>    document_comments table.
>
>  * Allowing search by position: "any AD/AD name" has position
>    "any/Yes/NoObj/Discuss/..."
>
>  * Show "has IPR disclosures" flag in search result list.
>
> There are a few medium sized projects out there that I think could be done
> during the sprint, but would have a higher chance of success with a little
> bit of exploration/analysis before we get there. Please look through the list
> and see if there's something there that would solve a problem you are having.
>
> If you know of something that the sprinters should be working on, but don't see it
> on the EnhancementIdeas list, please add it, or send me a quick note and I'll make
> sure it gets there.
>
> Remember that you can download a current snapshot of the database at any time.
> Now might be a good time to bring your local development environment back into
> action. If you're new to the sprint or haven't set up a local environment before,
> these links will help:
>  <http://trac.tools.ietf.org/tools/ietfdb/wiki/SprintCoderSetup>
>  <http://trac.tools.ietf.org/tools/ietfdb/wiki/SprintDatabase>
>
> If you're able to sprint, but haven't signed up yet, please do so now
> at <http://trac.tools.ietf.org/tools/ietfdb/wiki/IETF79SprintSignUp>
>
>
> _______________________________________________
> codesprints mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codesprints
>

---

From: Robert Sparks <[email-masked]>
Date: Fri, 8 Oct 2010 11:01:06 -0500

I don't think that's what the person originally suggesting that had in mind, but it sounds like a good idea!

My read of the suggestion below was to add a tab to the main document view. There has been work done in the
meantime that probably obviates the suggestion (at least the tab part) - there is a link on the document's main page.
It might be reasonable to include the # of disclosures in the text of that link.

RjS