Subject: Re: [TOOLS-DEVELOPMENT] Does anyone else find it hard tracking Discuss discussions?

From: Lars Eggert <[email-masked]>
Date: Fri, 29 Oct 2010 12:43:38 +0300

On 2010-10-29, at 12:35, Adrian Farrel wrote:
> I try to encourage authors to edit the subject line so that it reads (e.g.)
> "Adrian's DISCUSS on draft-ietf-foo-bar" but even when encouraged they forget,
> and most people don't receive the encouragement.

CC'ing the tools team. It should be super easy to make the datatracker generate personalized subject lines. (And I agree that that would be very nice.)

Lars

---

From: Jari Arkko <[email-masked]>
Date: Fri, 29 Oct 2010 13:29:22 +0300

Lars, Adrian,

> CC'ing the tools team. It should be super easy to make the datatracker generate personalized subject lines. (And I agree that that would be very nice.)

+1

(So far I have been relying on there being enough diversity that some 
people file a DISCUSS and COMMENT, others a DISCUSS, and yet others a 
COMMENT. But it only goes so far.)

jari

---

From: "Polk, William T." <[email-masked]>
Date: Fri, 29 Oct 2010 10:18:06 -0400

Yep.  Personalizing the subject line would be awesome.

On 10/29/10 6:29 AM, "Jari Arkko" <[email-masked]> wrote:

Lars, Adrian,

+1

jari

---

From: Robert Sparks <[email-masked]>
Date: Fri, 29 Oct 2010 09:56:22 -0500

Adding this to the sprint list as ticket #530

This is related to what I sent out earlier about the ->contents<- of the email that gets sent out as well (copied at the end for convenience).

One question on the subject line. In the past people have been concerned about having the "important" information of the subject
appear as early as possible, citing convenience in spotting it in pop-up notifications like growl provides, or making it easy to see
on phone email readers. Is this still important? I note that we will eventually have an IESG with two people with the same first name,
so full names on the subject will have to happen. 

Would you rather see

1) Adrian Farrel's DISCUSS and COMMENT on draft-ietf-rediculously-long-name-99
2) draft-ietf-rediculously-long-name DISCUSS/COMMENT: Adrian Farrel
3) DISCUSS/COMMENT draft-ietf-rediculously-long-name-99 Adrian Farrel

or some other permutation?

I have a mild leaning for 3)

RjS

On Oct 29, 2010, at 9:18 AM, Polk, William T. wrote:

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

......

> IESG -
> 
> I remember an earlier conversation asking if we could add information about the document being commented on
> and the ADs position at the time of the message to the _body_ of the text that generated for email. I recall the reaction
> being positive, and am planning to make that change during the codesprint, but wanted to check again that everyone
> thinks this is acceptable.
> 
> The change would make what currently looks like this:
> 
> Begin forwarded message:
> 
>> From: Robert Sparks <[email-masked]>
>> Date: September 29, 2010 10:50:58 AM CDT
>> To: [email-masked]
>> Cc: [email-masked], [email-masked]
>> Subject: COMMENT: <draft-ietf-fecframe-sdp-elements-09.txt>
>> 
>> Comment:
>> Section 3.3 copies text from -framework. Would a pointer be sufficient? It would
>> certainly be easier to maintain should these documents ever be revised.
>> 
>> 
>> 
>> 
> 
> look something like this: 
> 
>> From: Robert Sparks <[email-masked]>
>> Date: (the real date would go here, deleting for now since this was not actually sent)
>> To: [email-masked]
>> Cc: [email-masked], [email-masked]
>> Subject: COMMENT: <draft-ietf-fecframe-sdp-elements-09.txt>
>> 
>> Document: <draft-ietf-fecframe-sdp-elements-09.txt>
>> From: Robert Sparks (current position: No Objection)
>> 
>> Comment:
>> Section 3.3 copies text from -framework. Would a pointer be sufficient? It would
>> certainly be easier to maintain should these documents ever be revised.
> 
>> 
>> 
>> 
> 
> Thoughts?
> 
> RjS

---

From: Jari Arkko <[email-masked]>
Date: Fri, 29 Oct 2010 18:25:26 +0300

3

or 3b: "DISCUSS: draft-foo (Jari)"

---

From: Robert Sparks <[email-masked]>
Date: Fri, 29 Oct 2010 12:13:39 -0500

To make sure I understand, does this match 3b?

DISCUSS/COMMENT: <draft-ietf-geopriv-held-identity-extensions-05.txt> (Lars Eggert)

RjS

On Oct 29, 2010, at 11:08 AM, Ralph Droms wrote:

> +1 to 3b
> 
> - Ralph
> 
> On Oct 29, 2010, at 11:25 AM 10/29/10, Jari Arkko wrote:
> 
>> 3
>>

---

From: Jari Arkko <[email-masked]>
Date: Fri, 29 Oct 2010 21:19:19 +0300

Robert Sparks kirjoitti:
> *DISCUSS/COMMENT: <draft-ietf-geopriv-held-identity-extensions-05.txt> 
> (Lars Eggert)*
>

No, because I was suggesting the use of first name. I realize that it 
may not be unique in all cases. But I also like relatively short subject 
liunes.

Jari

---

From: Robert Sparks <[email-masked]>
Date: Fri, 29 Oct 2010 13:36:30 -0500

We could use just first names (assuming the tracker makes this easy) for now and leave breadcrumbs for someone to
change it later if we have a name collision.

What about the version number - for my purposes, that is pretty important. I would be willing to remove the .txt.

RjS

On Oct 29, 2010, at 1:19 PM, Jari Arkko wrote:

>> *DISCUSS/COMMENT: <draft-ietf-geopriv-held-identity-extensions-05.txt> (Lars Eggert)*
>> 
> 
> No, because I was suggesting the use of first name. I realize that it may not be unique in all cases. But I also like relatively short subject liunes.
> 
> Jari
> 
>> 
>> RjS
>>

---

From: Jari Arkko <[email-masked]>
Date: Fri, 29 Oct 2010 22:00:47 +0300

I'm not sure I understand why you need the version number, but for sure 
your process needs it for something. Anyway, I'm grepping for the draft 
name without the version number, because that lets me find the right 
mails regardless of any intervening draft updates (that might affect 
this or some other discuss). I'd prefer not to have extra characters 
like "<>", or the ".txt".

Jari