Subject: [TOOLS-DEVELOPMENT] history and IESG writeups, RFC Editor notes, etc.

From: Jari Arkko <[email-masked]>
Date: Fri, 10 Sep 2010 10:00:52 +0300

I have a functionality request that we talked about in yesterday's IESG 
telechat, and Russ asked me to forward it to you.

The tracker web interface gives a lot of information of what has changed 
on a document, e.g., 
https://datatracker.ietf.org/doc/draft-ietf-dna-simple/. For instance, 
it tracks state changes, adds comments from ADs, position changes, etc.

However, one thing that is not visible in this history list is the 
writeup changes. When a last call message, RFC Editor note, or approval 
message gets changes it is not reflected in the history. Seeing these 
changes in the history as well would be useful. For instance, in the 
case of the DNA document it was unclear to me yesterday when the RFC 
Editor note field had been edited, and I had to do a lot of research to 
find out that it was actually a very old piece of text, entered before 
the draft had changed.

Jari

---

From: Robert Sparks <[email-masked]>
Date: Mon, 13 Sep 2010 09:32:12 -0500

Jari - 

Would you get what you need from knowing what the date of last edit of any of the writeup sections was? 

RjS

On Sep 10, 2010, at 2:00 AM, Jari Arkko wrote:

> I have a functionality request that we talked about in yesterday's IESG telechat, and Russ asked me to forward it to you.
> 
> The tracker web interface gives a lot of information of what has changed on a document, e.g., https://datatracker.ietf.org/doc/draft-ietf-dna-simple/. For instance, it tracks state changes, adds comments from ADs, position changes, etc.
> 
> However, one thing that is not visible in this history list is the writeup changes. When a last call message, RFC Editor note, or approval message gets changes it is not reflected in the history. Seeing these changes in the history as well would be useful. For instance, in the case of the DNA document it was unclear to me yesterday when the RFC Editor note field had been edited, and I had to do a lot of research to find out that it was actually a very old piece of text, entered before the draft had changed.
> 
> Jari
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Jari Arkko <[email-masked]>
Date: Mon, 13 Sep 2010 17:55:52 +0300

The primary use case would be checking whether the draft or the RFC 
Editor note is newer. If the draft is newer, then the note is probably 
out of date or redundant.

jari