Subject: Re: [TOOLS-DEVELOPMENT] datatracker issue

From: Robert Sparks <[email-masked]>
Date: Thu, 12 Aug 2010 17:20:35 -0500

(Copying Henrik and tools-development)

David - 

What resolution is your screen?

RjS

ps - I just noticed that the right-click on the positions grid (to get directly to the
edit my position form) is not working for me.

On Aug 12, 2010, at 1:24 PM, David Harrington wrote:

> Hi,
> 
> I work on a rather small screen (10")
> 
> There is a popup that shows the discusses and comments (the "Positions
> for" popup). It constantly shifts to position itself relative to the
> 0,0 of my current screen. The bottom lines fall below the bottom of my
> screen, and I cannot scroll my screen to see the lines that are below
> the bottom of my screen because of this self positioning mode.
> 
> Can we change this popup so that it scrolls with the screen rather
> than constantly repositioning itself?
> or do it as a tab?
> 
> I am not sure whether this is a tools-team issue or a
> contracted-deliverable, so I'm nto sure who to send this to.
> 
> dbh
>

---

From: "David Harrington" <[email-masked]>
Date: Fri, 13 Aug 2010 12:39:04 -0400

Hi,

resolution: 1280x800 (on a 10x7" screen)

One problem is that the popup has a fixed size that can be longer than
the vertical size of my screen;
I scroll my screen all the way to the bottom, to expose the bottom of
the popup.
If that would cause the fixed-size popup to not fit fully on the
screen, the popup forces my screen to scroll down to keep the top
corner of the popup in view. It overrides my control of the scrollbar
position.
As a result, I cannot get to the edit position and close buttons at
the bottom of the popup.

dbh 

> -----Original Message-----
> From: Robert Sparks [mailto:[email-masked]] 
> Sent: Thursday, August 12, 2010 6:21 PM
> To: David Harrington
> Cc: IESG IESG; Henrik Levkowetz; IETF Tools Development
> Subject: Re: datatracker issue
> 
> ps - I just noticed that the right-click on the positions 
> grid (to get directly to the edit my position form) is not 
> working for me.
>

---

From: Lars Eggert <[email-masked]>
Date: Tue, 17 Aug 2010 17:08:29 +0300

Hi,

another datatracker issue: I just clicked the "request last call" button for draft-ietf-nsis-nslp-auth, but the status page shows it as being in this state for 15 days? Many of the other durations shown are also bogus (e.g. the one for draft-ietf-tcpm-tcp-lcd and draft-ietf-ippm-spatial-composition)

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 17 Aug 2010 16:43:22 +0200

Hi Lars,

This is due to some very brittle code which looks for particular strings
in the document comments in order to compute the number of days since the
last state change.  I've patched the production datatracker for another
of these earlier today, and now also fixed this one.  If you find docs
which still seem wrong, please let me know, as this most likely is caused
by additonal changes to the draft history comment format, introduced lately.

Best,

	Henrik

On 2010-08-17 16:08 Lars Eggert said:
> Hi,
> 
> another datatracker issue: I just clicked the "request last call"
> button for draft-ietf-nsis-nslp-auth, but the status page shows it as
> being in this state for 15 days? Many of the other durations shown
> are also bogus (e.g. the one for draft-ietf-tcpm-tcp-lcd and
> draft-ietf-ippm-spatial-composition)
> 
> 
> 
> 
> 
> 
> Lars