Subject: [TOOLS-DEVELOPMENT] Minutes: Tools Call 11 Aug 2010

From: Steve Conte <[email-masked]>
Date: Wed, 11 Aug 2010 08:58:55 -0700

As always, all mistakes are my own and please feel free to correct:

-----

Tools Call - 11 Aug 2010

Attendees:

Alexa Morris
Steve Conte
Bob Hinden
Robert Sparks
Julian Reschke
Ray Pelletier
Glen Barney
Henrik Levkowetz

Agenda:

0.  Bash the Agenda

1.  Database Conversion

RP - No update
HL - No update

2.  tools.ietf.org support

Henrik found someone to support, should start Monday

3.  Certificates Renewed

Wildcard certs for IETF, IESG, IAB domains.  Been issued, needs to be installed

4.  Maastricht Code Sprint Results

RjS: Several people working on various projects, lots of good work done.  New version
deployed during the week of IETF. 
- enhanced agenda tool
- ability to d/l documents during a telechat
- notes/editing section of datatracker
- more..

Has suggestions about improvements:
- duplicate instance of production environment on dev server including applications and
directory structure
- having an environment where a staged rollout can be run

Must have a dialog with Henrik and Glen about keeping the new server up to date with the
production server 

Way to find out what versions are on prod server would be helpful

Glen said that AMS is building a cloud computing model and would be able to offer a 
duplicate of the production server for this

HL isn't sure it's a big problem yet and whether or not to spend manpower to fix it
Glen's proposal makes sense once we're moved to the virtual servers

5.  CafePress Site Up - http://www.cafepress.com/ietf/7211616

Correct URL is: http://www.cafepress.com/ietf/
CafePress is up and running, currently 1 shirt and 2 stickers sold since 01 July

Ray to send a mail to IETF list to (re)announce the site

6.  IT Project Update

IESG Data Tracker Interface - IOLA
IDST Development - Cencentric Sky
LSMT Development - Yaco

HL - Yaco: lots of activity.  Patrick Falstrom discussed some really desirable features
and curious how to put them into the spec.

RP - Process is to get a statement of work that goes to the sub-committee to review/edit
and then send to Yaco as a change request for a new cost.  Get IAOC approval and then 
issue SoW to Yaco.

HL - IOLA is working on the items, HL hasn't seen the latest work from them.  Overall 
pleased with their work.  

Proceedings WO - AMS
Meetings WO - AMS

RP - Approved by IAOC and sent to AMS

Interim Meetings - AMS - under review
IAOC has call on 26 Aug and hopefully will be taken up there

Author & WG Specs
In Last Call

Author & WG Development Bid

7.  Other

Server in Japan is up.  HL has been able to log in and verify.  Setup of server will take place 
very soon  (in conjunction with server with crashed HD)

-----
Steve Conte
[email-masked]

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 12 Aug 2010 14:57:17 +0200

Hi,

>From yesterday's TMC meeting:

> Way to find out what versions are on prod server would be helpful

I've included a patch to django for the next release, which will
include complete debugging info in the error notification mails
which are sent when something fails in the production server.

This will be the same information which is presented as a web page
when an error occurs in the development environment, and it includes
things like the Python version, the python path, and the values of
local variables in all stack frames at the time of the error.  This
should make debugging production server exceptions much easier.

Best,

	Henrik