Subject: [TOOLS-DEVELOPMENT] Tools Meeting: 16 July 2010

From: Steve Conte <[email-masked]>
Date: Fri, 16 Jul 2010 08:58:22 -0700

Tools Call - 16 July 2010

Ray Pelletier
Henrik Levkowetz
Steve Conte
Robert Sparks
Russ Housley

1.  DB Conversion

HL - No changes of substance.  Some related work done, namely IESG tracker.  See item 6
RH - Needs to begin to have a final date as there are other dependancies on it.  To 
discuss in Maasricht

2.  Code Sprint

RH - Room Change to MECCafe
     Signup looks lighter than last time
RjS - It is lighter, but some previous folks just won't be in Maasricht
      Is there any specific task to be done?
RH - IESG Telechat page could be good
     - Button to D/L all docs that are on the agenda for offline reading
RjS - Is there any work to do around the new IESG datatracker?
HL - Quite possibly.. catch items as they come up. Old datatracker will still be there and will
be used as a fallback.

3.  Critical Tools Transfer
    idnits - Has been moved
    rfcdiff - GB waiting on Henrik.  HL sent it and GB put it up and should be OK to announce it
    www.ietf.org/tools/rfcdiff
    NomCom - All scripts on the server, but some functions that GB has to do (config, etc)

4. tools.ietf.org

HL - 5 servers total, 3 in production, 1 with disk problem.  Suggestions come in to make things
nicer.  HL either implements or discusses.

5. "User Manual for WG Chairs to use the
new features of the Datatracker" and to prepare a training session (for a future IETF meeting) 
to help the Chairs understand how to use the new features that we will be implementing for them.

Wiki somewhere to provide users manual to provide training on tools.
How to proceed?  
1) volunteer
2) whoever develops code makes first pass
3) 3rd party makes first pass

RjS - If tool is accessible enough, then volunteer is fine.  If tool is complex, then contractor
should be responsible

HL to set up new wiki branch within WG chairs wiki and then to choose chairs (newer chairs with 
less experience) to use tools to determine tool/manual complexity

6.  Dev Work Update
	Work suggestions

RP - 9 awards to date.  through rfp or bids process (those who already have an IDIQ contract).  
some of them have been completed. 
<Ray showing documents that show awarded contracts and work plan>

7.  Dev Support Mailing Lists

RH - Developers wanting a way to ask questions in the midst of their development.  HL suggested
mailing lists.  No requests to date.

8.  IETF Store

SC - Thanks go to Ray and Jorge Contreras for weeding through the Cafepress StoreID issues and 
we now have storeID of http://www.cafepress.com/ietf

Store is up, asked for suggestions.  RP asked for hats.  Will be updated.

SC to provide price structure and URL to Ray for IAOC information

8.  Other 

-----
Steve Conte
[email-masked]

---

From: "Glen Barney (AMS)" <[email-masked]>
Date: Fri, 16 Jul 2010 11:16:01 -0700

All -

Sorry I missed the call today; I am on vacation and the timing was unexpected.

>     www.ietf.org/tools/rfcdiff

Yes, it is okay to announce it, and I will be linking it to the site later
today.

>     NomCom - All scripts on the server, but some functions that GB

Henrik will be sending me instructions as soon as he said them ready, I
believe.

Also, I am deploying the 3.00 datatracker now.  It should be ready momentarily.

Glen

---

From: IETF Chair <[email-masked]>
Date: Fri, 16 Jul 2010 15:37:50 -0400

The rfcdiff tool has become critical to the IETF.  Many people use it
while reviewing drafts, and the RFC Editor uses it in the Auth48
process.  Recognizing our dependency on this tool, it has been installed
on the www.ietf.org web site, and it will be maintained by the
Secretariat with assistance from the tools volunteers.

http://www.ietf.org/tools/rfcdiff

Enjoy,
Russ