Subject: [TOOLS-DEVELOPMENT] AGENDA: Tools Call 9 April

From: Ray Pelletier <[email-masked]>
Date: Thu, 8 Apr 2010 11:47:30 -0400

All,

The Tools Call will take place Friday 9 April at 11:00 AM EDT  
(UTC-4).  WebEx details below.

Draft Agenda

1.  Bash the Agenda

2.  Database Redesign

3.  I-D Submission Tool

4.  WG & Author Front End Specs
	
5.  Mission Critical Tools Transfer to Secretariat
	idnits
	rfcdiff
	NomCom
	xml2rfc

6.  Datatracker UI Updates: Screen Scraping Concerns

7.  Anaheim Codesprint Results

8. Conte Update
	CafePress Store
	
9. Other Business
	Draft Signing Project
	Porting the IESG datatracker interface to Django

Ray

Topic: Tools Cmte
Date: Friday, April 9, 2010
Time: 11:00 am, Eastern Daylight Time (New York, GMT-04:00)
Meeting Number: 969 882 910
Meeting Password: (This meeting does not require a password.)

-------------------------------------------------------
To join the online meeting (Now from iPhones too!)
-------------------------------------------------------
1. Go to https://workgreen.webex.com/workgreen/j.php?ED=133137482&UID=0&RT=MiMxMQ%3D%3D
2. Enter your name and email address.
3. Enter the meeting password: (This meeting does not require a  
password.)
4. Click "Join Now".

To view in other time zones or languages, please click the link:
https://workgreen.webex.com/workgreen/j.php?ED=133137482&UID=0&ORT=MiMxMQ%3D%3D

-------------------------------------------------------
To join the audio conference only
-------------------------------------------------------
To receive a call back, provide your phone number when you join the  
meeting, or call the number below and enter the access code.
Call-in toll-free number (US/Canada): 1-866-699-3239
Call-in toll number (US/Canada): 1-408-792-6300
Global call-in numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=133137482&tollFree=1
Toll-free dialing restrictions: http://www.webex.com/pdf/tollfree_restrictions.pdf

Access code:969 882 910

-------------------------------------------------------
For assistance
-------------------------------------------------------
1. Go to https://workgreen.webex.com/workgreen/mc
2. On the left navigation bar, click "Support".

You can contact me at:
[email-masked]
1-703-652-9534

To add this meeting to your calendar program (for example Microsoft  
Outlook), click this link:
https://workgreen.webex.com/workgreen/j.php?ED=133137482&UID=0&ICS=MI&LD=1&RD=2&ST=1&SHA2=6Zn4RH7hNlr8nZtzzMM0UKS8XZRdLebMxzRLUqYCtRc=&RT=MiMxMQ%3D%3D

The playback of UCF (Universal Communications Format) rich media files  
requires appropriate players. To view this type of rich media files in  
the meeting, please check whether you have the players installed on  
your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php

Sign up for a free trial of WebEx
http://www.webex.com/go/mcemfreetrial

http://www.webex.com

IMPORTANT NOTICE: This WebEx service includes a feature that allows  
audio and any documents and other materials exchanged or viewed during  
the session to be recorded. By joining this session, you automatically  
consent to such recordings. If you do not consent to the recording, do  
not join the session.

---

From: Russ Housley <[email-masked]>
Date: Thu, 08 Apr 2010 11:56:12 -0400

The list in #5 should include I-D Submission Tool; it has been declared
critical.  Thus, we could merge #3 and #5.

We should report on the non-IETF Stream spec development RFP.

Russ

On 4/8/2010 11:47 AM, Ray Pelletier wrote:
> All,
> 
> The Tools Call will take place Friday 9 April at 11:00 AM EDT (UTC-4).
>  WebEx details below.
> 
> Draft Agenda
> 
> 1.  Bash the Agenda
> 
> 2.  Database Redesign
> 
> 3.  I-D Submission Tool
> 
> 1. Go
> to https://workgreen.webex.com/workgreen/j.php?ED=133137482&UID=0&RT=MiMxMQ%3D%3D
> <https://workgreen.webex.com/workgreen/j.php?ED=133137482&UID=0&RT=MiMxMQ%3D%3D> 
> 3. Enter the meeting password: (This meeting does not require a password.) 
> 4. Click "Join Now". 
> 
> <https://workgreen.webex.com/workgreen/j.php?ED=133137482&UID=0&ORT=MiMxMQ%3D%3D> 
> 
> Global call-in
> numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=133137482&tollFree=1
> <https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=133137482&tollFree=1> 
> Toll-free dialing
> restrictions: http://www.webex.com/pdf/tollfree_restrictions.pdf 
> 
> Access code:969 882 910 
> 
> [email-masked] <mailto:[email-masked]> 
> 1-703-652-9534 
> 
> <https://workgreen.webex.com/workgreen/j.php?ED=133137482&UID=0&ICS=MI&LD=1&RD=2&ST=1&SHA2=6Zn4RH7hNlr8nZtzzMM0UKS8XZRdLebMxzRLUqYCtRc=&RT=MiMxMQ%3D%3D> 
> 
> the meeting, please check whether you have the players installed on your
> computer by going
> to https://workgreen.webex.com/workgreen/systemdiagnosis.php 
> 
> http://www.webex.com <http://www.webex.com/> 
> 
> 
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Ray Pelletier <[email-masked]>
Date: Tue, 13 Apr 2010 08:58:56 -0400

Tools Call 4-9-10

Attendees
Henrik
Bob
Russ
Ray
Glen
Alexa
Julian

1.  Bash the Agenda

2.  Database Redesign
Henrik
	No change since Code Sprint
	Next steps: complete model uses new table and test it; import group  
info in current DT plus the history that has not been in the tracker

Russ
	IOLA Work Order has been approved by IAOC and they'll begin 1 May
	End of that move real tools to DB to see whether Henrik or Pasi model  
correct
	Also a Secretariat tool moved to test DB redesign; IAOC approved  
Rolodex yesterday

3.  Alternate Stream spec development RFP
	9 April announcement
	3 May Proposals due
	RFP for RFC Editor and IANA will be let after Alt stream complete

4.  WebEx API and Vols

Alexa
	Talked with Joe Hildebrand
	How to make WebEx easier to use for WG chairs;
	Suggestion was to work with tools team to automate initiation of WebEx
	Series of clicks, entry of host key, initiate the Innkeeper

Russ
	Where are script requirements?

Alexa
	Need to get Joe and ? together to work out

Russ
	Perhaps Joe and Joel should discuss

Henrik
	Probably not particularly complicated; requires some time to do and  
test

Russ
	May be able to use to time stamp audio stream
	Probably Joe, Joel and Henrik should discuss

Alexa
	WebEx Volunteers - start training people to take care of WebEx during  
the sessions
	Training by WebEx person, perhaps on Sunday in Maastricht and  
possibly again in Beijing
	Hildebrand to coordinate

Ray
	Scaling WebEx use is the issue; and that requires each session support

Russ
	Put burden on the WG Chair to get volunteers

Henrik
	Why so manpower intensive?

5.  Mission Critical Tools Transfer to Secretariat
	idnits - Done, but not announced
	rfcdiff - up in April

	NomCom - we (Glen and Henrik?) need to agree where to put it, rsync  
and test it.

	xml2rfc - new vol team maintaining; xml.resource.org --> using tools  
server(s) to respond
		breakage issues because code is pointing to xml.resource.org  Also  
on rfc editor servers.
		
	I-D Submission Tool - more complex proposition; not ready for beta  
testing; needs stuff done for alpha testing; maybe outsource it

	Glen - top priority; Secretariat getting complaints all the time

6.  Datatracker UI Updates: Screen Scraping Concerns
	No apps broken because no complaints
	Some other automation broken; some changes need to be made
		Vol or Contractor - Volunteer
		Code Sprinter? - Henrik to look for one

7.  Anaheim Code Sprint Results
	Different Data Tracker than going into it - Pasi over many months
	Will need many incremental changes and releases
	Better Code Sprints - organization, Django familiarity -
	
8. Conte Update
	CafePress Store
	Bob - have our lawyer get in touch with them and free up the ietf  
address for us.
	Ray - will get in touch with Jorge for that
	
9. Other Business
	Draft Signing Project for Internet Drafts
		Glen waiting on Russ, but 95% done
		Will be doing a dry run, last stage ask Verisign to sign the  
certificates
		Verisign donated smime certs for these I-D signing

	Porting the IESG datatracker interface to Django
		Work Order approved and IOLA to begin 1 May

On Apr 8, 2010, at 11:47 AM, Ray Pelletier wrote:

> The playback of UCF (Universal Communications Format) rich media  
> files requires appropriate players. To view this type of rich media  
> files in the meeting, please check whether you have the players  
> installed on your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php
>
> audio and any documents and other materials exchanged or viewed  
> during the session to be recorded. By joining this session, you  
> automatically consent to such recordings. If you do not consent to  
> the recording, do not join the session.