Subject: [TOOLS-DEVELOPMENT] AGENDA: Tools Call Friday

From: Ray Pelletier <[email-masked]>
Date: Thu, 11 Mar 2010 16:05:29 -0500

All;

We will have our monthly call Friday 12 March at 11:00 AM EST  
(UTC-5).  WebEx details below.

Draft Agenda

Tools Call 3-12-10

1.  Bash the Agenda

2.  Database Redesign

3.  IDIQ RFP

4.  WG & Author Front End Specs RFP

5.  Secretariat Tools for Redesigned DB: Task Orders

6.  Mission Critical Tools Transfer to Secretariat

7.  Datatracker UI Updates: Screen Scraping Concerns

8.  Anaheim Codesprint
	- IPR related to RFC 5683

9. Conte Update

10. Other Business

Ray

Topic: Tools Cmte
Date: Friday, March 12, 2010
Time: 11:00 am, Eastern Standard Time (New York, GMT-05:00)
Meeting Number: 960 126 032
Meeting Password: (This meeting does not require a password.)

-------------------------------------------------------
To join the online meeting (Now from iPhones too!)
-------------------------------------------------------
1. Go to https://workgreen.webex.com/workgreen/j.php?ED=132419052&UID=0&RT=MiMxMQ%3D%3D
2. Enter your name and email address.
3. Enter the meeting password: (This meeting does not require a  
password.)
4. Click "Join Now".

To view in other time zones or languages, please click the link:
https://workgreen.webex.com/workgreen/j.php?ED=132419052&UID=0&ORT=MiMxMQ%3D%3D

-------------------------------------------------------
To join the audio conference only
-------------------------------------------------------
To receive a call back, provide your phone number when you join the  
meeting, or call the number below and enter the access code.
Call-in toll-free number (US/Canada): 866-699-3239
Call-in toll number (US/Canada): 1-408-792-6300
Global call-in numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=132419052&tollFree=1
Toll-free dialing restrictions: http://www.webex.com/pdf/tollfree_restrictions.pdf

Access code:960 126 032

-------------------------------------------------------
For assistance
-------------------------------------------------------
1. Go to https://workgreen.webex.com/workgreen/mc
2. On the left navigation bar, click "Support".

You can contact me at:
[email-masked]
1-703-652-9534

To add this meeting to your calendar program (for example Microsoft  
Outlook), click this link:
https://workgreen.webex.com/workgreen/j.php?ED=132419052&UID=0&ICS=MI&LD=1&RD=2&ST=1&SHA2=AsV5I8J/KqGxbOW1jf91AS0tzg/h9De4zAqaFMzBwbo=&RT=MiMxMQ%3D%3D

The playback of UCF (Universal Communications Format) rich media files  
requires appropriate players. To view this type of rich media files in  
the meeting, please check whether you have the players installed on  
your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php

Sign up for a free trial of WebEx
http://www.webex.com/go/mcemfreetrial

http://www.webex.com

IMPORTANT NOTICE: This WebEx service includes a feature that allows  
audio and any documents and other materials exchanged or viewed during  
the session to be recorded. By joining this session, you automatically  
consent to such recordings. If you do not consent to the recording, do  
not join the session.

---

From: <[email-masked]>
Date: Fri, 12 Mar 2010 09:15:31 +0100

Quick status update from my side:

There has been three datatracker releases since the last call;
highlights include:
- New datatracker main page: http://datatracker.ietf.org/
- New per-WG pages in datatracker (not really deployed yet):
  http://db.tools.ietf.org/wg/
  http://db.tools.ietf.org/wg/tls/
  http://db.tools.ietf.org/wg/charter/
- Updated most pages to use the new look-and-feel
- Ripped out everything under /drafts/, and replaced it with
  redirects to the new document pages (under /doc/).
  The old /idtracker/ pages are not replaced yet, however.
- IETF meeting agenda page had partially working "row coloring"
  feature; it now works.
- Merged in Robert's code to move legacy liaison statements
  from hardcoded template to the database.

Cleaned my notes about datatracker enhancement ideas, and dumped
them to http://trac.tools.ietf.org/tools/ietfdb/wiki/EnhancementIdeas

Updated http://trac.tools.ietf.org/group/tools/trac/wiki/DataSources
page to describe currently available machine-readable data
sources (for building other tools based on datatracker data)

Wrote a script to check the database for violated foreign key, unique
column, and non-null column constraints (which MySQL is not currently
checking). The output was rather sad... manual edits and broken
scripts have left the database in a state where there's lot of broken
pointers (foreign keys). Some of them are causing exceptions from
datatracker code; I'll send SQL to fix the 10 or so most important
and/or easiest-to-fix constraints to Glen next week.

www.ietf.org main page now has "Internet-Drafts and RFCs Quick Search"
box, pointing to the new document search on datatracker.

Best regards,
Pasi

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Ray Pelletier
Sent: 11 March, 2010 23:05
To: [email-masked]
Subject: [TOOLS-DEVELOPMENT] AGENDA: Tools Call Friday

All;

We will have our monthly call Friday 12 March at 11:00 AM EST (UTC-5).  WebEx details below.

Draft Agenda

Tools Call 3-12-10

1.  Bash the Agenda

2.  Database Redesign

3.  IDIQ RFP

8.  Anaheim Codesprint

9. Conte Update

10. Other Business

Ray

Topic: Tools Cmte

3. Enter the meeting password: (This meeting does not require a password.)
4. Click "Join Now".

To receive a call back, provide your phone number when you join the meeting, or call the number below and enter the access code.

Access code:960 126 032

You can contact me at:
[email-masked]<mailto:[email-masked]>
1-703-652-9534

To add this meeting to your calendar program (for example Microsoft Outlook), click this link:
https://workgreen.webex.com/workgreen/j.php?ED=132419052&UID=0&ICS=MI&LD=1&RD=2&ST=1&SHA2=AsV5I8J/KqGxbOW1jf91AS0tzg/h9De4zAqaFMzBwbo=&RT=MiMxMQ%3D%3D

The playback of UCF (Universal Communications Format) rich media files requires appropriate players. To view this type of rich media files in the meeting, please check whether you have the players installed on your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php

http://www.webex.com<http://www.webex.com/>

IMPORTANT NOTICE: This WebEx service includes a feature that allows audio and any documents and other materials exchanged or viewed during the session to be recorded. By joining this session, you automatically consent to such recordings. If you do not consent to the recording, do not join the session.