Subject: [TOOLS-DEVELOPMENT] Notes: Tools Call 12 Feb 2010

From: Steve Conte <[email-masked]>
Date: Fri, 12 Feb 2010 08:38:06 -0800

As always, feel free to correct any misinterpretations I may have inserted.

-----

Tools Call - 12 Feb 2010

Pasi Eronen
Robert Sparks
Steve Conte
Glen Barney
Karen Moreland
Alexa Morris
Henrik Levkowetz
Bob Hinden

1.  Bash the Agenda

Item 8 - Rolodex - added

2.  Database Redesign

HL - Continuing with new approach importing document info from scratch instead of 
importing.  Not yet complete.  Runs longer every time and is giving errors.  
-- Expect to be done in a few days
-- Updated (slightly) some of the models.  Changes smaller than expected
-- Revised schema not sent out yet
http://merlot.tools.ietf.org/src/db/new/redesign/models.png

3.  IDIQ RFP

RH - 16 Bidders submitted
-- Round 2 asking for estimates against conversion from PERL scripts for IESG part
of the tracker
-- Narrowed the field of Bidders
-- IAOC decided to award 2 task order contracts
-- Moving along
-- Considering a 3rd task order contract
-- Names should be announced no later than Anaheim plenary

4.  WG & Author Front End Specs RFP

RH - Completed process, notification have been made
-- Ed J. chosen
-- Working on it now and draft by the I-D cutoff
-- will be visiting chairs at the anaheim mtg
-- BoF scheduled to discuss the RFP, looking for comments from community
-- Finalizing spec soon after Anaheim
-- Using IDIQ to build and award task order
-- Similar process for other streams (April)

5.  Secretariat Tools for Redesigned DB: Task Orders

RH - Task Order in place with AMS with Secritariat Contract
-- working on tools in a place so redesigned DB can be implemented
-- moving away from PERL scripts

GB - Rolodex Related (Item 8)
-- HL spent 1hr discussing Django administrative interface
-- interface may be able to be used to expedite some of the tools
-- interface viable option for numerous secretariat tools
-- AMS programmer retasked to use admin interface for rolodex
--- programmer said he was done with the rolodex
--- programmer to finish rolodex but then build it with the admin interface
-- SUGGEST that rolodex be put on hold as determinations are made to use admin
interface
-- Couple days to see new Rolodex
-- Couple of weeks for new roll out plan

6.  Mission Critical Tools Transfer to Secretariat

RH - Doing idnits and rfcdiff
GB - idnits package on his desk, soon but not yet
HL - Has next package ready for after nits is done, waiting for feedback before 
delivering
GB - should be within the next week or so
RH - Concerned that this is sliding with no clear end yet
PE - rfcdiff not useful without the draft archive, so questions the move to AMS
servers
RH - rfcdiff also used with RFC48, but could be policy issues to move the draft archive
GB - big directory on AMS server called draft archive
RH - Files are there, but not retrievable by anyone but Secretariat
PE - that archive is not complete

7.  Datatracker UI Updates: Screen Scraping Concerns

RH - Was going to deploy Pasi's UI but to ask people who were scraping to get feedback
or suggestions
PE - Email sent to ask to send mail to tools-discuss list, no responses
RH - Requests a 2nd mail be sent.. PE to send
PE - worked with Glen to change header info to determine which screens are scrapped
-- most scrapes are currently from searchbots
~/idtracker/draftname
-- almost all the information on that page is already avail via XML
RjS - Suggests that there be information on page for instructions on direct data feed
once move is made

8.  Rolodex

See Item 5

9.  Anaheim Codesprint

SC - received responses from HL and RH but nothign from Marcia yet.. SC has been 
time limited due to staff retreat but will ping Marcia on her pending items
HL - Work Agenda:
--Work on applications based on new tables
RjS - Anything specific?  HL - No.. anything
HL - would like people to start on things desired

idsubmission?  maybe! depending on conversion code completion

10. Conte Update

Conversion process in place with AMS
Lost tools server in Asia/Pac, clarifying and/or looking for a new location

11. Other Business

PE - 3k+ lines cleaned to iesg selection agenda and now in Django
-- datatracker UI update: waiting for HL to do a release  (HL should be able to do it 
right after this call)

-----
Steve Conte
[email-masked]

---

From: Steve Conte <[email-masked]>
Date: Sat, 13 Feb 2010 12:55:00 -0800

Seems I forgot to list Russ in the attendees.  Thanks Ray for catching that.

Steve

> As always, feel free to correct any misinterpretations I may have inserted.
Russ Housley
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

-----
Steve Conte
[email-masked]