Subject: [TOOLS-DEVELOPMENT] Tools status update

From: <[email-masked]>
Date: Fri, 11 Dec 2009 17:08:54 +0100

A short status update from me:

On 18 November 2009, Pasi Eronen wrote:
 
> What I plan to do in the next 2 months or so:
> 
> - Get authentication/authorization working according to the revised
> plans. Authentication part is quite simple with Django 1.1.
> Authorization (who is in IESG/who is chairing what WG/etc.) needs
> some work.

New authentication code was deployed on December 1. It also includes
authorization roles/groups for IESG and secretariat, but not yet WG
chairs.

Next step is to add authorization for WG/BOF/etc. chairs, but since we
don't yet have any code that would need it, it's currently not very
high on my priority list.

> - Implement missing pieces (text agenda, moderator script) needed to
> retire all Perl code related to IESG telechat agendas (3,500+ lines).

Code written and deployed. If Amy and Cindy agree, the moderator
script code might be tested for the next (December 17) telechat.  
Text agenda/IESG agenda package emails will hopefully be tested for
the January 7 telechat (also depending on Amy and Cindy).

Work on retiring the old code will start when we're satisfied with the
testing results (hopefully after the January 7 telechat).

> - Try to get the "new tracker UI for drafts/RFCs" completed and
> deployed (replacing the old pages).

Some small progress, but no finished code yet. This will be my top 
tools priority during the next 1-2 months.

Best regards,
Pasi

---

From: Russ Housley <[email-masked]>
Date: Fri, 11 Dec 2009 11:56:10 -0500

>tools priority during the next 1-2 months.

I think it would be useful to put a text box on the ietf.org front 
page that does the same search as https://datatracker.ietf.org/doc/

Is this easy or hard?

Russ

---

From: <[email-masked]>
Date: Fri, 11 Dec 2009 18:09:52 +0100

> page that does the same search as https://datatracker.ietf.org/doc/

This is very easy (no code needed), but see my reply to Glen 
and Alexa below:

Best regards,
Pasi

> -----Original Message-----
> From: Eronen Pasi (Nokia-NRC/Helsinki)
> Sent: 08 December, 2009 10:11
> To: 'ext Glen'; Alexa Morris
> Cc: Russ Housley
> Subject: RE: [IETF WEBSITE] New home page
> 
> This doesn't really need any code; the form on the main
> page could just have an URL pointing to datatracker:
> 
> <form action="http://datatracker.ietf.org/doc/search/" method="post" >
> <input name="name" type="text" />
> <input name="activeDrafts" value="on" type="hidden" />
> <input name="rfcs" value="on" type="hidden" />
> <input type="submit" value="Search" />
> </form>
> 
> However, I'm NOT 100% sure if we want to advertise the "new tracker
> UI" very widely yet.
> 
> There are couple of changes (at least making it work better without
> JavaScript enabled, and caching the HTMLized draft texts to avoid
> overloading the server) that I'd like to make before we announce
> it for general use. I hope to have these done within the next
> month or so.
> 
> Best regards,
> Pasi
>

---

From: Russ Housley <[email-masked]>
Date: Fri, 11 Dec 2009 14:41:23 -0500

I'm not sure we want to expose this yet, but I have found it very useful.

 From the front page of the ietf.org website, I think that it should 
probably not provide a list of documents that are on tools.ietf.org, 
but rather the ones on ietf.org itself.

Russ