Subject: [TOOLS-DEVELOPMENT] Tools Call

From: Ray Pelletier <[email-masked]>
Date: Sat, 14 Nov 2009 15:18:35 -0500

All;

The next tools call is on 20 November at 12:00 PM EST, 9:00PM PST.

I will resend WebEx meeting details with correct time.

Ray

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 17 Nov 2009 14:47:15 +0100

Ray,

You have conflicting time information. I assume you mean 9:00 AM PST,
i.e. 18.00 CET. Is this correct?

/Magnus

Ray Pelletier skrev:
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development
> 

-- 

Magnus Westerlund

IETF Transport Area Director
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: Ray Pelletier <[email-masked]>
Date: Tue, 17 Nov 2009 08:51:16 -0500

> i.e. 18.00 CET. Is this correct?

Ahh, you are right.  Jet lag.

Ray

---

From: <[email-masked]>
Date: Wed, 18 Nov 2009 16:44:27 +0100

I won't make the call (have to be at home with the kids, and the
grandparents are already booked :-), but here's a short summary
of what I've done since the last call:

- As of Tuesday of the IETF week, datatracker.ietf.org is running
with Django 1.1.1 instead of 0.96 (this involved 150+ SVN commits
between Stockholm and now).

Retired old tools:

- Replaced Mailing List Request Tool and Non-WG Mailing List
Submission Tool (2,000+ lines of rarely used code) with instructions
pages ("send these details to some AD, and ask him/her to forward
the approved request to ietf-action").

- Completed Django replacements for generating all_id.txt,
1id-index.txt, and 1id-abstracs.txt (based on code sprint work by
Robert and Jelte). These were deployed just before IETF76, and the
old Perl scripts were retired.

- Removed bunch of random Perl scripts: message-list (NomCom
announcements), email-list (List of WG mailing lists),
iesg-doc-status (Status of documents currently in IESG).

Minor improvements:

- Worked with Glen to improve mailing list archive usability: they
now show 500 messages per page (instead of 25), which makes the
browser's "Find" (inside a page) function much more useful.

- The public version of the IESG telechat agenda now includes the
"list of remaining action items" (Section 1.4), and proposed
charters (Sections 4.*).

- Did some clean-up for the Trac ticket system, so we can use
it again for keeping track of bugs and requested enhancements

What I plan to do in the next 2 months or so:

- Get authentication/authorization working according to the revised
plans. Authentication part is quite simple with Django 1.1.
Authorization (who is in IESG/who is chairing what WG/etc.) needs
some work.
  
- Implement missing pieces (text agenda, moderator script) needed to
retire all Perl code related to IESG telechat agendas (3,500+ lines).

- Try to get the "new tracker UI for drafts/RFCs" completed and
deployed (replacing the old pages).

(And I look forward to seeing some kind of of minutes from
the call :-)

Best regards,
Pasi

> -----Original Message-----
> From: [email-masked] [mailto:tools-development-
> [email-masked]] On Behalf Of ext Ray Pelletier
> Sent: 14 November, 2009 22:19
> To: [email-masked]
> Subject: [TOOLS-DEVELOPMENT] Tools Call
> 
> All;
>

---

From: Russ Housley <[email-masked]>
Date: Wed, 18 Nov 2009 15:52:43 -0500

I have 10:00 Eastern on my calendar for this call.  When was the time changed?

Russ

---

From: Ray Pelletier <[email-masked]>
Date: Wed, 18 Nov 2009 17:00:13 -0500

> I have 10:00 Eastern on my calendar for this call.  When was the  

Henrik reminded me that in deference to the early hour for the west  
coast USA we had concluded to hold the call 2 hours later.

Ray

---

From: Ray Pelletier <[email-masked]>
Date: Fri, 20 Nov 2009 06:04:29 -0500

All;

Draft Agenda for 11-20 Call.

Ray

Tools Call 11-20-09

1.  Database Redesign Update

2.  Secretariat Tools for Redesigned DB

3.  WG Chairs & Authors Front End

4.  TLP 4.0 -
		Changes to accommodate Alternative Streams
		Timeline - December TLP 4.0 ready for adoption (Maybe)

5.  Mission Critical Tools Xfer to Secretariat - Status
		rfcdif - install in another place in Dec
		idnits - install in another place in Dec

6.  RFC Production Center and RFC Publisher to AMS
	Transition Update

8.  Hiroshima Code Sprint Results

9.  Conte Update

10.  Python IDIQ Contract Update

---

From: Ray Pelletier <[email-masked]>
Date: Fri, 20 Nov 2009 11:54:57 -0500

WebEx Details:

Hello ,

Ray Pelletier invites you to attend this online meeting.

Topic: Tools Cmte
Date: Friday, November 20, 2009
Time: 12:00 pm, Eastern Standard Time (New York, GMT-05:00)
Meeting Number: 969 103 188
Meeting Password: (This meeting does not require a password.)

-------------------------------------------------------
To join the online meeting (Now from iPhones too!)
-------------------------------------------------------
1. Go to https://workgreen.webex.com/workgreen/j.php?ED=130324467&UID=0&RT=MiMxMQ%3D%3D
2. Enter your name and email address.
3. Enter the meeting password: (This meeting does not require a  
password.)
4. Click "Join Now".

To view in other time zones or languages, please click the link:
https://workgreen.webex.com/workgreen/j.php?ED=130324467&UID=0&ORT=MiMxMQ%3D%3D

-------------------------------------------------------
To join the audio conference only
-------------------------------------------------------
To receive a call back, provide your phone number when you join the  
meeting, or call the number below and enter the access code.
Call-in toll-free number (US/Canada): 866-699-3239
Call-in toll number (US/Canada): 1-408-792-6300
Global call-in numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=130324467&tollFree=1
Toll-free dialing restrictions: http://www.webex.com/pdf/tollfree_restrictions.pdf

Access code:969 103 188

-------------------------------------------------------
For assistance
-------------------------------------------------------
1. Go to https://workgreen.webex.com/workgreen/mc
2. On the left navigation bar, click "Support".

You can contact me at:
[email-masked]
1-703-652-9534

To add this meeting to your calendar program (for example Microsoft  
Outlook), click this link:
https://workgreen.webex.com/workgreen/j.php?ED=130324467&UID=0&ICS=MI&LD=1&RD=2&ST=1&SHA2=UkBaCJw0WkQZXvCtvK4cBlTPbRGHpOmxAzaYfTFSAro=&RT=MiMxMQ%3D%3D

The playback of UCF (Universal Communications Format) rich media files  
requires appropriate players. To view this type of rich media files in  
the meeting, please check whether you have the players installed on  
your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php

Sign up for a free trial of WebEx
http://www.webex.com/go/mcemfreetrial

http://www.webex.com

IMPORTANT NOTICE: This WebEx service includes a feature that allows  
audio and any documents and other materials exchanged or viewed during  
the session to be recorded. By joining this session, you automatically  
consent to such recordings. If you do not consent to the recording, do  
not join the session.

---

From: Ray Pelletier <[email-masked]>
Date: Fri, 20 Nov 2009 12:52:09 -0500

Tools Call 11-20-09

Attendees
Henrik
Russ
Magnus
Bob
Steve
Ray
Alexa

1.  Database Redesign Update
	Henrik - not a lot has changed since last update;
	Russ - Kurtis discussion, 2 weeks dedicated possible
	Henrik - says its doable

2.  Secretariat Tools for Redesigned DB
	Glen - technical perspective started rewriting tools in Django  
framework; clearly the way to go because IETF community using; started  
writing tools for things that were absent, like adding liaisons to  
liaisons db.
			Next tackling: Rolodex
			Proceeding with work.

3.  WG Chairs & Authors Front End
	Russ - Ed Juskevicius volunteered and began updating Henrik effort of  
2 years ago
			met with WG chairs in Hiroshima and will have next iteration out soon
			RFP for completion of work will be out Nov/Dec;
			Expect specs to be ready for Anaheim mtg 	for final comments
			Expect specs to be published in May
			Development to be awarded against the IDIQ contract

4.  TLP 4.0 -
		Changes to accommodate Alternative Streams
		Timeline - December TLP 4.0 should be ready for adoption
		Boilerplate will change for IRTF and IS, so changes to xml2rfc needed
		
5.  Mission Critical Tools Xfer to Secretariat - Status
		rfcdif - install in another place in Dec
		idnits - install in another place in Dec
		Henrik to handle with Glen.

6.  RFC Production Center and RFC Publisher to AMS
	Transition Update
	Glen - everything under control; no surprises at this point
		In progress; staged all basics; reviewing all material received; on  
track for 15 Dec
		Website - transfer next week to Trust, then update the domains
	Russ - any potholes?
	Glen - not right now; volume of scripts less than from NeuStar;  
however live programs and scripts about 4x that from NeuStar; messy,  
but nothing of concern; comfortable

8.  Hiroshima Code Sprint Results
	Henrik - completed transition to Django 1.1 from 0.96
		means authentication handling inside and outside of Dango all in one  
place
		Successful code sprint: Clear goal and accomplished it

9.  Conte Update
	Steve - Inventorying AMS core system; ID Tracker directory; 400 files  
- active and not. 	Python directory 2.38 review?  May not review.   
Next step to see where Web links are pointing to.  See what's live and  
getting rid of the orphans.

	Henrik - current release of Django data tracker is that 2.38  
directory.  No inventory needed.  All under version control.

10.  Python-Django IDIQ Contract Update

	Ray - RFP out.  Closes 11 Dec.
	More than 6 responses so far; one company at least among the group.
	Some more interesting than others.
	Expect contract awards in Q1

On Nov 20, 2009, at 11:54 AM, Ray Pelletier wrote:

> The playback of UCF (Universal Communications Format) rich media  
> files requires appropriate players. To view this type of rich media  
> files in the meeting, please check whether you have the players  
> installed on your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php
>
> audio and any documents and other materials exchanged or viewed  
> during the session to be recorded. By joining this session, you  
> automatically consent to such recordings. If you do not consent to  
> the recording, do not join the session.
>
>