Subject: [TOOLS-DEVELOPMENT] Call Friday 10 April

From: Ray Pelletier <[email-masked]>
Date: Thu, 9 Apr 2009 15:23:14 -0400

All;

We will have our monthly call tis Friday at 10:00 AM EDT (UTC-4).   
Call in details below.

Agenda:

1. SF Code Sprint

2.  Mission Critical Subcommittee

3. Datatracker Support Consensus

4.  Other

Ray

Access Code: 3269881

Country	Toll free number	Toll number	On-net*
ARGENTINA (ARG)	08008007323	01151717323	
AUSTRALIA (AUS)	1800359924		
AUSTRIA (AUT)	0800291800		
BAHAMAS (BHS)	18003890349		
BELARUS (BLR)	882000110035		
BELGIUM (BEL)	080039119	027924505	
BOTSWANA (BWA)	002698003000557		
BRAZIL (BRA)	08008873239	01149497323	
BULGARIA (BGR)	008001151067		
CANADA (CAN)	8005048071	6477233983	
CHILE (CHL)	800532833		
CHINA UNIFIED (CHINA TELECOM)	8008190328		
4006208035		
COLOMBIA (COL)	018009198715		
COSTA RICA (CRI)	08000150522		
CROATIA (HRV)	0800222927		
CYPRUS (CYP)	80096147		
CZECH REPUBLIC (CZE)	800142548		
DENMARK (DNK)	80703116	36927814	
DOMINICAN REPUBLIC (DOM)	18887514523		
ECUADOR (ECU)	1800010184		
ESTONIA (EST)	8000100225		
FINLAND (FIN)	0800772087	0923193947	
FRANCE (FRA)	0800941634	0174180779	
GERMANY (DEU)	08001014529	089710404600	
GREECE (GRC)	0080016122038715		
HONG KONG (HKG)		30508639	
HUNGARY (HUN)	0680015305		
ICELAND (ISL)	8008086		
INDIA (IND)	0008001006005		
0008001005002		
0008000012011		
000182		
INDONESIA (IDN)	0018030152030072		
IRELAND (IRL)	1800719953	16530905	
ISRAEL (ISR)	1809458715		
ITALY (ITA)	800182599	200617507	
JAPAN (JPN)	00531001557		
KAZAKHSTAN (KAZ)	88003337317		
KOREA, REPUBLIC OF (KOR)	00308140437		
KYRGYZSTAN (KGZ)	0080070077706		
LATVIA (LVA)	80000742		
LUXEMBOURG (LUX)	80023947		
MALAYSIA (MYS)	1800807136		
MEXICO (MEX)	0018005148260		
MOLDOVA, REPUBLIC OF (MDA)	080069001		
MONACO (MCO)	80093340		
NETHERLANDS (NLD)	08002658226	0207084835	
NEW ZEALAND (NZL)	0800440066		
NORWAY (NOR)	80056403	21033159	
PANAMA (PAN)	008002269745		
PERU (PER)	080070373	017057323	
PHILIPPINES (PHL)	180011100764		
POLAND (POL)	008001114567		
PORTUGAL (PRT)	800780606		
ROMANIA (ROM)	0800895088		
RUSSIAN FEDERATION (RUS)	81080022641012		
SAINT KITTS AND NEVIS (KNA)	18007449281		
SINGAPORE (SGP)	8001011437	64944158	
SLOVAKIA (SVK)	0800004237		
SOUTH AFRICA (ZAF)	0800990941		
SPAIN (ESP)	900800373	917911825	
SWEDEN (SWE)	0201400591	0114966102	
SWITZERLAND (CHE)	0800700285	0434569406	
TAIWAN (TWN)	0809092289		
TAJIKISTAN (TJK)	8108003337317		
THAILAND (THA)	001800656917		
UKRAINE (UKR)	88005042610		
UNITED ARAB EMIRATES (ARE)	8000170894		
UNITED KINGDOM (GBR)	08004960579	02079040084	
UNITED STATES (USA)	8005048071	3032480281	
URUGUAY (URY)	00040190114		
UZBEKISTAN (UZB)	810800121006		
VENEZUELA (VEN)	08001004179		

*On-net numbers may not be available in all areas of the countries  
indicated.

---

From: Ray Pelletier <[email-masked]>
Date: Fri, 10 Apr 2009 10:16:14 -0400

All;

Appears that holidays impacted today's attendance.  Accordingly we are  
rescheduling to Friday 24 April at 10:00 AM EDT (UTC-4).

A more flushed out agenda follows.

Thanks

Ray

Agenda:

1. SF Code Sprint
   Results
   Stockholm

2.  Mission Critical Subcommittee
   Define 'Mission Critical' tools and services
   Membership
   Review Process
   Acceptance Criteria (code, cost, etc)

3. Datatracker Support Consensus
   Datatracker from 00 - RFC#
   'Support' for Authors, WG Chairs, IESG, RFC Editor, IANA,  
Secretariat & community
   'Support' - tools and/or information

4.  Other
   - Tools Inventory Template

On Apr 9, 2009, at 3:23 PM, Ray Pelletier wrote:

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 10 Apr 2009 21:02:28 +0200

Ray,

It's Easter, and Good Friday on April 10th.  I didn't count on this call
going to be run today...

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 10 Apr 2009 21:03:54 +0200

Ah.  A call on Friday April 24th sounds much better than on Good Friday.

Best,

	Henrik

---

From: Ray Pelletier <[email-masked]>
Date: Wed, 22 Apr 2009 14:11:33 -0400

All,

A reminder of the call this Friday at 10:00 am EDT (UTC-4).  Agenda  
below.

Ray

On Apr 10, 2009, at 10:16 AM, Ray Pelletier wrote:

> All;
>
> Appears that holidays impacted today's attendance.  Accordingly we  
> are rescheduling to Friday 24 April at 10:00 AM EDT (UTC-4).
>

---

From: Lucy Lynch <[email-masked]>
Date: Wed, 22 Apr 2009 13:20:04 -0700 (PDT)

On Wed, 22 Apr 2009, Ray Pelletier wrote:

> All,
>
> A reminder of the call this Friday at 10:00 am EDT (UTC-4).  Agenda below.

All -

I've been thinking about the software maintenance issue and I think that
Henrik's suggestion that we use something like the deb-control file is
a good one. I've looked at the debian stuff and they have a set of 
standard package files the would get us started:

        Package: <package name>
        Version: <version string>
        Maintainer: <fullname email>
        Description: <short description>
        Section: <section>
        Priority: <priority>
        Essential: <yes|no>
        Architecture: <arch|all>
        Source: <source name>
        Depends: <package list>
        Pre-Depends: <package list>
        Recommends: <package list>
        Suggests: <package list>
        Conflicts: <package list>
        Replaces: <package list>
        Provides: <package list>

but we probably want a bit more information as things are scattered
among several platforms, sites, etc. I've started a list:

Module: <sub-module control info> - question, are there tools the multiple
                                     maintainers for sub-sets of code?
Maintainer_Backup: <fullname email>

Network_URI: <production site>
Backup_URI:  <backup site>
Beta_URI:    <test site>         - optional

Framework: <>                    - optional, do you need this?
Language: <program version>	 - i.e. python, perl, etc.
Revision_Control: <program uri>  - how and where to store/get the stuff

Supports: <package name(s)>      - may not be needed if we parse all
                                    control files

Change_Req: <timeframe>          - maintainer driven
Freeze_Req: <timeframe>          - this most likely relates to IETF
                                    meeting and submission dates
Contributors:<short description> - additional names
IETF: <critical:nice:etc>        - This one is for Russ ;-)
Additional_Orgs: <>               - ? do we track other orgs who use IETF
                                    tools - like I2 and XML2RFC?

and I'm sure I've missed some things that would be nice to have.

I know Ray was thinking that this would be a web form that the developers 
would fill in and then the results would provide a contact database. I 
think that may be backwards. I think we want a control file (or files) for 
each tool and a parser that will scrape the results, sync, and provide 
them to the team and to Ray (could be web-a-vized).

This would take a little work to regularize the data entry conventions,
but would end up being easier to maintain (as long as coders remember
to update the control file).

2 cents -

- Lucy

>> 'Support' for Authors, WG Chairs, IESG, RFC Editor, IANA, Secretariat & 
>> community
>>> We will have our monthly call tis Friday at 10:00 AM EDT (UTC-4).  Call in 
>>> details below.
>>> 
>>> Agenda:
>>> 
>>> 1. SF Code Sprint
>>>

---

From: Russ Housley <[email-masked]>
Date: Thu, 23 Apr 2009 14:31:35 -0400

What is the difference between Depends and Pre-Depends?

At 04:20 PM 4/22/2009, Lucy Lynch wrote:
>I know Ray was thinking that this would be a web form that the 
>developers would fill in and then the results would provide a 
>contact database. I think that may be backwards. I think we want a 
>control file (or files) for each tool and a parser that will scrape 
>the results, sync, and provide them to the team and to Ray (could be 
>web-a-vized).
>
>>>>We will have our monthly call tis Friday at 10:00 AM EDT 
>>>>(UTC-4).  Call in details below.
>>>>Agenda:
>>>>1. SF Code Sprint
>>>>ARGENTINA (ARG) 08008007323     01151717323 AUSTRALIA 
>>>>(AUS)     1800359924 AUSTRIA (AUT)        0800291800 BAHAMAS 
>>>>(BHS)        18003890349 BELARUS (BLR)       882000110035 BELGIUM 
>>>>(BEL)      080039119       027924505 BOTSWANA 
>>>>(BWA)        002698003000557 BRAZIL 
>>>>(BRA)    08008873239     01149497323 BULGARIA 
>>>>(BGR)      008001151067 CANADA 
>>>>(CAN)       8005048071      6477233983 CHILE (CHL)  800532833 
>>>>CHINA UNIFIED (CHINA TELECOM) 8008190328 4006208035 COLOMBIA 
>>>>(COL)    018009198715 COSTA RICA (CRI)   08000150522 CROATIA 
>>>>(HRV)       0800222927 CYPRUS (CYP) 80096147 CZECH REPUBLIC 
>>>>(CZE)   800142548 DENMARK (DNK) 80703116        36927814 
>>>>DOMINICAN REPUBLIC (DOM)       18887514523 ECUADOR 
>>>>(ECU)       1800010184 ESTONIA (EST)        8000100225 FINLAND 
>>>>(FIN)        0800772087      0923193947 FRANCE (FRA) 
>>>>0800941634      0174180779 GERMANY 
>>>>(DEU)        08001014529     089710404600 GREECE 
>>>>(GRC)       0080016122038715 HONG KONG 
>>>>(HKG)                30508639 HUNGARY (HUN)  0680015305 ICELAND 
>>>>(ISL)        8008086 INDIA (IND)     0008001006005 0008001005002 
>>>>0008000012011 000182 INDONESIA (IDN)        0018030152030072 
>>>>IRELAND (IRL)  1800719953      16530905 ISRAEL (ISR)   1809458715 
>>>>ITALY (ITA)  800182599       200617507 JAPAN (JPN)   00531001557 
>>>>KAZAKHSTAN (KAZ)    88003337317 KOREA, REPUBLIC OF 
>>>>(KOR)    00308140437 KYRGYZSTAN (KGZ)    0080070077706 LATVIA 
>>>>(LVA)      80000742 LUXEMBOURG (LUX)       80023947 MALAYSIA 
>>>>(MYS) 1800807136 MEXICO (MEX) 0018005148260 MOLDOVA, REPUBLIC OF 
>>>>(MDA)        080069001 MONACO (MCO)  80093340 NETHERLANDS 
>>>>(NLD)      08002658226     0207084835 NEW ZEALAND 
>>>>(NZL)    0800440066 NORWAY (NOR) 80056403        21033159 PANAMA 
>>>>(PAN)   008002269745 PERU (PER) 080070373       017057323 
>>>>PHILIPPINES (PHL)     180011100764 POLAND 
>>>>(POL)       008001114567 PORTUGAL (PRT)     800780606 ROMANIA 
>>>>(ROM) 0800895088 RUSSIAN FEDERATION (RUS)     81080022641012 
>>>>SAINT KITTS AND NEVIS (KNA)      18007449281 SINGAPORE 
>>>>(SGP)     8001011437      64944158 SLOVAKIA (SVK) 0800004237 
>>>>SOUTH AFRICA (ZAF)   0800990941 SPAIN 
>>>>(ESP)  900800373       917911825 SWEDEN 
>>>>(SWE)  0201400591      0114966102 SWITZERLAND 
>>>>(CHE)    0800700285      0434569406 TAIWAN (TWN) 0809092289 
>>>>TAJIKISTAN (TJK)     8108003337317 THAILAND (THA)    001800656917 
>>>>UKRAINE (UKR)      88005042610 UNITED ARAB EMIRATES 
>>>>(ARE)  8000170894 UNITED KINGDOM (GBR) 
>>>>08004960579     02079040084 UNITED STATES (USA) 
>>>>8005048071      3032480281 URUGUAY (URY)        00040190114 
>>>>UZBEKISTAN (UZB)    810800121006 VENEZUELA (VEN)    08001004179
>>>>*On-net numbers may not be available in all areas of the 
>>>>countries indicated.

---

From: Lucy Lynch <[email-masked]>
Date: Thu, 23 Apr 2009 12:57:27 -0700 (PDT)

> What is the difference between Depends and Pre-Depends?

the deb-control man page says:

Depends: <package list>
     List of packages that are required for this package to provide a 
non-trivial amount of functionality. The package maintenance software will 
not allow a package to be installed if the packages listed in its Depends 
field aren't installed (at least not without using the force options), and 
will run the postinst scripts of packages listed in Depends: fields before 
those of the packages which depend on them, and run prerm scripts before.

Pre-Depends: <package list>
     List of packages that must be installed and configured before this one 
can be installed. This is usually used in the case where this package 
requires another package for running its preinst script.

see: http://linuxreviews.org/man/deb-control/

note that control file items are mostly optional, so if there are
no pre-depends, conflicts, etc. the field just doesn't get used.

- Lucy

>> a good one. I've looked at the debian stuff and they have a set of standard 
>> package files the would get us started:
>>
>>        Package: <package name>
>> each tool and a parser that will scrape the results, sync, and provide them 
>> to the team and to Ray (could be web-a-vized).
>> 
>>>>> We will have our monthly call tis Friday at 10:00 AM EDT (UTC-4).  Call 
>>>>> in details below.
>>>>> Agenda:
>>>>> 1. SF Code Sprint
>>>>> ARGENTINA (ARG) 08008007323     01151717323 AUSTRALIA (AUS) 
>>>>> 1800359924 AUSTRIA (AUT)        0800291800 BAHAMAS (BHS) 
>>>>> 18003890349 BELARUS (BLR)       882000110035 BELGIUM (BEL) 
>>>>> 080039119       027924505 BOTSWANA (BWA)        002698003000557 BRAZIL 
>>>>> (BRA)    08008873239     01149497323 BULGARIA (BGR)      008001151067 
>>>>> CANADA (CAN)       8005048071      6477233983 CHILE (CHL)  800532833 
>>>>> CHINA UNIFIED (CHINA TELECOM) 8008190328 4006208035 COLOMBIA (COL) 
>>>>> 018009198715 COSTA RICA (CRI)   08000150522 CROATIA (HRV) 
>>>>> 0800222927 CYPRUS (CYP) 80096147 CZECH REPUBLIC (CZE)   800142548 
>>>>> DENMARK (DNK) 80703116        36927814 DOMINICAN REPUBLIC (DOM) 
>>>>> 18887514523 ECUADOR (ECU)       1800010184 ESTONIA (EST) 
>>>>> 8000100225 FINLAND (FIN)        0800772087      0923193947 FRANCE (FRA) 
>>>>> 0800941634      0174180779 GERMANY (DEU)        08001014529 
>>>>> 089710404600 GREECE (GRC)       0080016122038715 HONG KONG (HKG) 
>>>>> 30508639 HUNGARY (HUN)  0680015305 ICELAND (ISL)        8008086 INDIA 
>>>>> (IND)     0008001006005 0008001005002 0008000012011 000182 INDONESIA 
>>>>> (IDN)        0018030152030072 IRELAND (IRL)  1800719953      16530905 
>>>>> ISRAEL (ISR)   1809458715 ITALY (ITA)  800182599       200617507 JAPAN 
>>>>> (JPN)   00531001557 KAZAKHSTAN (KAZ)    88003337317 KOREA, REPUBLIC OF 
>>>>> (KOR)    00308140437 KYRGYZSTAN (KGZ)    0080070077706 LATVIA (LVA) 
>>>>> 80000742 LUXEMBOURG (LUX)       80023947 MALAYSIA (MYS) 1800807136 
>>>>> MEXICO (MEX) 0018005148260 MOLDOVA, REPUBLIC OF (MDA)        080069001 
>>>>> MONACO (MCO)  80093340 NETHERLANDS (NLD)      08002658226     0207084835 
>>>>> NEW ZEALAND (NZL)    0800440066 NORWAY (NOR) 80056403        21033159 
>>>>> PANAMA (PAN)   008002269745 PERU (PER) 080070373       017057323 
>>>>> PHILIPPINES (PHL)     180011100764 POLAND (POL)       008001114567 
>>>>> PORTUGAL (PRT)     800780606 ROMANIA (ROM) 0800895088 RUSSIAN FEDERATION 
>>>>> (RUS)     81080022641012 SAINT KITTS AND NEVIS (KNA)      18007449281 
>>>>> SINGAPORE (SGP)     8001011437      64944158 SLOVAKIA (SVK) 0800004237 
>>>>> SOUTH AFRICA (ZAF)   0800990941 SPAIN (ESP)  900800373       917911825 
>>>>> SWEDEN (SWE)  0201400591      0114966102 SWITZERLAND (CHE)    0800700285 
>>>>> 0434569406 TAIWAN (TWN) 0809092289 TAJIKISTAN (TJK)     8108003337317 
>>>>> THAILAND (THA)    001800656917 UKRAINE (UKR)      88005042610 UNITED 
>>>>> ARAB EMIRATES (ARE)  8000170894 UNITED KINGDOM (GBR) 08004960579 
>>>>> 02079040084 UNITED STATES (USA) 8005048071      3032480281 URUGUAY (URY) 
>>>>> 00040190114 UZBEKISTAN (UZB)    810800121006 VENEZUELA (VEN) 
>>>>> 08001004179

---

From: Ray Pelletier <[email-masked]>
Date: Fri, 24 Apr 2009 09:15:07 -0400

Attached for Agenda item 3.

Ray

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 24 Apr 2009 17:22:21 +0200

Hi Lucy, all,

Some comments on the control file fields, below:

>                                      maintainers for sub-sets of code?

I think we should take the easy path here and not provide sub-module control
info.  Instead we break any tool that has different maintainer and other
info for different parts of it as two or more tools with two or more
control files.

> Maintainer_Backup: <fullname email>

Not sure about this one....  

> Network_URI: <production site>

I have the equivalent of this in my control files already: "Url: <production site>",
so I agree it's something we should have.

> Beta_URI:    <test site>         - optional

I think both of the above may be somewhat useful, but I'd not focus on
them now...

> Framework: <>                    - optional, do you need this?

No, should be covered by the Depends: field

> Language: <program version>	 - i.e. python, perl, etc.

No, should be covered by the Depends: field

> Revision_Control: <program uri>  - how and where to store/get the stuff

Yes, good point, and I have a close equivalent of this in the control files
I use, with the label Source: .  Maybe call this "Repository:", to cover
both the case where there is an actual version control system, and the case
where the author just exposes a URL where you can get the latest version.

> Supports: <package name(s)>      - may not be needed if we parse all

Agreed.  Explicitly setting this violates the DRY principle

> Contributors:<short description> - additional names

Ack.

> IETF: <critical:nice:etc>        - This one is for Russ ;-)

Maybe we can re-use Priority for this?

>                                     tools - like I2 and XML2RFC?

This is for later, I think.

> and I'm sure I've missed some things that would be nice to have.

I have a Category: field which can be any of:

	author
	chair
	display
	meeting
	news
	review
	search
	share
	stats
	support
	validation

depending on which rough category the usage of the tool is.

I also have an Author: field, which is something which is missing from
the Debian control files because they don't really need it, but it is
important for us.

Regards,

	Henrik

---

From: Lucy Lynch <[email-masked]>
Date: Fri, 24 Apr 2009 14:00:13 -0700 (PDT)

> Some comments on the control file fields, below:
<snip>

> info for different parts of it as two or more tools with two or more

makes sense to me

> Not sure about this one....

this may be a seperate issue from the control data - trying to slove the 
"who do you call when the maintainer can't be reached?" question.

> I think both of the above may be somewhat useful, but I'd not focus on

fine by me

> where the author just exposes a URL where you can get the latest version.

I like Repository: !

> the Debian control files because they don't really need it, but it is

I like these as well -

- Lucy