Subject: Re: [TOOLS-DEVELOPMENT] Code Sprint Assignment

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 30 Nov 2007 22:30:39 -0800

I just read the attached assignment forms.

They are in my view completely unsuitable, in that 1) they
*grant a license* to the code, rather than deed the code to
the trust, and 2) potentially, in that they seem to grant licence
to run the code, also could be construed as granting patent rights.

*THIS IS NOT WHATR WE WANT*, in my opinion.

We *don't want* any patent rights granted to the trust, and we
would prefer the code to be given to the trust, rather than a
*license* to the code be granted.

I'm going to suggest that we during the sprint tomorrow don't
go into signing of these assignment forms, and instead work out
this afterwards and have something more appropriate signed later.

	Henrik

(Who seriously wonders if the lawyer who worked out this have any
idea at all of what is wanted and needed here.  Grr.)

On 2007-11-29 15:07 Ray Pelletier said the following:
> Cullen and others
> Attached are re-worked Individual and Corporate Assignment forms.
> 
> Ray.
> 
> 
> Cullen Jennings wrote:
> 
>> Thanks for getting this out. It looked mostly like what I expected  
>> with the exception I was a little surprised not to see the usual  
>> indemnification clause. Are you looking to have everyone get their  
>> employers to sign it?  In a case like mine where clearly I am doing  
>> this as part of my employment with Cisco, it seems like likely about  
>> the same agreement could be used with Cisco as Assignor but would  
>> have to redo the first para to remove the "individual" part. Once it  
>> is clear what changes are needed here so that a employer is doing the  
>> assignment, I'd like to go ask Cisco legal to see what they say.
>>
>> I'm pretty concerned that in the case of Cisco legal they will not be  
>> keen on this because it requires them to sign this before they see  
>> what patents or trade secrets they would be releasing under it.
>>
>> Cullen
>>
>> On Nov 19, 2007, at 7:28 AM, Ray Pelletier wrote:
>>
>>> All;
>>>
>>> Attached is a proposed Assignment document prepared by our attorney  
>>> for your review and comment.
>>>
>>> Will this work?
>>>
>>> Ray
>>> <IETF_Code_Sprint_Assignment_11-19-07.DOC>
>>> <mime-attachment.txt>
>>
>>
>>
>> ------------------------------------------------------------------------
>>
>> _______________________________________________
>> TOOLS-DEVELOPMENT mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/tools-development

_______________________________________________
TOOLS-DEVELOPMENT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-development

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 2 Dec 2007 07:36:09 -0800

So as info for folks that did not happen to be there...

I think most the folks at the coding sprint felt the current  
assignments would not work for them (Henrik and myself included). No  
one produced a signed copy of the assignment.

We will need to work on a plan B to achieve what we want.