Subject: Re: [TOOLS-DEVELOPMENT] NSS Update on Tool Set Porting to Django & Python

From: Russ Housley <[email-masked]>
Date: Tue, 01 May 2007 08:28:10 -0400

Jon:

Thanks.  This activity is very encouraging.

As you are aware, Henrik is spending about half of his time on tool 
development.  Bill Fenner may also have some time available.  I'd 
like you to think about how much the schedule could compress if we 
apply these very talented resources to the project as well.  As you 
know from our call, I think that the security holes need to be 
addressed quickly.

Russ

At 05:11 PM 4/30/2007, Lindberg, Jon wrote:
>TMC,
>
>Here is an update on activity since our call this past Friday.
>
>*Bill Fenner, Michael Lee and I spoke on Friday afternoon to gain
>further clarity.  Thank You Bill!!
>
>*Michael Lee arranged for Vid Luther, an NSS Developer, to fly up from
>Texas to work with us this week in order to get this project started as
>quickly as possible.  Vid has experience with both Django and Python.
>He is here now and has been working with us all day.
>
>*Henrik Levkowetz, Michael Lee, Vid Luther and I spoke this morning to
>gain further clarity.  Thank You Henrik!!
>
>*Michael & Vid have been working today to set up the development
>environment.  Will convert one tool over today/tomorrow to evaluate
>porting time and then extrapolate for the project.
>
>*High Level Timeline (Tentative)
>         -1 May, Draft internal proposal,
>         -2 May, Submit internal proposal to NeuStar Finance & Legal,
>         -4 May, Submit proposal to Ray for review/iteration/approval,
>         -11 May, IAD submits approval,
>         -14 May, NSS begins Porting Develop, Testing and Release as
>complete,
>         -2 July, NSS completes Tool Set Porting.
>
>*Scripts to be Ported
>area_mailing_list.cgi
>idindex.cgi
>ipr.cgi
>ipr_detail.cgi
>ipr_detail_show.cgi
>ipr_disclosure.cgi
>ipr_generic.cgi
>ipr_list.cgi
>ipr_notify.cgi
>ipr_search.cgi
>ipr_update_list.cgi
>lastcall.cgi
>liaison_detail.cgi
>liaison_field_help.cgi
>liaison_guide_from_ietf.cgi
>liaison_guide_to_ietf.cgi
>liaison_managers_list.cgi
>liaisons.cgi
>meeting_agenda_html.cgi
>meeting_agenda_text.cgi
>meeting_materials.cgi
>nwg_list.cgi
>nwg_list_submit.cgi
>pidtracker.cgi
>previous_announcement.cgi
>recent_announcement.cgi
>request_approve_mail.cgi
>request_area_confirm.cgi
>request_confirm.cgi
>request_list.cgi
>request_mail.cgi
>rfc_editor_announcement.cgi
>show_nomcom_message.cgi
>states_table.cgi
>upload.cgi
>view_meeting_agenda_html.cgi
>view_meeting_agenda_text.cgi
>view_telechat_minute.cgi
>
>(ACTION: Please let us know if this list is correct.)
>
>*Michael sent the security fixes, from the first 50 hours, to Ray a week
>ago Monday (23 April).  Michael will deploy these releases as soon as we
>have confirmation from Ray that he approves.  I do want to confirm that
>our internal Sr. Architect, John Korpi, has reviewed the security fixes
>and believes them to be in good order.  John Korpi is also Python
>expert.
>
>(ACTION:  Ray, can you please confirm approval for deployment.)
>
>*We also want to confirm that the enhancements to the IDST are on track
>to be completed by 9 May, 2007.
>
>Please let me know if I have missed something.  We recognize the
>importance and sense of urgency around this project and will be using
>all of our resources to deliver our very best result as quickly as
>possible.
>
>Best Regards,
>Jon Lindberg
>+1.703.474.7209
>
>_______________________________________________
>TOOLS-DEVELOPMENT mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/tools-development

_______________________________________________
TOOLS-DEVELOPMENT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-development

---

From: "Lindberg, Jon" <[email-masked]>
Date: Tue, 1 May 2007 17:09:52 -0400

Russ:

Thank You for your note and my apologies for the long delay in getting
back with you.  Here is another update including responses to your note
from below.

*We would be delighted to work with Henrik and/or Bill on this project!!
Henrik and Bill, please let us know your availability and we will
coordinate next steps with you immediately.

*To your point about compression, we are 'always' going to put out a
conservative time line, but, in this case we are, of course, hoping to
complete this project ahead or way ahead of schedule.

*In fact, we have already set up the development environment and Vid is
currently in the process of porting two applications to the Django
Framework and expects to have these completed by tomorrow.  With some
internal testing, we are hoping to go live with these two applications
by early next week.

*Of concern, the IPR and Mailing List Request Tools may be more complex
than either Henrik or Bill believe, and therefore more time consuming,
so this is one area that makes the overall project completion date more
difficult to predict.

*We have completed our proposal and it has been submitted internally to
NeuStar Legal and Finance.  We have asked for a quick turn around, so we
are hoping to be able to send this proposal to Ray by COB tomorrow
(Wednesday).

*If a quick agreement can be made on the proposal (by Thursday morning
of this week), then we will extend Vid Luther's time here in Sterling
for another week, so that he will have direct access to Michael if/when
he has a question.  His presence here is, obviously, more costly for us,
but would be much more efficient for the project.  As a reminder, Vid
knows Python and Django, but is not familiar with some of the detailed
rules of the programs...especially the IPR and Mailing List Request
tools.
 
*Please stand by for our proposal by COB tomorrow.

Thanks!!
Jon Lindberg
+1.703.474.7209

-----Original Message-----
From: Russ Housley [mailto:[email-masked]] 
Sent: Tuesday, May 01, 2007 8:28 AM
To: Lindberg, Jon; Bill Fenner; Henrik Levkowetz; Ray Pelletier; Luther,
Vidyut
Cc: Suleymanova, Dinara; [email-masked]
Subject: Re: [TOOLS-DEVELOPMENT] NSS Update on Tool Set Porting to
Django & Python

Jon:

Russ

---

From: "Lindberg, Jon" <[email-masked]>
Date: Wed, 2 May 2007 15:50:18 -0400

Russ, Ray & the TMC,

Here is a quick update on where we are at:

*Our proposal has been approved by NeuStar Legal and Finance and I just
sent to Ray for review.

*Vid has successfully ported the 'Area Mailing List - List Page' and is
now working on the 'Meeting Agenda'.

Please let me know if you have any questions/concerns or if I/we can
help in any way.

Best Regards,
Jon Lindberg
+1.703.474.7209

-----Original Message-----
From: Lindberg, Jon 
Sent: Tuesday, May 01, 2007 5:10 PM
To: 'Russ Housley'; Bill Fenner; Henrik Levkowetz; Ray Pelletier;
Luther, Vidyut
Cc: Suleymanova, Dinara; [email-masked]
Subject: RE: [TOOLS-DEVELOPMENT] NSS Update on Tool Set Porting to
Django & Python
Importance: High

Russ:

 

Thanks!!
Jon Lindberg
+1.703.474.7209

-----Original Message-----
From: Russ Housley [mailto:[email-masked]] 
Sent: Tuesday, May 01, 2007 8:28 AM
To: Lindberg, Jon; Bill Fenner; Henrik Levkowetz; Ray Pelletier; Luther,
Vidyut

Jon:

Russ