Subject: [TOOLS-DEVELOPMENT] [Fwd: Re: Tools List]

From: Ray Pelletier <[email-masked]>
Date: Fri, 27 Apr 2007 12:26:31 -0400

All;

Michael's take on what tools should be re-written.

Is there agreement with this list?

Ray

-------- Original Message --------
Subject: 	Re: Tools List
Date: 	Fri, 27 Apr 2007 12:05:57 -0400
From: 	Michael Lee <[email-masked]>
To: 	Ray Pelletier <[email-masked]>
CC: 	Barbara Fuller <[email-masked]>, Jon Lindberg 
<[email-masked]>, [email-masked]
References: 	<2C9AA86BEC0D4B4ABBD55350FD743854026F1B20@stntexch14> 
<[email-masked]>

Ray,

Of those tools below, following tools are subject to be re-written  
because they are taking some kind of input from outside users (IESG,  
WG chairs, Liaison Managers, and other public users.)

* Library:
  - IETF.pm
  - GEN_DBUTIL_NEW.pm
  - GEN_UTIL.pm

* I-D Tracker:
  - idtracker.cgi
  - display_news.cgi
  - pidtracker.cgi

* IETF Announcement Sender:
  - ietf_announcement.cgi

* IPR Tool:
  - ipr.cgi
  - ipr_detail.cgi
  - ipr_detail_show.cgi
  - ipr_generic.cgi
  - ipr_list.cgi
  - ipr_notify.cgi
  - ipr_update_list.cgi
  - upload.cgi

* Liaison Tool:
  - liaison_mananger.cgi
  - liaison_detail.cgi

* Mailing List Request Tool:
  - request_approve_mail.cgi
  - request_area_confirm.cgi
  - request_confirm.cgi
  - request_list.cgi
  - request_mail.cgi

* Non-WG mailing list posting tool:
  - nwg_list_approve.cgi
  - nwg_list_submit.cgi

* WG chairs tools:
  - password_manager.cgi
  - session_approval.cgi
  - wg_proceedings.cgi
  - wg_session_requester.cgi

* I-D Database Interface:
  - idindex.cgi

Regards,
Michael.
On Apr 27, 2007, at 10:24 AM, Ray Pelletier wrote:

>
> The question is:
> Are these all the tools that will require re-writing for the Python  
> project?
>
> Ray
>
> Fuller, Barbara wrote:
>> Jon:
>>
>>
>>
>> It looks comprehensive to me.
>>
>>
>>
>> Barbara
>>
>>
>>
>> From: Lindberg, Jon
>> Sent: Friday, April 20, 2007 11:03 AM
>> To: 'Ray Pelletier'; Lee, Michael
>> Cc: Fuller, Barbara
>> Subject: Tools List
>> Importance: High
>>
>>
>>
>> Ray, this is the updated tools list for the Amended and Re-stated  
>> Agreement.
>>
>>
>>
>> Barbara and Michael, can you both please confirm that this is  
>> updated and complete.
>>
>>
>>
>> Thanks!
>>
>> Jon
>>
> <Update of Appendix I V 2 _ 01-10-07_.pdf>

_______________________________________________
TOOLS-DEVELOPMENT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-development

---

From: Russ Housley <[email-masked]>
Date: Fri, 27 Apr 2007 14:27:34 -0400

This is too detailed for my understanding of the tools....

At 12:26 PM 4/27/2007, Ray Pelletier wrote:

All;

Ray

-------- Original Message --------

Subject: Re: Tools List

From: Michael Lee

<[email-masked]>

To: Ray Pelletier
<[email-masked]>

CC: Barbara Fuller

<[email-masked]>, Jon Lindberg

<[email-masked]>,
[email-masked]

Ray,

Of those tools below, following tools are subject to be re-written
because they are taking some kind of input from outside users
(IESG,
WG chairs, Liaison Managers, and other public users.)

* Library:
- IETF.pm
- GEN_DBUTIL_NEW.pm
- GEN_UTIL.pm

* I-D Tracker:
- idtracker.cgi
- display_news.cgi
- pidtracker.cgi

* IPR Tool:
- ipr.cgi
- ipr_detail.cgi
- ipr_detail_show.cgi
- ipr_generic.cgi
- ipr_list.cgi
- ipr_notify.cgi
- ipr_update_list.cgi
- upload.cgi

* Liaison Tool:
- liaison_mananger.cgi
- liaison_detail.cgi

* WG chairs tools:
- password_manager.cgi
- session_approval.cgi
- wg_proceedings.cgi

Regards,
Michael.

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 27 Apr 2007 23:18:27 +0200

> WG chairs, Liaison Managers, and other public users.)

If the interfaces (.cgi files listed below) are re-written,
the module files above may be irrelevant.

>   - idtracker.cgi

ack

>   - display_news.cgi

Is this public?

>   - pidtracker.cgi

ack

> * IETF Announcement Sender:

Is this publicly available?  I don't think it should be.  Doesn't
seem like it should be on the primary list if not.  And what about

	previous_announcement.cgi 
	recent_announcement.cgi 
	rfc_editor_announcement.cgi 

>   - upload.cgi

All of these, yes.

>   - liaison_detail.cgi

Yes, and more:

	area_mailing_list.cgi
	liaison_field_help.cgi
	liaison_guide_from_ietf.cgi
	liaison_guide_to_ietf.cgi
	liaison_managers_list.cgi
	liaisons.cgi

>   - request_area_confirm.cgi

Yes

> * Non-WG mailing list posting tool:

Yes

>   - wg_session_requester.cgi

These are password-protected, I think?  For later re-write, but
not for immediate replacement if protected.

> * I-D Database Interface:

Yes.

Looking at the tarball received earlier, at least the following
which are listed under public tools should be rewritten or removed:

all_id.cgi		     meeting_agenda_text.cgi
all_id_html.cgi		     meeting_materials.cgi
area_mailing_list.cgi	     nwg_list.cgi
idindex.cgi		     nwg_list_submit.cgi
ipr.cgi			     pidtracker.cgi
ipr_detail.cgi		     previous_announcement.cgi
ipr_detail_show.cgi	     recent_announcement.cgi
ipr_disclosure.cgi	     request_approve_mail.cgi
ipr_generic.cgi		     request_area_confirm.cgi
ipr_list.cgi		     request_confirm.cgi
ipr_notify.cgi		     request_list.cgi
ipr_search.cgi		     request_mail.cgi
ipr_update_list.cgi	     rfc_editor_announcement.cgi
lastcall.cgi		     show_nomcom_message.cgi
liaison_detail.cgi	     states_table.cgi
liaison_field_help.cgi	     status_of_item.cgi
liaison_guide_from_ietf.cgi  upload.cgi
liaison_guide_to_ietf.cgi    view_meeting_agenda_html.cgi
liaison_managers_list.cgi    view_meeting_agenda_text.cgi
liaisons.cgi		     view_telechat_minute.cgi
meeting_agenda_html.cgi

	Henrik

> ------------------------------------------------------------------------
>

---

From: Bill Fenner <[email-masked]>
Date: Sat, 28 Apr 2007 07:48:39 -0700

>seem like it should be on the primary list if not.

Right, as far as I know this is a secretariat tool so can be done
in phase 3 if at all.

>And what about

Since they take no user input in creating the sql, perhaps
Michael thought they could be skipped, but they're vulnerable to
the shell/perl injection.

>...

I think a fair number can be removed, since I think they were
changed from cgi generation to cron generation to a file - e.g.,
the all_id ones, last call, status of items, probably others.

  Bill

---

From: "Lindberg, Jon" <[email-masked]>
Date: Mon, 30 Apr 2007 17:11:37 -0400

TMC,

Here is an update on activity since our call this past Friday.

*Bill Fenner, Michael Lee and I spoke on Friday afternoon to gain
further clarity.  Thank You Bill!!

*Michael Lee arranged for Vid Luther, an NSS Developer, to fly up from
Texas to work with us this week in order to get this project started as
quickly as possible.  Vid has experience with both Django and Python.
He is here now and has been working with us all day.

*Henrik Levkowetz, Michael Lee, Vid Luther and I spoke this morning to
gain further clarity.  Thank You Henrik!!

*Michael & Vid have been working today to set up the development
environment.  Will convert one tool over today/tomorrow to evaluate
porting time and then extrapolate for the project.

*High Level Timeline (Tentative)
	-1 May, Draft internal proposal,
	-2 May, Submit internal proposal to NeuStar Finance & Legal,
	-4 May, Submit proposal to Ray for review/iteration/approval,
	-11 May, IAD submits approval,
	-14 May, NSS begins Porting Develop, Testing and Release as
complete,
	-2 July, NSS completes Tool Set Porting.

*Scripts to be Ported
area_mailing_list.cgi
idindex.cgi
ipr.cgi
ipr_detail.cgi
ipr_detail_show.cgi
ipr_disclosure.cgi
ipr_generic.cgi
ipr_list.cgi
ipr_notify.cgi
ipr_search.cgi
ipr_update_list.cgi
lastcall.cgi
liaison_detail.cgi
liaison_field_help.cgi
liaison_guide_from_ietf.cgi
liaison_guide_to_ietf.cgi
liaison_managers_list.cgi
liaisons.cgi
meeting_agenda_html.cgi
meeting_agenda_text.cgi
meeting_materials.cgi
nwg_list.cgi
nwg_list_submit.cgi
pidtracker.cgi
previous_announcement.cgi
recent_announcement.cgi
request_approve_mail.cgi
request_area_confirm.cgi
request_confirm.cgi
request_list.cgi
request_mail.cgi
rfc_editor_announcement.cgi
show_nomcom_message.cgi
states_table.cgi
upload.cgi
view_meeting_agenda_html.cgi
view_meeting_agenda_text.cgi
view_telechat_minute.cgi

(ACTION: Please let us know if this list is correct.)

*Michael sent the security fixes, from the first 50 hours, to Ray a week
ago Monday (23 April).  Michael will deploy these releases as soon as we
have confirmation from Ray that he approves.  I do want to confirm that
our internal Sr. Architect, John Korpi, has reviewed the security fixes
and believes them to be in good order.  John Korpi is also Python
expert.

(ACTION:  Ray, can you please confirm approval for deployment.)

*We also want to confirm that the enhancements to the IDST are on track
to be completed by 9 May, 2007.

Please let me know if I have missed something.  We recognize the
importance and sense of urgency around this project and will be using
all of our resources to deliver our very best result as quickly as
possible.

Best Regards,
Jon Lindberg
+1.703.474.7209