Subject: RE: [Techspec] IAB path [Re: I-D ACTION:draft-mankin-pub-req-04.t xt]

From: "Stephen Hayes (TX/EUS)" <[email-masked]>
Date: Wed, 15 Feb 2006 18:08:17 -0600

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Harald Tveit Alvestrand
> Sent: Wednesday, February 15, 2006 5:38 PM
> To: Spencer Dawkins; [email-masked]
> Subject: Re: [Techspec] IAB path [Re: I-D
> ACTION:draft-mankin-pub-req-04.txt]
> 
> 
> 
> 
> --On onsdag, februar 15, 2006 16:26:48 -0600 Spencer Dawkins 
> <[email-masked]> wrote:
> 
> > From: "Harald Tveit Alvestrand" <[email-masked]>
> >
> >>
> >> I'd state flatly that the techspec requirements apply to 
> documents from
> >> the IETF that are published with IETF approval, as decided 
> by the IESG.
> >>
> >> If, as I think, we want the publication mechanism to be 
> applicable to
> >> other documents (which includes independent submissions, 
> IAB documents,
> >> IRTF documents and IAOC documents, if any), I think the 
> requirements for
> >> those classes of documents need to be separate.
> >>
> >> Trying to merge them makes the process of writing them down FAR too
> >> convoluted.
> >>
> >>                      Harald
> >
> > Hi, Harald,
> >
> > On this same topic - aren't direct submissions, IETF documents, IAB
> > documents, IRTF documents, and IAOC documents are all submitted and
> > approved for publication in different ways?
> >
> > If so, it seems unhelpful to put procedures for all of 
> these documents
> > into a single draft - wouldn't that mean that the draft 
> would be approved
> > by all the different approving bodies before it could be published?
> >
> > I think I'm agreeing and just trying to make sure I 
> understand all the
> > reasons why you're right :-)
> 
> that makes eminent sense to me, so I guess we understand each 
> other :-)
> 
> otoh, in the end the continuation (or not) of the RFC series 
> has to be 
> reduced in the end to a single statement of work under a 
> single contract - 
> but I think the IETF standard process should make *its* input 
> into that 
> process now, and let the other pieces come along later.
> 
>                     Harald
> 
> 
I also think it makes sense to narrow the scope to only IETF documents, as decided by the IESG.  This does not prevent many of these requirements from being adopted for documents arriving via other channels.

This document so far mainly addresses the technical publisher part of the publication process.  As indicated in section 5 there are complementary processes that need to be developed on the IETF side.  These processes will probably be unique to documents going through the IESG.

Stephen

> _______________________________________________
> Techspec mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/techspec
> 

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 17 Feb 2006 15:51:42 +0100

> This document so far mainly addresses the technical publisher part of the publication process.  As indicated in section 5 there are complementary processes that need to be developed on the IETF sid…

However (in answer to Harald), the other pieces have to be available,
together with the techspec piece, in time for the IAOC to write an RFP, so
they actually do have to be worked on in parallel - but not here.

I'm not sure that the IAOC will be generating enough RFCs to justify
a special process, BTW. The only one we generated so far needed to be
a BCP anyway, so it went to the IESG in the normal way.

     Brian