Subject: [Techspec] IRTF in scope? [Re: I-D ACTION:draft-mankin-pub-req-04.txt]

From: Brian E Carpenter <[email-masked]>
Date: Mon, 06 Feb 2006 10:42:43 +0100

Scope nit:

>    This draft only addresses those documents submitted to the IETF via 
>    the IAB, IESG, or IRTF.

There is no mention of IRTF documents, and in fact I would think that's
probably out of scope.

    Brian

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 06 Feb 2006 10:49:33 +0100

>    This draft only addresses those documents submitted to the IETF via 

In fact nothing substantive is said about IAB documents. Perhaps it needs
to be stated as a requirement that the technical publisher shall accept
for publication, as IETF documents, only drafts that have been approved
by the IESG, or drafts from the IAB (which do not require IESG approval).

    Brian

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 15 Feb 2006 22:52:26 +0100

> by the IESG, or drafts from the IAB (which do not require IESG approval).

I'd state flatly that the techspec requirements apply to documents from the 
IETF that are published with IETF approval, as decided by the IESG.

If, as I think, we want the publication mechanism to be applicable to other 
documents (which includes independent submissions, IAB documents, IRTF 
documents and IAOC documents, if any), I think the requirements for those 
classes of documents need to be separate.

Trying to merge them makes the process of writing them down FAR too 
convoluted.

                      Harald

---

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 15 Feb 2006 16:26:48 -0600

From: "Harald Tveit Alvestrand" <[email-masked]>

>
> I'd state flatly that the techspec requirements apply to documents from 
> the IETF that are published with IETF approval, as decided by the IESG.
>
> If, as I think, we want the publication mechanism to be applicable to 
> other documents (which includes independent submissions, IAB documents, 
> IRTF documents and IAOC documents, if any), I think the requirements for 
> those classes of documents need to be separate.
>

Hi, Harald,

On this same topic - aren't direct submissions, IETF documents, IAB 
documents, IRTF documents, and IAOC documents are all submitted and approved 
for publication in different ways?

If so, it seems unhelpful to put procedures for all of these documents into 
a single draft - wouldn't that mean that the draft would be approved by all 
the different approving bodies before it could be published?

I think I'm agreeing and just trying to make sure I understand all the 
reasons why you're right :-)

Thanks,

Spencer

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 16 Feb 2006 00:38:25 +0100

--On onsdag, februar 15, 2006 16:26:48 -0600 Spencer Dawkins 
<[email-masked]> wrote:

> documents, IRTF documents, and IAOC documents are all submitted and
> approved for publication in different ways?
>
> If so, it seems unhelpful to put procedures for all of these documents
> into a single draft - wouldn't that mean that the draft would be approved
> by all the different approving bodies before it could be published?
>

that makes eminent sense to me, so I guess we understand each other :-)

otoh, in the end the continuation (or not) of the RFC series has to be 
reduced in the end to a single statement of work under a single contract - 
but I think the IETF standard process should make *its* input into that 
process now, and let the other pieces come along later.

                    Harald

---

From: Leslie Daigle <[email-masked]>
Date: Fri, 17 Feb 2006 19:14:59 -0500

Having mulled it over a bit (and strictly as an individual
contributor here):

I agree about the complexity of trying to capture the
needs of all potential IETF-constellation publication paths.

However, I am concerned that having each (IAB, IRTF) define
their own requirements independently will create something of
an implementation quagmire for the publisher.  ("If it's a
Tuesday, and it's an IAB document, I have 3 days remaining
to get this out").

So, while requirements relating to approval may be
inapplicable to IAB documents (eg), format (conversion) and
publication tracking had better be consistent across all
paths.

I suggest that may mean separating requirements in the document
to be clear about which ones are invariant across all
IETF-group-produced documents, and which ones are specific to
WGs.  Or, call out the "approval" steps and make it clear
they are for IETF WG process, and that other approval
requirements may be created.

Or something.

Leslie.

---

From: John C Klensin <[email-masked]>
Date: Sat, 18 Feb 2006 07:45:31 -0500

Leslie,

This is getting fairly far from what I've understood to be
techspec's non-charter, but two additional observations...

> requirements may be created.

I think this is exactly right.  From the standpoint of an RFP,
the right organization should be something like:

		N.  Documents will originate from different sources,
		each with its own approval process.  All but N.3 are
		non-discretionary in terms of publication, although the
		RFC Editor may return them to the authorizing body if
		they are incomprehensible.
		
		N.1  The IETF (IESG) approval process
		
		N.2  IAB-authorized approval processes
		
		N.3  Independent submissions
		
		N.4  Other processes approved from time to time by the
		IAB and IAOC.
		
		N+1. Technical Editing
		
		N+2. Copy editing
		
		N+3. Formatting
		
		...

And, if one gets to this level of detail, the RFP or contract
must address one other issue that arises naturally from multiple
paths: who has the right to set processing priorities and by
what mechanism.   We have recently had a situation in which one
body has, from time to time, nearly starved other paths for
resources simply by insisting that its documents come first.
That may be reasonable, or may not, but, if two bodies make the
same demands...

     john