Subject: [Techspec] New requirement for early permanent ID allocation

From: "Stephen Hayes (TX/EUS)" <[email-masked]>
Date: Wed, 22 Feb 2006 17:18:38 -0600

Early permanent ID allocation is not something currently done in the IETF.  Although there is already a potential requirement to do this, implementing it will imply yet another new potential requirement on the technical publisher.

o Potential Req-INDEX-7 - When an permanent ID is allocated early, the technical publisher must provide a disclaimer and pointer in the index to resolve searches on that permanent ID.  The post approval version of the draft must be stored until the document is published since it could expire before publication.

The text of the disclaimer that comes up could be something like:

"RFC xxxx is currently in publication.  A preliminary version of this specification is available at <pointer to the draft>.  This draft is believed to be technically stable and has been approved by the IETF.  Please ignore the expiration date on the draft as no further versions of this draft are expected prior to publication of the RFC.  However, technical changes and delays in publication of this RFC are possible and the user should be aware of the inherent dangers of using pre-publication versions of documents.  and any other disclaimers, blah, blah, blah"

It is also recommended that the technical publisher retains control of the allocation of permanent identifiers.  This is especially true when multiple organizations (IESG, IAB, IRTF) share a single identifier sequence.  One way that this might work is for the IESG to request "publication" or "publication with early allocation"

Stephen

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 22 Feb 2006 18:01:56 -0800

At 5:18 PM -0600 2/22/06, Stephen Hayes (TX/EUS) wrote:
>Early permanent ID allocation is not something currently done in the 
>IETF.  Although there is already a potential requirement to do this, 
>implementing it will imply yet another new potential requirement on 
>the technical publisher.

Given the complexity you describe, and the rareness of the need, 
might it not be better to change the requirement to "quick 
highest-priority publication"? The permanent identifier comes with 
that for free, of course. As long as this only comes up a few times a 
year (and I think that is more than has been seen to date), the IESG 
could tell the technical publisher to stick a particular document at 
the top of the editing queue.

The outside organizations that "need" the identifier will get it more 
slowly than "just make one up", but they would get the full document. 
Further, there would be no confusion about what the contents that the 
identifier point to.

--Paul Hoffman, Director
--VPN Consortium

---

From: John C Klensin <[email-masked]>
Date: Thu, 23 Feb 2006 10:04:01 -0500

Two (separable) comments/issues and an aside...

--On Wednesday, 22 February, 2006 17:18 -0600 "Stephen Hayes
(TX/EUS)" <[email-masked]> wrote:

> Early permanent ID allocation is not something currently done
> in the IETF.  Although there is already a potential
> requirement to do this, implementing it will imply yet another
> new potential requirement on the technical publisher.
> 
> o Potential Req-INDEX-7 - When an permanent ID is allocated
> early, the technical publisher must provide a disclaimer and
> pointer in the index to resolve searches on that permanent ID.
> The post approval version of the draft must be stored until
> the document is published since it could expire before
> publication.
> 
> "RFC xxxx is currently in publication.  A preliminary version
> of this specification is available at <pointer to the draft>.
>...

The relevance of the Identifier, how it is assigned, etc., is a
current NEWTRK work item, embedded significantly in the "ISD"
work and somewhat so in the "SRD" work.  Both would provide
alternate models to needing more disclaimers that, based on
historical experience, would probably be generally ignored.
Until and unless NEWTRK is terminated and a plausible
disposition made of its outstanding tasks, it seems
inappropriate to me for this non-chartered effort to reach
conclusions in this area other than, possibly, to make
recommendations to NEWTRK.

> It is also recommended that the technical publisher retains
> control of the allocation of permanent identifiers.  This is
> especially true when multiple organizations (IESG, IAB, IRTF)
> share a single identifier sequence.  One way that this might
> work is for the IESG to request "publication" or "publication
> with early allocation"

Please separate this into a separate issue.  To the extent to
which we are going to maintain multiple sets of numbers, some of
which apply to subsets of the others, the standards-track
reference ID (currently STD, but its assignment only to Full
Standards is another NEWTRK issue) and other reference IDs
should arguably be controlled directly by some IASA-associated
entity or contractor that is different from the technical
publisher.  I understand this effort to be defining a "technical
publisher" role.  If that role is to be one of a publisher,
rather than having broader standards-management functions, then
we had better be _very_ careful about what the IDs are and who
assigns them.

And, again, who assigns the identifier is a very different issue
from when  that identifier is assigned.

     john

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 24 Feb 2006 16:36:56 +0800

From: "John C Klensin" <[email-masked]>

> we had better be _very_ careful about what the IDs are and who

I agree with John here. I'm not sure I understand the case for continuing 
current practice, at a minimum.

> from when  that identifier is assigned.

Ack.