Subject: [Techspec] Referencing by external organizations

From: "Stephen Hayes (TX/EUS)" <[email-masked]>
Date: Wed, 15 Feb 2006 18:47:10 -0600

One of the goals of re-engineering the technical publication process is to solve the problems with providing references to external organizations.  Outside organizations often want to reference IETF specifications, but are frustrated by their unavailability since they cannot be formally referenced until they exit the RFC queue.

Three approaches have been proposed to address this issue:
1. Expedited handling - moving some critically needed documents to the top of the queue

o Current Req-EXPEDITE-1 - The IETF technical publisher shall expedite the processing of specific documents at the request of the IESG. 

2. Early allocation of permanent identifiers - this allows outside documents to complete their specifications (populated with the correct references) with the expectation that the document will eventually pop out.

o Potential Req-PERMID-2 - The IETF technical publisher should permit early allocation of stable identifiers for or by the IESG to satisfy referencing requirements of external bodies. 

3. Tighten the overall publication timelines so there is not a long wait before publication

o Potential Req-TIMEFRAMES-1 - The IETF technical publisher should have a goal of an average publication time of no more than 4 weeks and at least 98% of all documents should be published within 8 weeks. Documents held up due to references or due to a protocol action should be excluded from this statistic. 

I would propose that we focus on approachs 2 & 3 and drop 1.  Approach 3 by itself is hard to guarantee (especially with the references loophole).  If an identifier can be provided early, with an expectation that the final document will appear within a reasonable time, then I suspect most external organizations will be satisfied.  Most standards organizations will accept the risk that the published document could be delayed or possibly never appear.

I would also propose to tighten up the requirement of the allocation of stable identifiers from 4 weeks to 1 week and remove the exclusions for references and protocol actions.

o Potential Req-TIMEFRAMES-2 - The IETF technical publisher should have a goal of an average stable identifier allocation time of no more than 1 week and at least 98% of documents should have a stable identifier allocated within 2 weeks of approval. 

Stephen Hayes

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 17 Feb 2006 16:19:19 +0100

below...

Stephen Hayes (TX/EUS) wrote:
> One of the goals of re-engineering the technical publication
> process is to solve the problems with providing references to
> external organizations.  Outside organizations often want to
> reference IETF specifications, but are frustrated by their
> unavailability since they cannot be formally referenced until
> they exit the RFC queue.
> 
> Three approaches have been proposed to address this issue: 1.
> Expedited handling - moving some critically needed documents
> to the top of the queue
> 
> o Current Req-EXPEDITE-1 - The IETF technical publisher shall
> expedite the processing of specific documents at the request
> of the IESG.
> 
> 2. Early allocation of permanent identifiers - this allows
> outside documents to complete their specifications (populated
> with the correct references) with the expectation that the
> document will eventually pop out.
> 
> o Potential Req-PERMID-2 - The IETF technical publisher
> should permit early allocation of stable identifiers for or
> by the IESG to satisfy referencing requirements of external
> bodies.
> 
> o Potential Req-TIMEFRAMES-1 - The IETF technical publisher
> should have a goal of an average publication time of no more
> than 4 weeks and at least 98% of all documents should be
> published within 8 weeks. Documents held up due to references
> or due to a protocol action should be excluded from this
> statistic.
> 
> I would propose that we focus on approachs 2 & 3 and drop 1.

I don't think we can drop 1. Even if we reach perfection with
2 and 3, I'm not prepared to assert that we will never need
expedited publishing. So it should be part of the statement of
work, even if we very rarely need it in the new world, IMHO.

> Approach 3 by itself is hard to guarantee (especially with
> the references loophole).  If an identifier can be provided
> early, with an expectation that the final document will
> appear within a reasonable time, then I suspect most external
> organizations will be satisfied.  Most standards
> organizations will accept the risk that the published
> document could be delayed or possibly never appear.

There is a *reason* for requiring references at this time. We
don't want to generate citations of documents that may not be
released from the reference state for an indefinite period.
That would miss the point of why we hold documents for
normative references in the first place. Ditto if it's waiting
for an approval.

> 
> I would also propose to tighten up the requirement of the
> allocation of stable identifiers from 4 weeks to 1 week and
> remove the exclusions for references and protocol actions.

I agree to shorten the target time but I don't agree about
the exclusions.
> 
> o Potential Req-TIMEFRAMES-2 - The IETF technical publisher
> should have a goal of an average stable identifier allocation
> time of no more than 1 week and at least 98% of documents
> should have a stable identifier allocated within 2 weeks of
> approval.

As in my previous message, I think the actual definition
of the target times is a matter for the RFP. In this case,
the 98th percentile seems attainable, but if I was responding
to an RFP, I'd price it up to pay for vacation and sickness
cover. So even here, I'd suggest the 90th percentile.

     Brian