Subject: RE: [Techspec] New requirement for early permanent ID allocation

From: "Stephen Hayes (TX/EUS)" <[email-masked]>
Date: Thu, 23 Feb 2006 09:18:03 -0600

> 
> At 5:18 PM -0600 2/22/06, Stephen Hayes (TX/EUS) wrote:
> >Early permanent ID allocation is not something currently done in the 
> >IETF.  Although there is already a potential requirement to do this, 
> >implementing it will imply yet another new potential requirement on 
> >the technical publisher.
> 
> Given the complexity you describe, and the rareness of the need, 
> might it not be better to change the requirement to "quick 
> highest-priority publication"? The permanent identifier comes with 
> that for free, of course. As long as this only comes up a few times a 
> year (and I think that is more than has been seen to date), the IESG 
> could tell the technical publisher to stick a particular document at 
> the top of the editing queue.

I'm not sure this is a rare need.  Perhaps somebody can provide statistics on how often the expedited handling is requested.  Buch each time it is granted it is unfair to the other documents waiting in the queue.

Ideally, I would like to see early allocation of identifiers be the norm as opposed to the exception.  This relieves some of the pressure in case a publication backlog develops.

> 
> The outside organizations that "need" the identifier will get it more 
> slowly than "just make one up", but they would get the full document. 
> Further, there would be no confusion about what the contents that the 
> identifier point to.

Given that the definitive reference for the RFC (I am assuming that a RFC number will continue to be the reference) is determined by the index, I am unsure of what confusion will arise.
> --Paul Hoffman, Director
> --VPN Consortium

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: "Stephen Hayes (TX/EUS)" <[email-masked]>
Date: Thu, 23 Feb 2006 10:02:44 -0600

Sorry, I missed this mail in the thread so ignore my previous request for statistics.  

>From discussions within the organizations Allison cited (3GPP, 3GPP2, OMA), there is a building reluctance to take work into IETF because of a feeling that it will take too long even when the id is very simple.  In many cases there is little problem getting technical agreement and stability, but the publication delay is long.  We can't really ask IETF to expedite every one of our dependency documents and most of them are normative references which are needed to meet our deadlines.

Regards, Stephen

> -----Original Message-----
> From: Allison Mankin [mailto:[email-masked]]
> Sent: Wednesday, February 22, 2006 10:47 PM
> To: Paul Hoffman
> Cc: Stephen Hayes (TX/EUS); [email-masked]
> Subject: Re: [Techspec] New requirement for early permanent ID
> allocation 
> 
> 
> Paul,
> 
> > year (and I think that is more than has been seen to date)
> 
> It's more than a few times a year.  There were 14 documents processed
> for Expedited Publication in December through February (so far) -
> The total RFCs published in this time (my count, may not be perfect)
> was about 130, so the Expedited documents were about 10%.
> 
> Expedited documents entail significant extra effort by the RFC Editor
> and the authors, AD, and WG Chair shepherds, as well as affecting
> the queue.
> 
> Want more?
> 
> Some SDOs which use our work a lot, 3GPP, OMA, 3GPP2, have sites with
> lists of the drafts and when these drafts need to be citable because
> the SDO's work gets finished.  IETF folks and folks from the SDO
> hold discussions to adjust the expectations in both directions, but
> these lists have over 50 documents and dates.  
> 
> "Quick highest priority publication" is what we're doing now, but
> it's pretty painful.
> 
> Allison
> 
> 
>

---

From: John C Klensin <[email-masked]>
Date: Fri, 24 Feb 2006 01:03:32 -0500

On  23 February, 2006 10:04 -0500, I wrote (text deleted from
the earlier note marked with "[...]")...

------- Earlier note ----------

Two (separable) comments/issues and an aside...

--On Wednesday, 22 February, 2006 17:18 -0600 "Stephen Hayes
(TX/EUS)" <[email-masked]> wrote:

> Early permanent ID allocation is not something currently done
> in the IETF.  Although there is already a potential
> requirement to do this, implementing it will imply yet another
> new potential requirement on the technical publisher.
> 
> o Potential Req-INDEX-7 - When an permanent ID is allocated
> early, the technical publisher must provide a disclaimer and
> pointer in the index to resolve searches on that permanent ID.
> The post approval version of the draft must be stored until
> the document is published since it could expire before
> publication.

[...]

The relevance of the Identifier, how it is assigned, etc., is a
current NEWTRK work item, embedded significantly in the "ISD"
work and somewhat so in the "SRD" work.  Both would provide
alternate models to needing more disclaimers that, based on
historical experience, would probably be generally ignored.
Until and unless NEWTRK is terminated and a plausible
disposition made of its outstanding tasks, it seems
inappropriate to me for this non-chartered effort to reach
conclusions in this area other than, possibly, to make
recommendations to NEWTRK.

[...]

> It is also recommended that the technical publisher retains
> control of the allocation of permanent identifiers.  This is
> especially true when multiple organizations (IESG, IAB, IRTF)
> share a single identifier sequence.  One way that this might
> work is for the IESG to request "publication" or "publication
> with early allocation"

Please separate this into a separate issue.  To the extent to
which we are going to maintain multiple sets of numbers, some of
which apply to subsets of the others, the standards-track
reference ID (currently STD, but its assignment only to Full
Standards is another NEWTRK issue) and other reference IDs
should arguably be controlled directly by some IASA-associated
entity or contractor that is different from the technical
publisher.  I understand this effort to be defining a "technical
publisher" role.  If that role is to be one of a publisher,
rather than having broader standards-management functions, then
we had better be _very_ careful about what the IDs are and who
assigns them.

And, again, who assigns the identifier is a very different issue
from when  that identifier is assigned.

[...]

--- End of earlier note ----

In the interest of stimulating discussion where it belongs, I
have just queued an I-D titled "Identifying Standards Track
Documents",
draft-ietf-newtrk-docid-00.txt, that addresses these issues and
provides for assignment of stable identifiers for
standards-track documents not later than the Protocol Action for
Proposed Standard.  Because this is a simple issue and a simple
proposal, the I-D violates what most consider to be my usual
practice: exclusive of front and back matter, it is
significantly under four pages long.

I have written the proposal up as a change, not a process
experiment.  It occurs to me that, were a different Standards
Identifier prefix chosen, it could be structured as a process
experiment if people wanted to do that.  I'll leave that for
discussion in NEWTRK or elsewhere (and this comment will be more
clear after one reads the draft).

     john

---

From: "Stephen Hayes (TX/EUS)" <[email-masked]>
Date: Fri, 24 Feb 2006 14:13:40 -0600

ok, I understand the desire to partition the work.

pub-req will be agnostic with respect to:
- What a stable permanent identifier is and how many classes of identifiers there are
- Who owns and who assigns the stable permanent identifiers

Godspeed to the newtrk work on this.

Stephen

> From: Spencer Dawkins [mailto:[email-masked]]
> Sent: Friday, February 24, 2006 2:37 AM
> To: [email-masked]
> From: "John C Klensin" <[email-masked]>
> 
> 
> I agree with John here. I'm not sure I understand the case 
> for continuing 
> current practice, at a minimum.
> 
> Ack.