Subject: [Techspec] Issue 4: Publication time criteria

From: "Stephen Hayes (TX/EUS)" <[email-masked]>
Date: Mon, 23 Jan 2006 08:36:42 -0600

Requirement on what criteria to specify on how long to publish a document.

Proposed Resolution: Basically we are telling the technical publisher how high to jump.  So we can have endless arguments on how to measure it and what number we should pick.  I am going to throw out a number to get the fight started.  It may turn out that the final number will be based upon contractual agreements, but it is good to have a target to start with.

Potential Req-TIMEFRAMES-1 - The IETF technical publisher should have a goal of an average publication time of 4 weeks and 98% of all documents should be published within 8 weeks. Documents held up due to references or due to a protocol action should be excluded from this statistic. 

Potential Req-TIMEFRAMES-2 - The IETF technical publisher should have a goal of an average stable indentifier allocation time of 4 weeks and 98% of documents should have a stable identifier allocated within 8 weeks of approval. Documents held up due to references or due to a protocol action should be excluded from this statistic. 

Fulfiling these guidelines means that the publisher would have to publish before the appeals window.  Note however that the appeals process is only one mechanism.  A legal action challenging a document could occur months or even years after its publication.  A new potential requirement is added:

Potential Req-INDEX-6 - The IETF can indicate to the publisher that it should change the status of a document (e.g., to Historical) and this should be reflected in the index.

Add a bullet to Section 5 (IETF Implications of Technical Publication Requirements) indicating that the IETF needs to define a process to decide and inform the technical publisher of status changes to published documents as the result of an appeal, legal action, or some other procedural action.

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: Pekka Savola <[email-masked]>
Date: Mon, 23 Jan 2006 17:14:42 +0200 (EET)

On Mon, 23 Jan 2006, Stephen Hayes (TX/EUS) wrote:
> Potential Req-INDEX-6 - The IETF can indicate to the publisher that 
> it should change the status of a document (e.g., to Historical) and 
> this should be reflected in the index.

As a matter of fact, this is a current requirement.

> Add a bullet to Section 5 (IETF Implications of Technical 
> Publication Requirements) indicating that the IETF needs to define a 
> process to decide and inform the technical publisher of status 
> changes to published documents as the result of an appeal, legal 
> action, or some other procedural action.

As you note, there may be some debate on what "indicate" means.  Is a 
request by IESG or some other body enough?  Does this require an RFC? 
I think in the past all these have been done using a text in an RFC.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 23 Jan 2006 08:08:46 -0800

At 8:36 AM -0600 1/23/06, Stephen Hayes (TX/EUS) wrote:
>Potential Req-TIMEFRAMES-1 - The IETF technical publisher should 
>have a goal of an average publication time of 4 weeks and 98% of all 
>documents should be published within 8 weeks. Documents held up due 
>to references or due to a protocol action should be excluded from 
>this statistic.
>
>Potential Req-TIMEFRAMES-2 - The IETF technical publisher should 
>have a goal of an average stable indentifier allocation time of 4 
>weeks and 98% of documents should have a stable identifier allocated 
>within 8 weeks of approval. Documents held up due to references or 
>due to a protocol action should be excluded from this statistic.

Maybe change "time of 4 weeks" to "time of up to 4 weeks" in both 
edits. Without such a change, if the publisher is faster than the 
requirement, they will be forced to slow down, probably with NOOP 
loops.

--Paul Hoffman, Director
--VPN Consortium

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 24 Jan 2006 11:21:06 +0100

Pekka Savola wrote:
>> Potential Req-INDEX-6 - The IETF can indicate to the publisher that it 
>> should change the status of a document (e.g., to Historical) and this 
>> should be reflected in the index.
> 
> 
>> Add a bullet to Section 5 (IETF Implications of Technical Publication 
>> Requirements) indicating that the IETF needs to define a process to 
>> decide and inform the technical publisher of status changes to 
>> published documents as the result of an appeal, legal action, or some 
>> other procedural action.
> 
> 
> request by IESG or some other body enough?  Does this require an RFC? I 
> think in the past all these have been done using a text in an RFC.

I believe that formal decisions by the IESG are enough for a status
change, although in many cases a change (e.g. to Historic) is the result
of the IESG approving a new document. At least in theory, a PS can become
a DS or a DS can become a Standard without a new RFC. I don't think we
should *require* a new document - that would be pure bureaucracy.

    Brian