Subject: Re: [Techspec] permanent identifier at approval

From: Allison Mankin <[email-masked]>
Date: Wed, 26 Oct 2005 09:27:00 -0700

Pekka,

In the new draft, the two month delay for waiting for
appeals is reconsidered in general.  Probably not as
clearly as it should be.

I think we could do some form of not delaying for
the appeals process, but again, I think we only have control
over the IETF's part of the document activity, so
in my view, putting out the stable permanent identifier
form of the document predictably in a month would be
a good way to handle this.

For getting the full document out that quickly, this group had
best look at all the techspec requirements as a whole.

The following from -01 was written from much experience, with
many many documents, and many expedited documents, where
we had to get everyone in line to do the process fast:

 Note that this requirement is heavily interdependent with
 other requirements.  It has implications for authors, editors,
 and protocol parameter assignment personnel:  they must
 be committed to timely action for their followup on any 
 final reviews, changes, and actions needed post-approval.
 (Small delays add up shockingly if one is looking for a month
 or two month turn-around; the AD and working group shepherd 
 really have to act as herders on this).

Reviewing for final, forever publication is hard to corral
people to do right, in my experience.

Allison

_______________________________________________
Techspec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/techspec

---

From: Allison Mankin <[email-masked]>
Date: Wed, 26 Oct 2005 09:58:42 -0700

Pekka,

> Only if it turns out that our primary requirement of "get the RFC
> published within a week or two after approval" cannot be met by

By the way, we have not got agreement among all of us that that
is a feasible requirement; it's a metric that could be placed,
but we have to agree on the input requirements for the service
and on our interactions with the technical publisher (that is
the point of my other post).

Let's put it on an issues list, but let's look at the list
of input requirements: requirements on the technical publications
service and requirements that are placed on IETF/publisher interaction.

A starting set is in draft-mankin-pub-req-01.txt

I mean to run an issues list, but let me check for a good setup.

Allison

---

From: "Stephen Hayes (TX/EUS)" <[email-masked]>
Date: Wed, 26 Oct 2005 15:45:06 -0500

Publishing specs within two weeks is certainly possible.

Within 3GPP, 90% of the specifications are published within 2 weeks of approval, 100% are published within 3 weeks of approval.

However to do so requires the necessary allocation of resources.  In 3GPP this is essentially the equivalent of having a dedicated full time secretary per WG to track and edit the documents.

I don't see this level of resource committment occuring within IETF.  In lieu of this, then I think the early allocation of permanent identifiers is a good second choice.

Stephen Hayes

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Allison Mankin
> Sent: Wednesday, October 26, 2005 11:59 AM
> To: Pekka Savola
> Cc: [email-masked]
> Subject: Re: [Techspec] permanent identifier at approval 
> 
> 
> Pekka,
>