Subject: [tcpPrague] Treatment of ECT(1) pre L4S

From: Dave Dolson <[email-masked]>
Date: Fri, 22 Jul 2016 11:01:06 +0000

If an operator were to deploy ECN today, pre L4S, what should be the treatment of ECT(1)?

I believe, from a discussion with Koen, that the safest approach is for a pre-L4S implementation to signal congestion to ECT(1) by dropping. If ECT(1) were treated the same as ECT(0) then new experimental TCP-Prague flows would out-compete any ECT(0) traffic.

Is this agreed? If so, should it be recommended somewhere?

Note that I got mixed answers on this from other IETF folks, so I think it is worth sorting out.

-Dave

---

From: Bob Briscoe <[email-masked]>
Date: Fri, 22 Jul 2016 13:52:51 +0100

Dave,

Assuming you're using an existing RED implementation...

Advice #1: If you can, make ECT(1) separately configurable from ECT(0), 
even if you set them both to the same config for now.
Advice #2: Don't drop ECT(1) if you are marking ECT(0). That would just 
introduce yet another odd behaviour.
                   As long as you've satisfied advice #1, you can change 
this decision in future if it proves better.
Advice #3: Once we have some L4S hosts, it might be possible to at least 
config ECT(1) to use the instantaneous queue size, rather than a 
smoothed queue size (ie RED's EWMA const = 2^0  = 1).

If you're actually implementing the AQM now, my advice would be 
different. I assume you are just talking about configuring an existing 
implementation.

> Note that I got mixed answers on this from other IETF folks, so I think it is worth sorting out.
OK. But we'll need to do some experiments first.

Bob
>
>
> -Dave
>
>
>
> _______________________________________________
> tcpPrague mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpprague

-- 
________________________________________________________________
Bob Briscoe                               http://bobbriscoe.net/