Subject: Re: Unacceptable ACK in SYN_RCVD state handling

From: Bob Braden <[email-masked]>
Date: Mon, 8 Apr 2002 22:13:38 GMT

*> 
  *> No, the scenario that applies is described on page 68 (sequence number check),

Yes, sorry, I misinterpreted what you were asking (ACK field as opposed
to sequence field of ACK segment (But the man DID say "receive window"...
mumble).

  *> 
  *> The point u mentioned above is the conflict i am having as well, it seems to me
  *> that retransmitting
  *> a SYN-ACK seems the right thing to do. But the BSD stack doesn't seem to be
  *> doing that.

I thought you said earlier that the BSD DOES retransmit the SYN.  In
any case, I would agree that the text of RFC 793 seems to say
otherwise.  This particular test is one that has caused a great deal of
confusion over the years.  From the underlying logic of TCP,  I believe
that retransmitting the SYN is OK.  So it seems you can choose either
interpretation you want (unless there is some  subtle security
implication.)

Bob Braden

  *> 
  *> Murali
  *> 
  *> 
  *> 
  *> 
  *> >
  *> >
  *> > Bob Braden
  *>

---

From: Murali Bashyam <[email-masked]>
Date: Mon, 08 Apr 2002 15:51:51 -0700

> I thought you said earlier that the BSD DOES retransmit the SYN.  In

Sorry, the BSD stack does retransmit the SYN. Linux sends a pure ACK in response.

Murali