Subject: Re: Intentional Host Reordering of TCP Fragments

From: "Nabil Seddigh" <[email-masked]>
Date: Fri, 16 Jun 2000 09:58:02 -0400 (EDT)

Jamal Hadi Salim writes:
>
>Linux's "intentional packet re-ordering" of fragments is because that
>is more efficient for Linux to do 
>

I guess I had already heard this opinion from you ;)
I was also hoping to hear opinions from other folks 
who have been involved in development
of the TCP/IP standards etc....

Seems to me that if network reordering is to be discouraged
then the same principle should apply to end-hosts. Seems
inconsistent to encourage network devices to avoid 
reordering yet allow end-hosts to reorder.

BTW, if you have an algorithm that allows you to do
100% accurate Layer-4 classification (without caching) in 
the face of reordered fragments then I wouldn't mind 
seeing it ;)

Best,
---
Nabil Seddigh
[email-masked]

---

From: [email-masked]
Date: Fri, 16 Jun 2000 23:24:24 +0400 (MSK DST)

Hello!

> reordering yet allow end-hosts to reorder.

I apologize, the word "reordering" applies to the cases
when some order ever existed. 8) There is no order for fragments,
but that one, which sending host generated.

Change subject line, please.

> 100% accurate Layer-4 classification (without caching) 

100% accurate algorithm, which classifies IP packets using keys
contained in payload, does not exist, cannot exist and must not exist.
It is in contradiction with basic principles of IP.

If such pseudo-router really wants to do this, it must:

1. Be sure that no other paths from the source to the destination exist.
2. Gather all the fragments before doing any decisions. The situation,
   when different fragments get different QoS must be excluded
   __completely__, otherwise this QoS loses a sense.
   BTW, moving closer to the subject, only after this it should
   issue them in the same order, which they were received in. 8)8)8)

Alexey