Subject: Conformance Testing Tools For TCP/IP

From: "Narsimharao Nagampalli" <[email-masked]>
Date: Tue, 25 Apr 2000 05:39:38 -0600

Hi All,

We are interested in information regarding Conformance Testing Tools and Test Suites for complete TCP/IP stack. Appreciate if anybody can throw some pointers.

Thanks,
Narsi

---

From: Péter Krémer <[email-masked]>
Date: Fri, 28 Apr 2000 12:48:49 +0200

Hi,

Narsimharao Nagampalli wrote:
> We are interested in information regarding Conformance Testing
> Tools and Test Suites for complete TCP/IP stack. Appreciate if
> anybody can throw some pointers.

We're dealing with conformance test of Internet protocols (TCP and
IPv6).
We wrote test cases (~180) for IPv6 in TTCN, which is an abstract
notation developed for conformance test. We also have some test cases
for TCP congestion control (slow start, congestion avoidance, fast
recovery and retransmit) and for connection establishment and closing
are being prepared.

Please, feel free to contact me for further information.

Bye,
-- 
Peter Kremer                    E-mail: [email-masked]
Ericsson Kft.			Tel: +36-1-437-7033
Conformance Center ETH/RL/S	Fax: +36-1-437-7767
H-1300, Budapest 3., P.O. Box 107

---

From: Paula DuFour <[email-masked]>
Date: Fri, 28 Apr 2000 12:28:05 -0400

Hello,

	I am a graduate student and I am attempting to understand
the developmental direction of the applications which use
TCP/IP protocols to communicate through the network.

	I have seen in the discussion of NFSv4 an encouragement to
use TCP rather than UDP for communications on the network
due to the lack of congestion control in UDP.

	I have seen some discussions of changing UDP to have
congestion control mechanisms.

	I just read this morning Sally Floyd's ietf draft regarding
the use of ECN field within IP to pass information regarding
congestion to the encapsulating protocols.

	Would anyone be able to give me a good feel for what
direction TCP/IP will take with respect to congestion
control?

Paula DuFour
Graduate Student
Telecommunications and Computer
SEAS George Washington University