Subject: Re: TCP Options Header Fields

From: alex r <[email-masked]>
Date: Thu, 3 Feb 2000 17:42:30 -0800 (PST)

From RFC 793
 Data Offset:  4 bits

    The number of 32 bit words in the TCP Header. 
This indicates where
    the data begins.  The TCP header (even one
including options) is an
    integral number of 32 bits long.

This says that the values possible are 0 to 15 (2^4
values). The counting starts from 1 even though 0 can
be represented and effectively we have 15 values
(1-15) which contribute to the length and this is a 4
byte quantity. So we have 15*4=60 bytes max as the
header length.

--- Zachary Amsden <[email-masked]>
wrote:
> > [email-masked] wrote:
> > > 
> > > All size references in many books and websites
> specify that the size of the
> > > Options field in the TCP header is 'variable' . 
> However, in the Selective ACK
> > > RFC (2018), it specifies that the Option field
> is a maximum of 40 bytes.
> > > 
> > > What is the maximum size of the Option field in
> the TCP header?
> > 
> > The tcp hlen is 4 bits, that would limit the tcp
> header length
> > to 2^4 * 5 = 64 bytes. The standard tcp header
> takes 20 bytes
> > plus 1 required tcp option (I believer it is MSS)
> 4 bytes. So the
> > maximum
> > option length left for SACK is 40 bytes.
> 
> With hlen as 4 bits, the maximum tcp header length
> from a zero offset is (2^4 
> - 1) << 2 = 60, giving 40 bytes maximum for tcp
> options.
> 
> -- 
> Zachary Amsden  [email-masked]  (650) 933-6919
>  09U-510  Core Protocols
> 
> 
> 
__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com

---

From: alex r <[email-masked]>
Date: Thu, 3 Feb 2000 17:44:17 -0800 (PST)

From RFC 793
 Data Offset:  4 bits