Subject: TCP Options Header Fields

From: [email-masked]
Date: Tue, 1 Feb 2000 18:01:36 -0500

All size references in many books and websites specify that the size of the
Options field in the TCP header is 'variable' .  However, in the Selective ACK
RFC (2018), it specifies that the Option field is a maximum of 40 bytes.

What is the maximum size of the Option field in the TCP header?

Thanks.

Patrick Foy

---

From: william Li <[email-masked]>
Date: Tue, 01 Feb 2000 17:43:33 -0800

> What is the maximum size of the Option field in the TCP header?

The tcp hlen is 4 bits, that would limit the tcp header length
to 2^4 * 5 = 64 bytes. The standard tcp header takes 20 bytes
plus 1 required tcp option (I believer it is MSS) 4 bytes. So the
maximum
option length left for SACK is 40 bytes.

-- 
Cheers

William Li
InterNetworking Systems, Lucent Technologies

---

From: Zachary Amsden <[email-masked]>
Date: Tue, 01 Feb 2000 19:08:57 -0800

> option length left for SACK is 40 bytes.

With hlen as 4 bits, the maximum tcp header length from a zero offset is (2^4 
- 1) << 2 = 60, giving 40 bytes maximum for tcp options.

-- 
Zachary Amsden  [email-masked]  (650) 933-6919  09U-510  Core Protocols