Subject: [Syslog] [Technical Errata Reported] RFC5424 (5010)

From: RFC Errata System <[email-masked]>
Date: Fri, 5 May 2017 03:12:40 -0700 (PDT)

The following errata report has been submitted for RFC5424,
"The Syslog Protocol".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5010

--------------------------------------
Type: Technical
Reported by: Job Snijders <[email-masked]>

Section: 8.1

Original Text
-------------
This document guards against the technical issues outlined in UTR36 by
REQUIRING "shortest form" encoding for syslog applications.

Corrected Text
--------------
"Shortest Form" encoding is REQUIRED for syslog applications to guard
against the technical issues outlined in UTR36.

Notes
-----
"REQUIRING" is not a RFC 2119 keyword.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5424 (draft-ietf-syslog-protocol-23)
--------------------------------------
Title               : The Syslog Protocol
Publication Date    : March 2009
Author(s)           : R. Gerhards
Category            : PROPOSED STANDARD
Source              : Security Issues in Network Event Logging
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: t.petch <[email-masked]>
Date: Fri, 5 May 2017 17:46:27 +0100

If this is a Technical Erratum, as it claims, then it is time to get out
the abacus!

Tom Petch

----- Original Message -----
From: "RFC Errata System" <[email-masked]>
Sent: Friday, May 05, 2017 11:12 AM
Subject: [Syslog] [Technical Errata Reported] RFC5424 (5010)

> _______________________________________________
> Syslog mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/syslog

---

From: Job Snijders <[email-masked]>
Date: Fri, 5 May 2017 18:57:15 +0200

On Fri, May 05, 2017 at 05:46:27PM +0100, t.petch wrote:
> If this is a Technical Erratum, as it claims, then it is time to get
> out the abacus!

I'm unsure what the purpose of your comment is. I just followed
directions to the best of my ability.

Please review https://www.rfc-editor.org/how-to-report/ it states:

    "Technical – error in the technical content (Note that changes in
    the usage of RFC 2119 keywords are considered technical.)"

Kind regards,

Job