Subject: [spring] Slot request for IETF 100

From: Shraddha Hegde <[email-masked]>
Date: Thu, 2 Nov 2017 16:14:08 +0000

Chairs,

I would like to request a 10 min slot to present the below draft.
https://tools.ietf.org/html/draft-hegde-spring-traffic-accounting-for-sr-paths-01

Thanks
Shraddha

---

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 3 Nov 2017 11:22:32 +0800

Shraddha,

Could this traffic accounting format be represented as a YANG module? If so, can it be part of an existing SR YANG module or would you define a new model?

> On Nov 3, 2017, at 12:14 AM, Shraddha Hegde <[email-masked]> wrote:
> 
> Chairs,
>  
> https://tools.ietf.org/html/draft-hegde-spring-traffic-accounting-for-sr-paths-01 <https://tools.ietf.org/html/draft-hegde-spring-traffic-accounting-for-sr-paths-01>
>  
>  
> Thanks
> Shraddha
>  
> _______________________________________________
> spring mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/spring <https://www.ietf.org/mailman/listinfo/spring>
Mahesh Jethanandani
[email-masked]

---

From: Shraddha Hegde <[email-masked]>
Date: Fri, 3 Nov 2017 03:53:34 +0000

Mahesh,

I have only seen https://datatracker.ietf.org/doc/draft-ietf-spring-sr-yang for YANG and it does not have
Anything related to traffic statistics counters AFAIK.
Is there any other model that I am not aware of?

Rgds
Shraddha

From: Mahesh Jethanandani [mailto:[email-masked]]
Sent: Friday, November 3, 2017 8:53 AM
To: Shraddha Hegde <[email-masked]>
Cc: [email-masked]; Adrian Farrel <[email-masked]>
Subject: Re: [spring] Slot request for IETF 100

Shraddha,

On Nov 3, 2017, at 12:14 AM, Shraddha Hegde <[email-masked]<mailto:[email-masked]>> wrote:

Chairs,

I would like to request a 10 min slot to present the below draft.
https://tools.ietf.org/html/draft-hegde-spring-traffic-accounting-for-sr-paths-01<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dhegde-2Dspring-2Dtraffic-2Daccounting-2Dfor-2Dsr-2Dpaths-2D01&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=-qbSPtOSkJdMwB1l9hkiqa9-N3yK1guGZ2mpiIW2xTw&s=0T_gwWUhvIuteydQEocfAwWi4FkB-D4Xzz500OjQX5Q&e=>

Thanks
Shraddha

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_spring&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=-qbSPtOSkJdMwB1l9hkiqa9-N3yK1guGZ2mpiIW2xTw&s=eF-gCphLyrNGcGxX4dv7nZ17v70Fikym6wj_kqW37IY&e=>

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 3 Nov 2017 12:21:44 +0000

Hi Shraddha,

If your SR traffic statistics draft progresses, the ietf-segment-routing model would need to be augmented. I don’t see having the YANG model augmentations as a prerequisite.

Thanks,
Acee

From: spring <[email-masked]<mailto:[email-masked]>> on behalf of Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
Date: Thursday, November 2, 2017 at 11:53 PM
To: Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] Slot request for IETF 100

Mahesh,

Rgds
Shraddha

From: Mahesh Jethanandani [mailto:[email-masked]]
Sent: Friday, November 3, 2017 8:53 AM
To: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] Slot request for IETF 100

Shraddha,

Chairs,

Thanks
Shraddha

Mahesh Jethanandani

---

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 3 Nov 2017 18:11:58 +0530

I would suggest that the draft define the augmentation of the SR yang model. Operationally, defining the statistics without defining how they can be retrieved does not make sense. 

Mahesh Jethanandani 
[email-masked]

> On Nov 3, 2017, at 5:51 PM, Acee Lindem (acee) <[email-masked]> wrote:
> 
> Hi Shraddha, 
> 
> From: spring <[email-masked]> on behalf of Shraddha Hegde <[email-masked]>
> To: Mahesh Jethanandani <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, Adrian Farrel <[email-masked]>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>  
> Mahesh Jethanandani
> [email-masked]
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 3 Nov 2017 13:19:55 -0000

Hi all,
 
This document defines a mechanism that enables the identification of SR paths (i.e., end-to-end flows) and so allows counting at a different granularity. But it doesn't define specific statistics, nor does it set out other uses (such as OAM) for identifying SR paths.
 
I appreciate the enthusiasm for working on new statistics and the YANG model augmentation. I hope we can all pitch in and do that. But I think that belongs in a separate document from where the path identifier is defined.
 
Do you all want to sit down in Singapore and talk through the model augmentation.
 
Adrian

From: spring [mailto:[email-masked]] On Behalf Of Mahesh Jethanandani
Sent: 03 November 2017 12:42
To: Acee Lindem (acee)
Cc: [email-masked]; Adrian Farrel; Shraddha Hegde
Subject: Re: [spring] Slot request for IETF 100

Mahesh Jethanandani 
[email-masked]

 
Thanks,
Acee 

Mahesh,

Rgds
Shraddha

Shraddha,

 
Chairs,
 
I would like to request a 10 min slot to present the below draft.
 <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dhegde-2Dspring-2Dtraffic-2Daccounting-2Dfor-2Dsr-2Dpaths-2D01&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=-qbSPtOSkJdMwB1l9hkiqa9-N3yK1guGZ2mpiIW2xTw&s=0T_gwWUhvIuteydQEocfAwWi4FkB-D4Xzz500OjQX5Q&e=> https://tools.ietf.org/html/draft-hegde-spring-traffic-accounting-for-sr-paths-01

Thanks
Shraddha
 
_______________________________________________
spring mailing list
 <mailto:[email-masked]> [email-masked]
 <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_spring&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=-qbSPtOSkJdMwB1l9hkiqa9-N3yK1guGZ2mpiIW2xTw&s=eF-gCphLyrNGcGxX4dv7nZ17v70Fikym6wj_kqW37IY&e=> https://www.ietf.org/mailman/listinfo/spring
 
Mahesh Jethanandani
[email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 3 Nov 2017 22:32:16 +0530

Ok. I have to admit the title of the draft threw me off, where it says "Traffic Accounting for MPLS Segment Routing Paths”, while it really means “Mechanisms for Traffic Accounting in MPLS Segment Routing Paths”.

Regardless, I agree that the actual statistics could belong in another draft from this one, and I would happy to discuss this in Singapore.

Cheers.

> On Nov 3, 2017, at 6:49 PM, Adrian Farrel <[email-masked]> wrote:
> 
> Hi all,
>  
> [email-masked] <mailto:[email-masked]>
> 
> On Nov 3, 2017, at 5:51 PM, Acee Lindem (acee) <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Hi Shraddha, 
>>  
>> From: spring <[email-masked] <mailto:[email-masked]>> on behalf of Shraddha Hegde <[email-masked] <mailto:[email-masked]>>
>> To: Mahesh Jethanandani <[email-masked] <mailto:[email-masked]>>
>> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, Adrian Farrel <[email-masked] <mailto:[email-masked]>>
>>> I have only seen https://datatracker.ietf.org/doc/draft-ietf-spring-sr-yang <https://datatracker.ietf.org/doc/draft-ietf-spring-sr-yang> for YANG and it does not have
>>>   <>
>>> From: Mahesh Jethanandani [mailto:[email-masked] <mailto:[email-masked]>] 
>>> To: Shraddha Hegde <[email-masked] <mailto:[email-masked]>>
>>> Cc: [email-masked] <mailto:[email-masked]>; Adrian Farrel <[email-masked] <mailto:[email-masked]>>
>>>> On Nov 3, 2017, at 12:14 AM, Shraddha Hegde <[email-masked] <mailto:[email-masked]>> wrote:
>>>>  
>>>> Chairs,
>>>>  
>>>> https://tools.ietf.org/html/draft-hegde-spring-traffic-accounting-for-sr-paths-01 <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dhegde-2Dspring-2Dtraffic-2Daccounting-2Dfor-2Dsr-2Dpaths-2D01&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=-qbSPtOSkJdMwB1l9hkiqa9-N3yK1guGZ2mpiIW2xTw&s=0T_gwWUhvIuteydQEocfAwWi4FkB-D4Xzz500OjQX5Q&e=>
>>>>  
>>>>  
>>>> Thanks
>>>> Shraddha
>>>>  
>>>> https://www.ietf.org/mailman/listinfo/spring <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_spring&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=-qbSPtOSkJdMwB1l9hkiqa9-N3yK1guGZ2mpiIW2xTw&s=eF-gCphLyrNGcGxX4dv7nZ17v70Fikym6wj_kqW37IY&e=>
>>>  
>>> Mahesh Jethanandani
>>> [email-masked] <mailto:[email-masked]>
Mahesh Jethanandani
[email-masked]

---

From: "Roberta Maglione (robmgl)" <[email-masked]>
Date: Fri, 3 Nov 2017 17:55:31 +0000

Hello Shraddha,
what's the difference between the SR-Path-Identifier specified in your draft and the Binding Segment defined in the Segment Routing Architecture draft?

Thanks
Roberta

From: spring [mailto:[email-masked]] On Behalf Of Shraddha Hegde
Sent: Thursday, November 2, 2017 5:14 PM
To: [email-masked]
Cc: Adrian Farrel <[email-masked]>
Subject: [spring] Slot request for IETF 100

Chairs,

Thanks
Shraddha

---

From: Yingzhen Qu <[email-masked]>
Date: Sat, 4 Nov 2017 16:06:18 +0000

Hi,

As an author of the SR Yang model, I'd be interested in this discussion in Singapore.

Thanks,
Yingzhen
From: Mahesh Jethanandani
To: Adrian Farell<[email-masked]<mailto:[email-masked]>>
Cc: Adrian Farrel<[email-masked]<mailto:[email-masked]>>;[email-masked]<mailto:[email-masked]>;Acee Lindem (acee)<[email-masked]<mailto:[email-masked]>>;Shraddha Hegde<[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] Slot request for IETF 100
Time: 2017-11-03 10:03:55

Cheers.

On Nov 3, 2017, at 6:49 PM, Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Adrian

From: spring [mailto:[email-masked]] On Behalf Of Mahesh Jethanandani
Sent: 03 November 2017 12:42
To: Acee Lindem (acee)
Cc: [email-masked]<mailto:[email-masked]>; Adrian Farrel; Shraddha Hegde
Subject: Re: [spring] Slot request for IETF 100

Mahesh Jethanandani

On Nov 3, 2017, at 5:51 PM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Shraddha,

Thanks,
Acee

Mahesh,

Rgds
Shraddha

Shraddha,

Chairs,

Thanks
Shraddha

Mahesh Jethanandani

Mahesh Jethanandani

---

From: Mach Chen <[email-masked]>
Date: Mon, 6 Nov 2017 01:45:16 +0000

Hi Adrian and others,

I agree with Adrian, indeed, the YANG work should be in a separate document. And it should include at two parts IMHO, one is as Mahesh mentioned, using the YANG model to retrieve the counting data, the other would be to use YANG for configuration, for example, to enable the measurement, to configure the Path segment identifier/label, to configure the mapping between an SR path and relevant information, etc.

BTW, FYI, there is another draft (https://tools.ietf.org/html/draft-cheng-spring-mpls-path-segment-00 ) that also tries to solve the same problem, but uses different solutions. For me, I think this is a valid issue. After reading two documents, I found that at least four solutions are proposed, each has its pros and cons. I would encourage people to read the two drafts and discuss on the solutions,  and hopefully we can converge on a single solution.

Best regards,
Mach

From: spring [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Friday, November 03, 2017 9:20 PM
To: 'Mahesh Jethanandani' <[email-masked]>; 'Acee Lindem (acee)' <[email-masked]>
Cc: [email-masked]; 'Adrian Farrel' <[email-masked]>; 'Shraddha Hegde' <[email-masked]>
Subject: Re: [spring] Slot request for IETF 100

Hi all,

Adrian

Mahesh Jethanandani

Thanks,
Acee

Mahesh,

Rgds
Shraddha

Shraddha,

Chairs,

Thanks
Shraddha

Mahesh Jethanandani

---

From: Mach Chen <[email-masked]>
Date: Mon, 6 Nov 2017 02:02:57 +0000

Hi Roberta,

IMHO, from path identification point of view, they are similar.  Binding Segment is used to identify a path at the ingress LSR of the path, the Path segment is expected to be used to identify a path at the egress LSR or intermediate LSRs.

In addition, the Binding Segment will be replaced by the specific expanded label stack, and they will not be in the label stack at same time. The Path segment proposed in https://tools.ietf.org/html/draft-hegde-spring-traffic-accounting-for-sr-paths-01 and https://tools.ietf.org/html/draft-cheng-spring-mpls-path-segment-00 will be put together with the segment labels that identify the SR path in the label stack, and normally the Path segment label will be inserted following the last label of the SR path.

Best regards,
Mach

From: spring [mailto:[email-masked]] On Behalf Of Roberta Maglione (robmgl)
Sent: Saturday, November 04, 2017 1:56 AM
To: Shraddha Hegde <[email-masked]>; [email-masked]
Cc: Adrian Farrel <[email-masked]>
Subject: Re: [spring] Slot request for IETF 100

Hello Shraddha,

Thanks
Roberta

From: spring [mailto:[email-masked]] On Behalf Of Shraddha Hegde
Sent: Thursday, November 2, 2017 5:14 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Subject: [spring] Slot request for IETF 100

Chairs,

Thanks
Shraddha

---

From: Shraddha Hegde <[email-masked]>
Date: Mon, 6 Nov 2017 03:20:07 +0000

Hi Roberta,

SR-Path-Identifier is a globally unique value identifying paths in the network.
SR-Path-Identifier could be local to a node in which case it is associated with a source-SID
To uniquely identify paths on a transit node. SR-Path-Identifiers are not used for
Forwarding traffic and are inserted only for traffic accounting purposes to uniquely
Identify the paths on a transit.

Binding-SIDs are used to steer traffic into the SR-Policies and are removed from the packet
On the head-end of the SR-Path.

Rgds
Shraddha

From: Roberta Maglione (robmgl) [mailto:[email-masked]]
Sent: Friday, November 3, 2017 11:26 PM
To: Shraddha Hegde <[email-masked]>; [email-masked]
Cc: Adrian Farrel <[email-masked]>
Subject: RE: Slot request for IETF 100

Hello Shraddha,

Thanks
Roberta

Chairs,

I would like to request a 10 min slot to present the below draft.
https://tools.ietf.org/html/draft-hegde-spring-traffic-accounting-for-sr-paths-01<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dhegde-2Dspring-2Dtraffic-2Daccounting-2Dfor-2Dsr-2Dpaths-2D01&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=mYMW8cP-MBdcSEwEt7xQ1fNqlxsu7vdNJUzWFdqDxGg&s=YOq5iSKjrzr3IV2CZIEmHyAk7a8sSaCqdjWUOsJxb_s&e=>

Thanks
Shraddha

---

From: "Roberta Maglione (robmgl)" <[email-masked]>
Date: Tue, 7 Nov 2017 02:28:51 +0000

Hi Shraddha,
Thanks for the clarification.
So basically if I understand correctly SR-Path-Identifier and Binding sid have several points in common and few differences:
both of them identify an SR-Path, and both can be either global or local.
The differences between the two are that SR-Path-Identifier is not used for the forwarding and the Binding Sid is removed by the head node, so not carried along the path, but still  semantically they seam to both mean the same thing: an identifier for the SR path

Regards
Roberta

From: Shraddha Hegde [mailto:[email-masked]]
Sent: Sunday, November 5, 2017 10:20 PM
To: Roberta Maglione (robmgl) <[email-masked]>; [email-masked]
Cc: Adrian Farrel <[email-masked]>
Subject: RE: Slot request for IETF 100

Hi Roberta,

Rgds
Shraddha

To: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Hello Shraddha,

Thanks
Roberta

Chairs,

Thanks
Shraddha