Subject: Re: [spring] FW: New Version Notification for draft-clad-spring-segment-routing-service-chaining-00.txt

From: Jeff Tantsura <[email-masked]>
Date: Wed, 18 Oct 2017 13:34:58 -0700

Hi Francois,

The draft has been published as the Standards Track document.
What is it you have been trying to standardize?

Thanks! 

Cheers,
Jeff

-----Original Message-----
From: spring <[email-masked]> on behalf of "Francois Clad (fclad)" <[email-masked]>
Date: Wednesday, October 18, 2017 at 07:46
To: "[email-masked]" <[email-masked]>
Subject: [spring] FW: New Version Notification for draft-clad-spring-segment-routing-service-chaining-00.txt

    Hello,
    
    We have just submitted draft-clad-spring-segment-routing-service-chaining-00.
    
    Any feedback is welcome.
    
    Regards,
    Francois
    
    On 06/10/2017, 21:32, "[email-masked]" <[email-masked]> wrote:

        A new version of I-D, draft-clad-spring-segment-routing-service-chaining-00.txt
        has been successfully submitted by Francois Clad and posted to the
        IETF repository.
        
        Name:		draft-clad-spring-segment-routing-service-chaining
        Revision:	00
        Title:		Segment Routing for Service Chaining
        Document date:	2017-10-06
        Group:		Individual Submission
        Pages:		24
        URL:            https://www.ietf.org/internet-drafts/draft-clad-spring-segment-routing-service-chaining-00.txt
        Status:         https://datatracker.ietf.org/doc/draft-clad-spring-segment-routing-service-chaining/
        Htmlized:       https://tools.ietf.org/html/draft-clad-spring-segment-routing-service-chaining-00
        Htmlized:       https://datatracker.ietf.org/doc/html/draft-clad-spring-segment-routing-service-chaining-00

        Abstract:
           This document defines data plane functionality required to implement
           service segments and achieve service chaining with MPLS and IPv6, as
           described in the Segment Routing architecture.

        
        Please note that it may take a couple of minutes from the time of submission
        until the htmlized version and diff are available at tools.ietf.org.
        
        The IETF Secretariat

    _______________________________________________
    spring mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/spring

---

From: "Bernier, Daniel" <[email-masked]>
Date: Tue, 24 Oct 2017 16:35:02 +0000

Hi Jeff, 

Do you mind if I take the microphone on this one?

The expired draft-homma (ref: https://tools.ietf.org/html/draft-homma-sfc-forwarding-methods-analysis-05#page-23 ) on SFC forwarding methods detailed pretty well the various options for forwarding in the context of service chaining and in particular the value for SPs into the use of stacked headers but also potential caveats or required enhancements at the time of writing.  

Following on that thought, I think it becomes essential that SPRING addresses these caveats/enhancements. 

And contrary to Alvaro’s comment in his review of draft-ietf-spring-segment-routing-mpls (ref: https://mailarchive.ietf.org/arch/msg/spring/97KtDebyroHfuNvllpNVb0s66H8/?qid=75cfe3b3b0f6d44817785cc576610ac3 ). I believe it also becomes apparent that answering SFC is “vital”. As it was part of the SR architecture drafts from the beginning (ref:  https://tools.ietf.org/html/draft-filsfils-rtgwg-segment-routing-00#page-23 ). Even more reason to address this in SPRING.

So, going back to your question, for us operators, I think it is essential that required forwarding behaviors, such as proxy mechanisms leveraging SR, get standardized so we can get interoperability and predictability between implementations. Be it in software or hardware. 

For an SP, the notion of “service-chains” is currently pretty hard to deploy and troubleshoot even more so in a multi-vendor fashion, it would be even harder if behaviors like proxies, behave differently.

Hope it makes sense

Thanks,

----------
Daniel Bernier

________________________________________
From: spring <[email-masked]> on behalf of Jeff Tantsura <[email-masked]>
Sent: Wednesday, October 18, 2017 4:34 PM
To: Francois Clad (fclad); [email-masked]
Subject: Re: [spring] FW: New Version Notification for draft-clad-spring-segment-routing-service-chaining-00.txt

Hi Francois,

Thanks!

Cheers,
Jeff

-----Original Message-----
From: spring <[email-masked]> on behalf of "Francois Clad (fclad)" <[email-masked]>
Date: Wednesday, October 18, 2017 at 07:46
To: "[email-masked]" <[email-masked]>
Subject: [spring] FW: New Version Notification for draft-clad-spring-segment-routing-service-chaining-00.txt

    Hello,

    Any feedback is welcome.

    Regards,
    Francois

        Abstract:

        The IETF Secretariat

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 24 Oct 2017 10:40:43 -0700

Hi Daniel,

Thank you for taking the microphone.
Perhaps my question wasn’t clear – I’m completely with you on the need of SFC SR properly documented, however the way document reads – it defines number of behaviors/functions and provides some ideas how those could be implemented. Hence my question, whether you think Informational track would be more appropriate.

Thanks!   

Cheers,
Jeff

-----Original Message-----
From: "Bernier, Daniel" <[email-masked]>
Date: Tuesday, October 24, 2017 at 09:35
To: Jeff Tantsura <[email-masked]>, "Francois Clad (fclad)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [spring] FW: New Version Notification for draft-clad-spring-segment-routing-service-chaining-00.txt

    Hi Jeff, 

    

    
    
    Hope it makes sense
    
    Thanks,
    
    ----------
    Daniel Bernier

    Hi Francois,

    Thanks!
    
    Cheers,
    Jeff
    
    -----Original Message-----
    From: spring <[email-masked]> on behalf of "Francois Clad (fclad)" <[email-masked]>
    Date: Wednesday, October 18, 2017 at 07:46
    To: "[email-masked]" <[email-masked]>
    Subject: [spring] FW: New Version Notification for draft-clad-spring-segment-routing-service-chaining-00.txt
    
        Hello,

        Any feedback is welcome.
    
        Regards,
        Francois

    

            Abstract:

    
    
            The IETF Secretariat

---

From: "Bernier, Daniel" <[email-masked]>
Date: Wed, 25 Oct 2017 16:08:58 +0000

Hi Jeff, 

Sorry about the confusion.

Personally, I would like to have it in a standard track so we end-up with a reference implementation that everyone can fall back to and ensure consistency and interoperability. Much like was being done with https://tools.ietf.org/html/draft-ietf-bess-service-chaining-03.
There will always be options to diverge and build custom implementations but with a referenced standard, it makes it easier for us.

Hope that's clearer

Thanks,

Daniel Bernier

________________________________________
From: Jeff Tantsura <[email-masked]>
Sent: Tuesday, October 24, 2017 1:40 PM
To: Bernier, Daniel; Francois Clad (fclad); [email-masked]
Subject: Re: [spring] FW: New Version Notification for draft-clad-spring-segment-routing-service-chaining-00.txt

Hi Daniel,

Thanks!

Cheers,
Jeff

-----Original Message-----
From: "Bernier, Daniel" <[email-masked]>
Date: Tuesday, October 24, 2017 at 09:35
To: Jeff Tantsura <[email-masked]>, "Francois Clad (fclad)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [spring] FW: New Version Notification for draft-clad-spring-segment-routing-service-chaining-00.txt

    Hi Jeff,

    Hope it makes sense

    Thanks,

    ----------
    Daniel Bernier

    Hi Francois,

    Thanks!

    Cheers,
    Jeff

    -----Original Message-----
    From: spring <[email-masked]> on behalf of "Francois Clad (fclad)" <[email-masked]>
    Date: Wednesday, October 18, 2017 at 07:46
    To: "[email-masked]" <[email-masked]>
    Subject: [spring] FW: New Version Notification for draft-clad-spring-segment-routing-service-chaining-00.txt

        Hello,

        Any feedback is welcome.

        Regards,
        Francois

            Abstract:

            The IETF Secretariat