Subject: [spring] MPLS Segment Routing in IP Networks

From: Leonid Okner <[email-masked]>
Date: Mon, 9 Oct 2017 18:30:06 -0700

Hello,

I would like to clarify on PHP explicit null label support in the
forwarding plane.

On segment termination node the forwarding plane can't tell if UDP header
is followed by an instruction (with explicit null label)  or directly by
the payload.
Programming this information from the control plane might not be
straightforward as well, as a node might have different roles in different
paths via the SR domain. In one path the node acts as termination nod while
in another path the node acts as a transit node.

Put in other words, it would be better it packet format can be determined
just by looking into packet data.

Thanks Leonid

Pop the explicit null label if it is present in the label stack as
> requested by the domain egress and communicated in the control
> plane as described in Section 7
> <https://tools.ietf.org/html/draft-bryant-mpls-unified-ip-sr-02#section-7>
> .

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 10 Oct 2017 01:45:15 +0000

Hi Leonid,

The UDP payload type should be indicated by the UDP destination port. For instance, if the payload is an MPLS packet, the UDP port is 6635 as specified in RFC7510. If the payload is an IP packet, the UDP port is TDB as specified in (https://tools.ietf.org/html/draft-xu-intarea-ip-in-udp-04).

Best regards,
Xiaohu

发件人: spring [mailto:[email-masked]] 代表 Leonid Okner
发送时间: 2017年10月10日 9:30
收件人: [email-masked]
主题: [spring] MPLS Segment Routing in IP Networks

Hello,

I would like to clarify on PHP explicit null label support in the forwarding plane.

On segment termination node the forwarding plane can't tell if UDP header is followed by an instruction (with explicit null label)  or directly by the payload.
Programming this information from the control plane might not be straightforward as well, as a node might have different roles in different paths via the SR domain. In one path the node acts as termination nod while in another path the node acts as a transit node.

Put in other words, it would be better it packet format can be determined just by looking into packet data.

Thanks Leonid

Pop the explicit null label if it is present in the label stack as
requested by the domain egress and communicated in the control
plane as described in Section 7<https://tools.ietf.org/html/draft-bryant-mpls-unified-ip-sr-02#section-7>.