Subject: Re: [spring] [OSPF] OSPFv2 Segment Routing Extensions ERO Extensions (would also effect OSPFv3 and IS-IS) - REPLY TO THIS ONE

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 12 Jun 2017 12:57:43 +0000

Hi Bruno, 

Here is my view.  

On 6/12/17, 8:50 AM, "spring on behalf of [email-masked]"
<[email-masked] on behalf of [email-masked]> wrote:

>Hello SPRING WG,
>
>I'd like to encourage discussion on this thread.
>
>The related questions seem to be:
>- Binding SIDs:
>	-  Is there any implementation?
>	- Is it useful?
>	- Does it need to be specified?

Binding SIDs as an architectural concept are very useful and will be
leveraged by numerous use cases. For example, one implemented use case is
BGP SR-TE. 
>
>- Binding SIDs advertised in IGP:
>	-  Is there any implementation?
>	 - Is it useful?
>	- Does it need to be specified?

At least for OSPF(v3), we currently don’t see any usage of binding SIDs. I
believe there is a use case for IS-IS but I’ll defer to the authors of the
IS-IS SR draft and implementation to elaborate.

As for the Bind SID ERO extensions, to the best of my knowledge, they are
not implemented or used by either OSPF or IS-IS.

>
>As of today, there seem to be multiple SPRING (related) document that
>make reference (define/use) to the Binding SIDs. e.g.
>- architecture 
>https://tools.ietf.org/html/draft-ietf-spring-segment-routing-11#section-3
>.5.2
>- MPLS instantiation
>https://tools.ietf.org/html/draft-ietf-spring-segment-routing-mpls-08#sect
>ion-2
>- non-protected paths
>https://tools.ietf.org/html/draft-litkowski-spring-non-protected-paths-01#
>section-3.3
>- SR policies: 
>https://tools.ietf.org/html/draft-filsfils-spring-segment-routing-policy-0
>0#section-7
>
>
>However, it also seems a priori possible to define Binding SIDs and not
>advertised them in the IGP. (e.g. by keeping them local to the PCE)
>
>On a side note, if the Binding SIDs are removed from the IGP, do they
>need to be removed from the BGP-LS extensions? [+IDR chairs]

At least the ERO extensions should be removed.

Thanks,
Acee 
>
>Thanks,
>Regards,
>--Bruno
>
>> From: OSPF [mailto:[email-masked]] On Behalf Of Peter Psenak
>> Sent: Monday, June 12, 2017 10:18 AM
> > To: OSPF WG List; [email-masked]; [email-masked]
> > Cc: [email-masked]
> > Subject: Re: [OSPF] OSPFv2 Segment Routing Extensions ERO Extensions
>(would also effect
> > OSPFv3 and IS-IS) - REPLY TO THIS ONE
> > 
> > Hi,
> > 
> > I would like to get some feedback on the usage of the SID/Label
>Binding TLV.
> > 
> > Is there any implementation that uses SID/Label Binding TLV for
> > advertising the SID/Label binding to a FEC as specified in section 6 of
> > the draft-ietf-ospf-segment-routing-extensions-16 or section 2.4 of
> > draft-ietf-isis-segment-routing-extensions-12?
> > 
> > If not, do we see this as something we want to preserve in the IGP SR
> > drafts?
> > 
> > ISIS uses The SID/Label Binding TLV to advertise
> > prefixes to SID/Label mappings, which is known to be supported by
> > several implementations and that piece needs to be preserved.
> > 
> > thanks,
> > Peter
> > 
> > On 09/06/17 19:04 , Peter Psenak wrote:
> > > Acee,
> > >
> > > my question is whether we need the whole section 6 and the SID/Label
> > > Binding Sub-TLV that it specifies. In OSPF Binding SID is not used
>for
> > > SRMS advertisement like in ISIS.
> > >
> > > thanks,
> > > Peter
> > >
> > >
> > >
> > > On 09/06/17 16:45 , Acee Lindem (acee) wrote:
> > >> Corrected IS-IS WG alias – Please reply to this one.
> > >> Thanks,
> > >> Acee
> > >>
> > >> From: Acee Lindem <[email-masked] <mailto:[email-masked]>>
> > >> Date: Friday, June 9, 2017 at 10:42 AM
> > >> To: OSPF WG List <[email-masked] <mailto:[email-masked]>>,
> > >> "[email-masked] <mailto:[email-masked]>" <[email-masked]
> > >> <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>"
> > >> <[email-masked] <mailto:[email-masked]>>
> > >> Cc: "[email-masked]
> > >> <mailto:[email-masked]>"
> > >> <[email-masked]
> > >> <mailto:[email-masked]>>
> > >> Subject: OSPFv2 Segment Routing Extensions ERO Extensions (would
>also
> > >> effect OSPFv3 and IS-IS)
> > >>
> > >>     Hi OSPF, ISIS, and SPRING WGs,
> > >>
> > >>     As part of the Alia’s AD review, she uncovered the fact that
>the ERO
> > >>     extensions in 6.1 and 6.2 are specified as far as encoding but
>are
> > >>     not specified as far as usage in any IGP or SPRING document. As
> > >>     document shepherd,  my proposal is that they simply be removed
>since
> > >>     they were incorporated as part of a draft merge and it appears
>that
> > >>     no one has implemented them (other than parsing). We could also
> > >>     deprecate types (4-8) in the OSPFv2 Extended Prefix LSA Sub-TLV
> > >>     registry to delay usage of these code points for some time (or
> > >>     indefinitely ;^).
> > >>
> > >>     Thanks,
> > >>     Acee
> > >>
> > >
> > > .
> > >
> > 
> > _______________________________________________
> > OSPF mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ospf
>
>__________________________________________________________________________
>_______________________________________________
>
>Ce message et ses pieces jointes peuvent contenir des informations
>confidentielles ou privilegiees et ne doivent donc
>pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
>recu ce message par erreur, veuillez le signaler
>a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
>electroniques etant susceptibles d'alteration,
>Orange decline toute responsabilite si ce message a ete altere, deforme
>ou falsifie. Merci.
>
>This message and its attachments may contain confidential or privileged
>information that may be protected by law;
>they should not be distributed, used or copied without authorisation.
>If you have received this email in error, please notify the sender and
>delete this message and its attachments.
>As emails may be altered, Orange is not liable for messages that have
>been modified, changed or falsified.
>Thank you.
>
>_______________________________________________
>spring mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/spring

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 12 Jun 2017 06:05:20 -0700

Hi,

I have got pretty much same view as Acee.
There are many application (future, to my knowledge no products) for which the concept of Binding SID (anchor node) is central, I’m aware of ISIS implementation, didn’t see OSPF.
 
Currently, I don’t see any use to ERO extensions, perhaps could be removed from base specs and added later, if/when clear use case shows up.
 
Cheers,
Jeff
 
On 6/12/17, 05:57, "Acee Lindem (acee)" <[email-masked]> wrote:

    Hi Bruno, 
    
    Here is my view.  

    

    

    Thanks,
    Acee