Subject: [spring] One question on E-flag of ABR/ASBR in OSPF SR extension

From: Chao Fu <[email-masked]>
Date: Thu, 18 May 2017 07:44:47 +0000

Hi,

Should we clarify how to set E-flag for ABR/ASBR in OSPF SR extension?

In https://www.ietf.org/id/draft-ietf-ospf-segment-routing-extensions-14.txt, the draft describes how to set NP-flag on ABR and ASBR (Section 5 [Page 14]):

   The NP-Flag (No-PHP) MUST be set for Prefix-SIDs allocated to inter-
   area prefixes that are originated by the ABR based on intra-area or
   inter-area reachability between areas.  When the inter-area prefix is
   generated based on a prefix which is directly attached to the ABR,
   the NP-Flag SHOULD NOT be set.

   The NP-Flag (No-PHP) MUST be be set for Prefix-SIDs allocated to
   redistributed prefixes, unless the redistributed prefix is directly
   attached to the ASBR, in which case the NP-flag SHOULD NOT be set.

However, the E-flag (Explicit-Null Flag) is not described. Should we clarify it also? I think E-flag SHOULD NOT be set if the prefix is not directly attached to the ABR or ASBR, and if necessary, it SHOULD be set if the prefix is directly attached to the ABR or ASBR.

Regards,
Chao Fu

---

From: Peter Psenak <[email-masked]>
Date: Thu, 18 May 2017 10:54:14 +0200

Hi Chao,

On 18/05/17 09:44 , Chao Fu wrote:
> In
> https://www.ietf.org/id/draft-ietf-ospf-segment-routing-extensions-14.txt,
> the draft describes how to set NP-flag on ABR and ASBR (Section 5 [Page
> 14]):
>
> However, the E-flag (Explicit-Null Flag) is not described. Should we
> clarify it also? I think E-flag SHOULD NOT be set if the prefix is not
> directly attached to the ABR or ASBR, and if necessary, it SHOULD be set
> if the prefix is directly attached to the ABR or ASBR.

The existing draft says:

"If the NP-flag is not set then the received E-flag is ignored."

Given that the draft clearly states when the NP-flag is set on ABR/ASBR 
above statement should be sufficient.

thanks,
Peter

>
> Regards,
>
> Chao Fu
>
>
>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: Chao Fu <[email-masked]>
Date: Thu, 18 May 2017 09:15:53 +0000

Hi Peter,

It's right if the NP-flag is not set then the received E-flag is ignored. But, if the NP-flag is SET because the prefix is not directly attached to the ABR, E-flag will not be ignored and the upstream neighbor will replace the Prefix-SID with the Explicit-NULL label 0. I guess actually the packet should be forwarded with the original prefix-SID, and no need to pop the 0 label and look up path again. 

Regards,
Chao Fu

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]] 
Sent: Thursday, May 18, 2017 16:54
To: Chao Fu <[email-masked]>; [email-masked]
Subject: Re: [spring] One question on E-flag of ABR/ASBR in OSPF SR extension

Hi Chao,

On 18/05/17 09:44 , Chao Fu wrote:
> https://www.ietf.org/id/draft-ietf-ospf-segment-routing-extensions-14.
> txt, the draft describes how to set NP-flag on ABR and ASBR (Section 5 
> [Page
> 14]):
>
> directly attached to the ABR or ASBR, and if necessary, it SHOULD be 
> set if the prefix is directly attached to the ABR or ASBR.

The existing draft says:

Given that the draft clearly states when the NP-flag is set on ABR/ASBR above statement should be sufficient.

thanks,
Peter

---

From: Peter Psenak <[email-masked]>
Date: Thu, 18 May 2017 11:47:22 +0200

Hi Chao,

On 18/05/17 11:15 , Chao Fu wrote:
> Hi Peter,
>
> It's right if the NP-flag is not set then the received E-flag is ignored. But, if the NP-flag is SET because the prefix is not directly attached to the ABR, E-flag will not be ignored

why would an E-bit be set in such case? It's up to the originator of the 
SID to decide when to set the E-bit. If the ABR does not set the E-bit 
no PHP would be done and advertised SID will be preserved.

Are you trying to add the text that would say that ABR MUST NOT set the 
E-bit either? I don't think it's necessary.

thanks,
Peter

> and the upstream neighbor will replace the Prefix-SID with the Explicit-NULL label 0. I guess actually the packet should be forwarded with the original prefix-SID, and no need to pop the 0 label and look up path again.
>
> Regards,
> Chao Fu
>
>
> .