Subject: [spring] WG Last Call for draft-ietf-spring-segment-routing-msdc-02

From: <[email-masked]>
Date: Tue, 21 Feb 2017 09:50:52 +0000

Hello Working Group,

This email starts a 2-week Working Group Last Call on draft-ietf-spring-segment-routing-msdc-02 [1].

Please read the document if you haven't read the most recent version yet, and send your comments to the list, no later than the *7th of March*.

Note that this is *not only* a call for comments on the document; it is also a call for support (or not) to publish this document as an Informational RFC.

We have already polled for IPR knowledge on this document and all Authors have replied.

No IPR has been disclosed [2].

Thank you

M&B

[1] https://tools.ietf.org/html/draft-ietf-spring-segment-routing-msdc-02
[2] https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-spring-segment-routing-msdc

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Tue, 21 Feb 2017 15:02:50 +0000

as co-author, I support the publication of this draft.

Thanks.
s.

> On Feb 21, 2017, at 10:50 AM, [email-masked] wrote:
> 
> Hello Working Group,
>  
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: <[email-masked]>
Date: Tue, 21 Feb 2017 15:37:26 +0000

Hi authors,

As the document shepherd, I have reviewed the document and have the following comments.

Thanks,
Regards,
Bruno

======================================
Major comment:
======================================
- Section 12 (Manageability) is empty ("TBD")
- Section 13 (Security) is empty ("TBD")

======================================
Minor Comment:
======================================
- Section 11 (IANA) is empty ("TBD")
- I-D.ietf-spring-segment-routing should probably be a normative reference

---
§1
Term "middle stage" is used twice but is not defined. May be replacing it with the terms Tier-x which are defined.

---
§4.1

---
"all the nodes are allocated the same SRGB"
Please expand SRGB on first use, and provides a reference ([I-D.ietf-spring-segment-routing])

---
§4.2.1
"BGP-Prefix Attribute"
The name of the BGP attribute is "BGP Prefix-SID" and the TLV hosting the index is "Label-Index"

---
§4.2.1

"Then, Node10 sends the following eBGP3107 update to Node7:

   . NLRI:  192.0.2.11/32
   . Label: 16011"

As per RFC 3107, the NLRI is both the IP prefix and the label. Hence, proposed
:s/NLRI/Prefix
or :s/NLRI/IP Prefix

(RFC 3107 uses the term "Prefix" but IMHO it implies "IP Prefix")

---
§4.2.1

OLD: it should allocate the label LOCAL-SRGB (16000) + "index" 11 (hence 16011)
"LOCAL-SRGB" is undefined. I would suggest
NEW: it should allocate the label from its own SRGB block, offset by the index received in the BGP Prefix-SID attribute. (16000+11 hence 16011)

---
§7.3 seems very similar to me than §7.2. e.g.

§7.2:
"  One particularly interesting instance of performance-aware routing is
   dynamic fault-avoidance.  If some links or devices in the network
   start discarding packets due to a fault, the end-hosts could detect
   the path(s) being affected and steer their flows away from the
   problem spot.  Similar logic applies to failure cases where packets
   get completely black-holed, e.g. when a link goes down."

§7.3
"if in the topology depicted on
   Figure 1 a link between spine switch Node5 and leaf node Node9 fails,
   HostA may exclude the segment corresponding to Node5 from the prefix
   matching the servers under Tier-2 devices Node9."

May be §7.3 should be removed or rephrased to better differentiate its content compared to §7.2

---
§8.1
"The Prefix Segment is a lightweight extension to BGP Labelled Unicast"
"Prefix Segment" is loosely (un)defined. draft-ietf-idr-bgp-prefix-sid-04 uses the term "BGP-Prefix-SID" or "BGP-Prefix-SID Attribute"

Please make a consistent use of the right term in the whole document.

---
"Common SRGB"
The call for a common SRGB is duplicated in section 4.1, 4.2 and 8.1. Please remove the duplicated text. (e.g. moving all related text to 8.1)

---
"§8 Additional Benefits
[...]
§8.4 Incremental Deployments
As explained in Section 4.2.5, this design can be deployed incrementally."

As the incremental benefit is already discussed at length in §4.2.5 there is no need to create a one line section 8.4 as this is not an _additional_ benefit.

So either removing §8.4 or moving §4.2.5 to 8.4.

---
§10
:/BGP Prefix SID attribute/BGP Prefix-SID attribute

Plus may be adding the reference to the IDR document.

:/ORIGINATOR_SRGB TLV/Originator SRGB TLV

---
§10
"   Specifically, the ORIGINATOR_SRGB TLV in the BGP Prefix SID signals
   the SRGB of the switch that originated the BGP Prefix Segment.

   This allows to determine the local label allocated by any switch for
   any BGP Prefix Segment, despite the lack of a consistent unique SRGB
   in the domain."

The above text is not clear enough for me to understand why and how the ORIGINATOR_SRGB is used.
I find the text in the IDR draft a little more clear. "It is used to build SRTE policies when different
   SRGB's are used in the fabric ([I-D.ietf-spring-segment-routing-msdc])." Which is a pity given that the IDR draft refers to the SPRING draft for the reason and the use.

So please rephrase/elaborate.

On a side note, I would not call this node a "switch" which for me is a layer 2 devices (e.g. Ethernet). I'd rather use the term router or LSR (or (egress) LER)

And I fail see the relation with the title "Alternative options"

======================================
Nits:
======================================
In figure 1 and 2, Node10 diagram outrun the box. :s/ 10  |/10  |

---
"In other words, per-flow ECMP that does not perform efficiently when flow life-time distribution is heavy-tailed."

may be :s/that does/does

---
"Referring to Figure 1Referring to Figure 1"

duplicated.

---
"In the MPLS case, we do not recommend to use different SRGBs at each node."
May be avoiding (double) negation when positive statement is meant . e.g. NEW: In the MPLS case, we do recommend to use same SRGBs at each node

From: spring [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 21, 2017 10:51 AM
To: [email-masked]
Subject: [spring] WG Last Call for draft-ietf-spring-segment-routing-msdc-02

Hello Working Group,

Thank you

M&B

Thank you.

---

From: <[email-masked]>
Date: Wed, 22 Feb 2017 13:00:17 +0000

Please find below some additional points

1)      "Abstract

   This document describes the motivation and benefits for applying
   segment routing in the data-center.  It describes the design to
   deploy segment routing in the data-center, for both the MPLS and IPv6
   dataplanes. »

It looks to me that this document is limited to BGP-based large-scale data-center  (DC) design described in [RFC7938].
So may be
:s/ the data-center./ BGP-based large-scale data-center.
:s/ in the data-center,/ in those data-center,

2)      For the document write up, are there any known deployment of draft-ietf-spring-segment-routing-msdc?

3)      § 2.1.  Reference design

"   o  Each node is its own AS (Node X has AS X)

      *  For simple and efficient route propagation filtering, Nodes 5,
         6, 7 and 8 share the same AS, Nodes 3 and 4 share the same AS,
         Nodes 9 and 10 share the same AS.

      *  For efficient usage of the scarce 2-byte Private Use AS pool,
         different Tier-3 nodes might share the same AS.

      *  Without loss of generality, we will simplify these details in
         this document and assume that each node has its own AS."

First 2 bullets are contradicting each other's.
Please update/rephrase as needed.

4)         [I-D.ietf-idr-bgp-prefix-sid] could be seen as a normative document. IDR WG is also initiating the WG last call, hence both document could progress together.

Thanks,
Regards,
Bruno

From: spring [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 21, 2017 4:37 PM
To: [email-masked]
Subject: Re: [spring] WG Last Call for draft-ietf-spring-segment-routing-msdc-02

Hi authors,

Thanks,
Regards,
Bruno

---
§1

---
§4.1

---

---
§4.2.1
"BGP-Prefix Attribute"

---
§4.2.1

   . NLRI:  192.0.2.11/32
   . Label: 16011"

---
§4.2.1

---

§7.2:

§7.3

---
§8.1

---
"Common SRGB"

---
"§8 Additional Benefits
[...]

---
§10

---
§10

---

may be :s/that does/does

---

duplicated.

---

From: spring [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Tuesday, February 21, 2017 10:51 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [spring] WG Last Call for draft-ietf-spring-segment-routing-msdc-02

Hello Working Group,

Thank you

M&B

Thank you.

Thank you.

---

From: Mohan Nanduri <[email-masked]>
Date: Mon, 27 Feb 2017 00:33:01 -0500

Support the publication of this draft.

Cheers,
-Mohan

On Tue, Feb 21, 2017 at 4:50 AM,  <[email-masked]> wrote:
> Hello Working Group,
>
>
>
> This email starts a 2-week Working Group Last Call on
> draft-ietf-spring-segment-routing-msdc-02 [1].
>
>
>
> Please read the document if you haven't read the most recent version yet,
> and send your comments to the list, no later than the *7th of March*.
>
> Note that this is *not only* a call for comments on the document; it is also
> a call for support (or not) to publish this document as an Informational
> RFC.
>
>
>
> [2]
> https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-spring-segment-routing-msdc
>
>
>
>
>
>
>
>
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu
> ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Tue, 28 Feb 2017 09:16:07 +0000

Hi Bruno,

thanks for the review. I integrated all the comments in the new version I’m going to submit very soon.

One last comment here below:

> On Feb 22, 2017, at 2:00 PM, [email-masked] wrote:
>  
> “   o  Each node is its own AS (Node X has AS X)
>  
>          this document and assume that each node has its own AS.”
>  
>  
> First 2 bullets are contradicting each other’s.

why so ? First bullet refers to tier-1 and tier-2. second bullet refers to tier-3.

thanks.
s.

---

From: Anoop Ghanwani <[email-masked]>
Date: Tue, 28 Feb 2017 11:29:41 -0800

I support publication of the document as an informational RFC.

Below are my comments.

Thanks,
Anoop

==

- pg 5, line 1
  What is the criteria that allow sharing the AS number?  Is there a
reference?

- pg 6
  "This means that every new connection will be established
   obliviously (memory- less) with regards to the paths chosen
    before, or chosen by other nodes."
  I am not sure what "chosen by other nodes" adds.  I think it
  can be removed.

- pg 7
  "local label 1600x" -> "local label (16000 + x).
  Also because of the way loopbacks are assigned, does this mean that the
number nodes that this scheme can handle is 512?  May be good to mention
why this is considered a good number.

- pg 11
  "BGP Prefix Segment 16011 then directs the packet down to Node11 along
the path (Node5, Node9, Node11)."
  I think it would be worth mentioning that node 9 need not appear in this
path.  In general, because of the nature of clos topologies, there is no
need to have intermediate nodes between the spine and the ToR on the way
down.  (If there is, it would be good to know why.)

Editorial

- some inconsistencies throughout.  would be good to make them consistent.
  Node1 and Node2 vs Nodes 1 and 2 vs "Node1" and "Node2"
  data center, data-center, DC

- Spell out SRGB and AIGP at first use.

- pg 1
  "use-case use-cases" -> use-cases

- pg 5
  "via BGP session" -> "via a BGP session."  (missing 'a' and period.)
  "address of it's loopback" -> "address of its loopback"
  "per-flow ECMP that does not" -> "per-flow ECMP does not"
  "placed on one path over others" ->  "placed on one path over others."
 (missing period)
  " implements oblivious" -> "implements an oblivious"

- pg 6
  "Absence of path visibility" -> "The absence of path visibility"

- pg 7
  "Figure 2 zooms on" -> "Figure 2 zooms in on"

- pg 8
  "an nondeterministic label" -> "a non-deterministic label"

- pg 9
  "Referring to Figure 1Referring to Figure 1" -> "Referring to Figure 1"

- pg 11
  "if Node7 does not support" -> "even though Node7 does not support"

- p12
  Missing a period at the end of the first and second items in Sec 4.3.
  "Attribute adverting" -> "Attribute advertising"

- pg 14
  "let us illustrate this assuming" -> "let us illustrate this concept
assuming"
  "flow to Z" -> "flow to HostZ"
  "assuming A is made aware" -> "assuming HostA is made aware"

- pg 15
  "the latter one" -> "the last one"

- pg 16
  "monitoring network elements health" -> "monitoring network elements'
health"
  "inSection 7.2" -> "in Section 7.2"
  "BGP Labelled Unicast" -> "BGP Labeled Unicast"  (also on pg 17)

- pg 18
  "thanks to PHP" -> "because of PHP"
  "Internet- scale" -> "Internet-scale"  (extra space)
  "go-to-the- Internet" -> "go-to-the-Internet"
  " do not recommend to use" -> "do not recommend using"
  "operation viewpoint" -> "operational viewpoint"

- pg 19
  "allows to construct" -> "allows us to construct"
  "Spine5 and Spine 8" -> Node5 and Node8
  "(e.g. ToR1's SRGB is [1000, 1999], ToR2's SRGB is [2000, 2999]...)." ->
  "(e.g. ToR1's SRGB is [1000, 1999], ToR2's SRGB is [2000, 2999], ...)." ->