Subject: [spring] A question regarding mode of SR/LDP interop

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 23 Feb 2017 13:45:12 +0000

Hi all,
I would like to point to what looks to me as inconsistency between the current (-05) version of the SR YANG Data Model draft<https://datatracker.ietf.org/doc/draft-ietf-spring-sr-yang/?include_text=1> and the latest (-06) version of the Segment Routing Interop with LDP draft<https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-ldp-interop/?include_text=1>.

The following text has been added to the latter:

  Section 2 describes the co-existence of SR with other MPLS Control
   Plane.  Section 3 documents a method to migrate from LDP to SR-based
   MPLS tunneling.  Section 4 documents the interworking between SR and
   LDP in the case of non-homogeneous deployment.  Section 5 describes
   how a partial SR deployment can be used to provide SR benefits to
   LDP-based traffic including a possible application of SR in the
   context of inter-domain MPLS use-cases.

   Typically, an implementation will allow an operator to select
   (through configuration) which of the described modes of SR and LDP
   co-existence to use.

To the best of my understanding, there is no match for the highlighted configuration parameter in the former document.
(This is expected since such a parameter has not been mentioned in the previous (-05) version of the former).

I hope the next version of the YANG Model draft will take care of that.

Regards, and lots of thanks in advance,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Thu, 23 Feb 2017 14:17:16 +0000

> On Feb 23, 2017, at 2:45 PM, Alexander Vainshtein <[email-masked]> wrote:
> 
> Hi all,
> I would like to point to what looks to me as inconsistency between the current (-05) version of the SR YANG Data Model draft and the latest (-06) version of the Segment Routing Interop with LDP draft.
>  

well, from an SR perspective, “through configuration” is not limited to YANG...

s.

> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 23 Feb 2017 14:42:15 +0000

Stefano,
I respectfully disagree. 

From my POV YANG data models (same as MIBs before them) are supposed to provide a comprehensive list of configurable parameters that impact operation of a protocol within the limits defined by the corresponding protocol spec.

My 2c,
Sasha

Office: +972-39266302
Cell:      +972-549266302

-----Original Message-----
From: Stefano Previdi (sprevidi) [mailto:[email-masked]] 
Sent: Thursday, February 23, 2017 4:17 PM
To: Alexander Vainshtein <[email-masked]>
Cc: [email-masked]; [email-masked]; Michael Gorokhovsky <[email-masked]>
Subject: Re: [spring] A question regarding mode of SR/LDP interop

s.

> Regards, and lots of thanks in advance, Sasha
>  
> Office: +972-39266302
> Cell:      +972-549266302

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Thu, 23 Feb 2017 14:52:45 +0000

Sasha,

> On Feb 23, 2017, at 3:42 PM, Alexander Vainshtein <[email-masked]> wrote:
> 
> Stefano,
> I respectfully disagree. 
> 

Far be it from me to question yang benefits... ;-)

it’s just that, from a protocol definition perspective, I won’t assume a given choice for management/configuration so that people can then chose snmp-mibs, yang or whatever comes next.

Where I agree with you is on the need for yang models to support the sr/ldp interop if the target is to be yang-capable on all aspects of protocol implementations.

s.

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 23 Feb 2017 14:58:46 +0000

Stefano,
Lots of thanks for a prompt response.

Looks as actually we are in sync. I just hope that the authors of the YANG Model draft will be in sync with us as well.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

-----Original Message-----
From: Stefano Previdi (sprevidi) [mailto:[email-masked]] 
Sent: Thursday, February 23, 2017 4:53 PM
To: Alexander Vainshtein <[email-masked]>
Cc: [email-masked]; [email-masked]; Michael Gorokhovsky <[email-masked]>
Subject: Re: [spring] A question regarding mode of SR/LDP interop

Sasha,

s.

> Cc: [email-masked]; [email-masked]; Michael 
> Gorokhovsky <[email-masked]>