Subject: [spring] IDR WG 2 week WG LC on draft-ietf-idr-bgpls-segment-routing-epe - (2/15/2017 to 3/1/2017)

From: "Susan Hares" <[email-masked]>
Date: Wed, 15 Feb 2017 18:34:44 -0500

This begins a 2 week IDR WG last call on
draft-ietf-idr-bgpls-segment-routing-epe from (2/15 to 3/1/2017)    There
are two implementations describe on the wiki at: 

https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgpls-segment-routing-epe
%20

The two implementation are from  Cisco IOS-XR release 6.0.2 and Cisco Nexus
Switch N9000/N3000 platforms running NX-OS 7.0(3)I1(1) or greater.   The
authors will indicate on the list and in the wiki the following information
:

1)      Were these implementations separate implementations? 

2)      What were the results of the interoperability tests? 

This work is linked to the draft-ietf-spring-segment-routing-central-epe
work in the SPRING WG. Based on the two drafts, the WG should might
consider:  

1)      Is there need for this work in deployments in networks/ 

2)      Is this technically ready for publication? 

3)      Does it fit with the spring informational draft? 

For the ease of reference the web references are below: 

https://datatracker.ietf.org/doc/draft-ietf-idr-bgpls-segment-routing-epe/

https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-central-e
pe/

Sue Hares

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 16 Feb 2017 11:06:53 +0000

Yes/support

Regards,
Jeff

> On Feb 15, 2017, at 23:34, Susan Hares <[email-masked]> wrote:
> 
> This begins a 2 week IDR WG last call on draft-ietf-idr-bgpls-segment-routing-epe from (2/15 to 3/1/2017)    There are two implementations describe on the wiki at:
> https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgpls-segment-routing-epe%20
>  
> The two implementation are from  Cisco IOS-XR release 6.0.2 and Cisco Nexus Switch N9000/N3000 platforms running NX-OS 7.0(3)I1(1) or greater.   The authors will indicate on the list and in the wiki the following information :
>  
> This work is linked to the draft-ietf-spring-segment-routing-central-epe work in the SPRING WG. Based on the two drafts, the WG should might consider:  
> https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-central-epe/
>  
> Sue Hares
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Thu, 16 Feb 2017 11:30:38 +0000

> On Feb 16, 2017, at 12:34 AM, Susan Hares <[email-masked]> wrote:
> 

yes.

> 2)      What were the results of the interoperability tests? 

the two implementations are interoperable on the set of features they support. See https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgpls-segment-routing-epe%20 for details.

> 1)      Is there need for this work in deployments in networks/ 

yes. This work has been triggered after several operators requirements for egress traffic engineering.

> 2)      Is this technically ready for publication? 

the authors believe so.

> 3)      Does it fit with the spring informational draft? 

yes. The use-case draft describing EPE (draft-ietf-spring-segment-routing-central-epe) has been adopted as WG doc in SPRING and it started the shepherd review.

Thanks.
s.

---

From: "Ketan Jivan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 16 Feb 2017 11:34:02 +0000

Support this draft.

Thanks,
Ketan

From: spring [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: 16 February 2017 05:05
To: [email-masked]
Cc: Alvaro Retana (aretana) <[email-masked]>; [email-masked]
Subject: [spring] IDR WG 2 week WG LC on draft-ietf-idr-bgpls-segment-routing-epe - (2/15/2017 to 3/1/2017)

Sue Hares

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 16 Feb 2017 13:39:44 +0100

Support.

Thx
R.

On Feb 15, 2017 6:39 PM, "Susan Hares" <[email-masked]> wrote:

> This begins a 2 week IDR WG last call on draft-ietf-idr-bgpls-segment-routing-epe
> from (2/15 to 3/1/2017)    There are two implementations describe on the
> wiki at:
>
> The two implementation are from  Cisco IOS-XR release 6.0.2 and Cisco
> Nexus Switch N9000/N3000 platforms running NX-OS 7.0(3)I1(1) or greater.
> The authors will indicate on the list and in the wiki the following
> information :
>
>
>

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Thu, 16 Feb 2017 13:28:54 +0000

Hi:

I've reviewed this document and believe it is ready for publication.

Thanks

Regards … Zafar

From: Idr <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Wednesday, February 15, 2017 at 6:34 PM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Idr] IDR WG 2 week WG LC on draft-ietf-idr-bgpls-segment-routing-epe - (2/15/2017 to 3/1/2017)

Sue Hares

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 16 Feb 2017 14:02:33 +0000

Support as a contributor.
Thanks,
Acee

From: spring <[email-masked]<mailto:[email-masked]>> on behalf of Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, February 15, 2017 at 6:34 PM
To: IDR List <[email-masked]<mailto:[email-masked]>>
Cc: "Alvaro Retana (aretana)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [spring] IDR WG 2 week WG LC on draft-ietf-idr-bgpls-segment-routing-epe - (2/15/2017 to 3/1/2017)

Sue Hares

---

From: "Gaurav Dawra (gdawra)" <[email-masked]>
Date: Thu, 16 Feb 2017 15:39:39 +0000

Support.

Regards,

-Gaurav

From: spring <[email-masked]<mailto:[email-masked]>> on behalf of Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Date: Thursday, February 16, 2017 at 4:39 AM
To: Susan Hares <[email-masked]<mailto:[email-masked]>>
Cc: idr wg <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Alvaro Retana (aretana)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] IDR WG 2 week WG LC on draft-ietf-idr-bgpls-segment-routing-epe - (2/15/2017 to 3/1/2017)

Support.

Thx
R.

On Feb 15, 2017 6:39 PM, "Susan Hares" <[email-masked]<mailto:[email-masked]>> wrote:
This begins a 2 week IDR WG last call on draft-ietf-idr-bgpls-segment-routing-epe from (2/15 to 3/1/2017)    There are two implementations describe on the wiki at:
https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgpls-segment-routing-epe%20

Sue Hares

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring

---

From: <[email-masked]>
Date: Thu, 16 Feb 2017 16:50:05 +0000

Hi,

I've read the draft, please find below some minor comments:

---
§4.3
"      *  A 4 octet index defining the offset in the SID/Label space advertised by this router using the encodings defined in  Section 3.1."

- Following the recent addition of the SRLB Label Space, I'd rather have the text explicitly refers to name of that Label space. e.g.
OLD: SID/Label space
NEW: SRGB

- Which (SRGB) advertisement? I'm assuming the IGP one, but I guess someone may imagine using the BGP "Originator SRGB TLV". Then what if the node runs multiple IGP with different SRGB configured?

- Note that this document has no "Section 3.1". The text seems borrowed from the IS-IS SR draft, hence may be adding the name of this draft would just solve the point. (with a normative reference to this IS-IS draft)

---
OLD: The Link NLRI uses the new Protocol-ID value (to be assigned by IANA)
proposed NEW: The Link NLRI uses the BGP Protocol-ID (TBD1)

("new" may become unspecific 2 years from now)

---
One could probably argue that [I-D.ietf-spring-segment-routing] should be a normative reference.

Thanks,
Regards,
--Bruno

From: spring [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, February 16, 2017 12:35 AM
To: [email-masked]
Cc: 'Alvaro Retana (aretana)'; [email-masked]
Subject: [spring] IDR WG 2 week WG LC on draft-ietf-idr-bgpls-segment-routing-epe - (2/15/2017 to 3/1/2017)

Sue Hares

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Miya Kohno <[email-masked]>
Date: Fri, 17 Feb 2017 15:56:47 +0900

I support this draft.

Thanks!
Miya Kohno

---

From: "Van De Velde, Gunter (Nokia - BE)" <[email-masked]>
Date: Fri, 17 Feb 2017 08:05:09 +0000

I read the paper and Yep I support

G/

From: Idr <[email-masked]> on behalf of Jeff Tantsura <[email-masked]>
Date: Thursday, 16 February 2017 at 12:06
To: Susan Hares <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [ALU] Re: [Idr] [spring] IDR WG 2 week WG LC ondraft-ietf-idr-bgpls-segment-routing-epe - (2/15/2017 to 3/1/2017)

Yes/support

Regards,
Jeff

On Feb 15, 2017, at 23:34, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote:
This begins a 2 week IDR WG last call on draft-ietf-idr-bgpls-segment-routing-epe from (2/15 to 3/1/2017)    There are two implementations describe on the wiki at:
https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgpls-segment-routing-epe%20

Sue Hares

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Fri, 17 Feb 2017 08:21:57 +0000

Fully support, yes.

Best Regards Bertrand Duvivier

BD> YES

BD > WORKING

Sue Hares

---

From: Giles Heron <[email-masked]>
Date: Fri, 17 Feb 2017 14:27:44 +0000

Likewise.

And it’s worth noting that OpenDaylight has an open-source implementation of the draft, and interops ok with IOS XR.  I may get around to testing interop with NX-OS also.

Giles

> On 17 Feb 2017, at 08:21, Bertrand Duvivier (bduvivie) <[email-masked]> wrote:
> 
> Fully support, yes. 
> 
> On Feb 15, 2017, at 23:34, Susan Hares <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgpls-segment-routing-epe%20 <https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgpls-segment-routing-epe%20>
>>  
>> https://datatracker.ietf.org/doc/draft-ietf-idr-bgpls-segment-routing-epe/ <https://datatracker.ietf.org/doc/draft-ietf-idr-bgpls-segment-routing-epe/>
>> https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-central-epe/ <https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-central-epe/>
>>  
>> Sue Hares 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/spring <https://www.ietf.org/mailman/listinfo/spring>_______________________________________________
> spring mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/spring <https://www.ietf.org/mailman/listinfo/spring>

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 20 Feb 2017 19:01:27 -0500

Giles: 

It would be helpful to fill out the wiki on the “SHOULD, MAY and MUSTs”.   If it is easier, you can just send me the answers and I will post it. 

Sue 

From: Giles Heron [mailto:[email-masked]] 
Sent: Friday, February 17, 2017 9:28 AM
To: Bertrand Duvivier (bduvivie)
Cc: Van De Velde, Gunter (Nokia - BE); Susan Hares; [email-masked]; [email-masked]
Subject: Re: [spring] [Idr] [ALU] Re: IDR WG 2 week WG LC ondraft-ietf-idr-bgpls-segment-routing-epe - (2/15/2017 to 3/1/2017)

Likewise.

Giles

Fully support, yes. 

On Feb 15, 2017, at 23:34, Susan Hares < <mailto:[email-masked]> [email-masked]> wrote:

 <https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgpls-segment-routing-epe%20> https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgpls-segment-routing-epe%20

BD> YES 

BD > WORKING

 <https://datatracker.ietf.org/doc/draft-ietf-idr-bgpls-segment-routing-epe/> https://datatracker.ietf.org/doc/draft-ietf-idr-bgpls-segment-routing-epe/

 <https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-central-epe/> https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-central-epe/

Sue Hares 

_______________________________________________
spring mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/spring> https://www.ietf.org/mailman/listinfo/spring

_______________________________________________
spring mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/spring> https://www.ietf.org/mailman/listinfo/spring

---

From: Mohan Nanduri <[email-masked]>
Date: Mon, 27 Feb 2017 00:35:07 -0500

Support the publication of this draft.

Cheers,
-Mohan