Subject: [Secdispatch] addressing Content-Type-Encoding errata on EST / RFC7030

From: Michael Richardson <[email-masked]>
Date: Wed, 19 Jun 2019 09:38:34 -0400

Dear secdispatch Chairs,

I have written draft-richardson-lamps-rfc7030est-clarify-02 to deal with
the errata:
   https://www.rfc-editor.org/errata/eid5107

it turns out that deployed code prevents us from having a signal that
would let us remove the needless base64 encoding, but at least we can
remove the deprecated CTE header which was not being used anyway.

I believe that we can deal with:
    https://www.rfc-editor.org/errata/eid4384
    https://www.rfc-editor.org/errata/eid5108

in this document as well, although I haven't yet done that.  The result would
be a standards track document that Updates RFC7030.

As an aside, I think that the errata needs to move from reported to accepted.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Eliot Lear <[email-masked]>
Date: Wed, 19 Jun 2019 15:50:05 +0200

I will just add that if we’re doing a correction, one other possibility would be to add new restless endpoints that are the same as the old ones but deal with encoding correctly, and then deprecate the old endpoints.

Eliot

> On 19 Jun 2019, at 15:38, Michael Richardson <[email-masked]> wrote:
> 
> Signed PGP part
> 
> Dear secdispatch Chairs,
>

---

From: Eliot Lear <[email-masked]>
Date: Wed, 19 Jun 2019 16:01:35 +0200

> On 19 Jun 2019, at 15:50, Eliot Lear <[email-masked]> wrote:
> 
> Signed PGP part

Erm.

> I will just add that if we’re doing a correction, one other possibility would be to add new restless endpoints

I was autoINcorrected.  That should be RESTful.

> that are the same as the old ones but deal with encoding correctly, and then deprecate the old endpoints.
> 
> Eliot
>