Subject: Re: [Secdispatch] EDHOC Summary

From: Mališa Vučinić <[email-masked]>
Date: Mon, 1 Apr 2019 11:58:52 +0200

+1

We are happy to contribute to this effort through feedback on the design, implementation for constrained devices and its evaluation in 6TiSCH networks.

Mališa

> On 30 Mar 2019, at 18:31, Thomas Watteyne <[email-masked]> wrote:
> 
> The 6TiSCH WG has produced a set of documents [1,2] that specify the use of OSCORE to secure message exchanges at the application layer including network access. At the side meeting in Prague two years ago involving several ADs and WG chairs, the 6TiSCH chairs have indicated the need for an efficient authenticated key exchange protocol that we could use during the network access to key OSCORE. We have also restated this request at the SECDISPATCH interim a couple of weeks ago.
> 
> The EDHOC specification was discussed on numerous occasions during the 6TiSCH working group meetings and the approach on using it for the extension of [1] towards zero-touch [3] deployments had a wide consensus. We welcome the work in this area to be done, and strongly support any decision of the security ADs that leads to the fast progress of this specification.
> 
> [1] https://datatracker.ietf.org/doc/draft-ietf-6tisch-minimal-security/ <https://datatracker.ietf.org/doc/draft-ietf-6tisch-minimal-security/> 
> [2] https://datatracker.ietf.org/doc/draft-ietf-6tisch-architecture/ <https://datatracker.ietf.org/doc/draft-ietf-6tisch-architecture/>
> [3] https://datatracker.ietf.org/doc/draft-ietf-6tisch-dtsecurity-zerotouch-join/ <https://datatracker.ietf.org/doc/draft-ietf-6tisch-dtsecurity-zerotouch-join/> 
> 
> _______________________________________________
> Secdispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secdispatch

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 1 Apr 2019 12:05:39 +0000

Since I had the discussion privately, minimal security and edhoc were discussed at 6TiSCH at pretty much every meeting, plenary or interim, since around IETF 97.

The minutes for an IETF are located in https://datatracker.ietf.org/doc/minutes-xx-6tisch/ where xx is the IETF number.
See for instance IETF 98 https://datatracker.ietf.org/doc/minutes-98-6tisch/; one can also google https://www.google.com/search?client=firefox-b-d&q=6tisch+minutes+edhoc
There was also a side meeting at IETF 103, all reported in the minutes https://bitbucket.org/6tisch/meetings/wiki/181108_ietf103_bangkok

One may also consult the minutes from the 6TiSCH WiKi  https://bitbucket.org/6tisch/meetings/wiki/browse/ where all are stored since inception of the WG.

All the best,

Pascal

From: Mališa Vučinić <[email-masked]>
Sent: lundi 1 avril 2019 11:59
To: Thomas Watteyne <[email-masked]>
Cc: [email-masked]; 6tisch <[email-masked]>; 6tisch-chairs <[email-masked]>
Subject: Re: [Secdispatch] EDHOC Summary

+1

Mališa

On 30 Mar 2019, at 18:31, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:

[1] https://datatracker.ietf.org/doc/draft-ietf-6tisch-minimal-security/
[2] https://datatracker.ietf.org/doc/draft-ietf-6tisch-architecture/
[3] https://datatracker.ietf.org/doc/draft-ietf-6tisch-dtsecurity-zerotouch-join/

_______________________________________________
Secdispatch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/secdispatch