Subject: Re: [Secdispatch] draft-selander-lake-reqs-00: SDOs

From: Göran Selander <[email-masked]>
Date: Thu, 18 Apr 2019 12:12:18 +0000

Hi Hannes,

On 2019-04-18, 13:04, "Secdispatch on behalf of Hannes Tschofenig" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Goeran, 
     
    I am not a big fan of motivating work by referencing to other SDOs
 
[GS] Fine, there are IETF internal references of OSCORE too.
     
Why? Because it is largely a forum shopping activity..

People from other SDOs have been encouraging us to add desired features (Open Connectivity Foundation) and offered help to progress (Fairhair Alliance). 

Others on the list may not know that you brought OSCORE to the OMA / LwM2M v1.1 specification. It is an optional feature. You wrote that part of the specification, if I recall correctly.

[GS] Correct. Like EST-CoAPs is a feature you have been driving in both IETF and OMA / LwM2M v1.1. 
     
       o  LwM2M version 1.1 [LwM2M <https://tools.ietf.org/html/draft-selander-lake-reqs-00#ref-LwM2M>].  LwM2M v1.1 defines bindings to two      challenging radio technologies where OSCORE will be deployed:      LoRaWAN and NB-IoT.    
    Regarding “… where OSCORE will be deployed”: Just because you add an optional feature to a specification does not get it deployed.

[GS] I am aware of companies investing in OSCORE for the purpose of deploying it with LwM2M over NB-IoT or LoRaWAN.

Göran

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 18 Apr 2019 12:30:24 +0000

Hi Goeran,

~snip~

.... and it fits nicely into the strategy to re-use DTLS, which was for a long time the story for IoT in the IETF*.

The reference to EST-CoAPs is, however, beside the point I am trying to make. Telling others on the mailing list that there is so much demand when you created that demand by writing the spec in other organizations is a bit tricky.

Tell them we are using DTLS and it works fine. They can come and talk to us. Our code is even open source, Apache 2.0 license.

Ciao
Hannes

(*) From RFC 7452 "Smart Object Architectural Considerations"

"
  To simplify the development task, and thereby
   to lower the cost of developing new products and prototypes, we
   believe that reuse of prior work is essential.
"

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Göran Selander <[email-masked]>
Date: Thu, 18 Apr 2019 12:56:57 +0000

Hi Hannes,

On 2019-04-18, 14:31, "Secdispatch on behalf of Hannes Tschofenig" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Goeran,
    
    ~snip~

    

[GS] The demand is there independently of who put the text into the standard.

Göran